View Issue Details

IDProjectCategoryView StatusLast Update
0026338mantisbtsignuppublic2019-11-19 11:49
Reporterintervision Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.22.1 
Summary0026338: Wrong confirmation link for new users
Description

(first of all sorry for my english - not my native language)
When i create a new user he receive a wrong confirmation link that doesn't work

Steps To Reproduce
  1. Create a new account
  2. Set an email for it
  3. Check email
Additional Information

The email contains this code (i have removed some data from URLS):

<br />
https://___SITENAME___/verify.php?id=7&amp;confirm_hash=___HASH___<br />
<br />

So, as you can see, the link contains "&" code instead of "&" symbol;
And email contains HTML tags but received as plain text

TagsNo tags attached.

Relationships

related to 0025606 closeddregad EMail Verification Link Broken 

Activities

atrol

atrol

2019-11-09 04:16

developer   ~0063063

This is similar to 0025606
It's not caused by Mantis, see 0025606:0061709.
Maybe it's caued by a 3rd party plugin, your email client, or your email provider

intervision

intervision

2019-11-09 14:03

reporter   ~0063064

Last edited: 2019-11-09 14:06

View 2 revisions

but 0025606 was not resolved - there are no any solution, exept "we don't know what is it".

Maybe it's caued by a 3rd party plugin
As it was mentioned in 0025606 (and in my case too) this problem appears with clean mantis installation and continues with plugins or without them.

your email client
This issue appears in several different clients and with several users (actually with all of my users)

or your email provider
My provider is myself. I used exim+dovecot with standard configs and there were no problems with other software anytime, excpet this.

Maybe this problem needs deep research?
From my side i could provide any help and information if needed...

intervision

intervision

2019-11-09 14:04

reporter   ~0063065

Last edited: 2019-11-09 14:25

View 4 revisions

also linked with 0010088 0010369 0010401

atrol

atrol

2019-11-10 03:50

developer   ~0063066

Did you try what's been suggested at 0025606:0061719 ?

intervision

intervision

2019-11-11 03:59

reporter   ~0063069

I need a time to check, please don't close this issue...

intervision

intervision

2019-11-15 02:45

reporter   ~0063094

Last edited: 2019-11-15 04:11

View 2 revisions

I can't uderstand

https://github.com/mantisbt/mantisbt/blob/release-2.20.0/core/email_api.php#L537

Line 573 as sugested in https://www.mantisbt.org/bugs/view.php?id=25606#c61719 or line 537 as we can see on link?

Anyway my mail table is empty after i try to create a new user and emails still sent (and still in HTML instead of plain text)...

atrol

atrol

2019-11-16 09:41

developer   ~0063104

Line 537 is the right one.

atrol

atrol

2019-11-16 09:55

developer   ~0063105

Maybe you did not understand what was meant with remove the force-sending of signup e-mail
It means change
email_store( $t_email, $t_subject, $t_message, null, true );
to
email_store( $t_email, $t_subject, $t_message, null );

intervision

intervision

2019-11-16 22:42

reporter   ~0063106

Last edited: 2019-11-16 22:51

View 3 revisions

Пользователь XXXXX создал аккаунт для вас с именем пользователя &quot;XXXXX&quot;. Для завершения регистрации, перейдите по следующей ссылке (проверьте, чтобы ссылка была в одну строку, иначе она не сработает) и введите в соответствующие поля удобный для вас пароль доступа (будьте внимательны, пароль надо ввести в два поля):

https://XXXXX/verify.php?id=10&confirm_hash=XXXXX

Если вы не запрашивали никакой регистрации, проигнорируйте это сообщение, и ничего не произойдет.

НЕ ОТВЕЧАЙТЕ НА ЭТО СООБЩЕНИЕ 

There are HTML tags in emails table

atrol

atrol

2019-11-17 05:00

developer   ~0063108

Are you complete sure that you don't have installed any 3rd party plugins?

Please provide screen shots (with English language settings) of the plugins page and the settings of the MantisBT Formatting plugin.

intervision

intervision

2019-11-19 08:23

reporter   ~0063113

hm... i leave only official plugins but in plugins list i found bbcode plugin (don't know how can i miss it).
when i disable it - everything works as should.

Thank you for your pation and, i think, this information should be pinned somwhere...
Also i try to contact with developer of this plugin and inform about this issue.

dregad

dregad

2019-11-19 11:49

developer   ~0063114

Follow-up in BBCode+ plugin https://github.com/mantisbt-plugins/BBCodePlus/issues/89

Issue History

Date Modified Username Field Change
2019-11-08 19:37 intervision New Issue
2019-11-09 04:16 atrol Assigned To => atrol
2019-11-09 04:16 atrol Status new => resolved
2019-11-09 04:16 atrol Resolution open => unable to reproduce
2019-11-09 04:16 atrol Note Added: 0063063
2019-11-09 04:16 atrol Relationship added related to 0025606
2019-11-09 14:03 intervision Note Added: 0063064
2019-11-09 14:04 intervision Status resolved => feedback
2019-11-09 14:04 intervision Resolution unable to reproduce => reopened
2019-11-09 14:04 intervision Note Added: 0063065
2019-11-09 14:06 intervision Note Edited: 0063064 View Revisions
2019-11-09 14:12 intervision Note Edited: 0063065 View Revisions
2019-11-09 14:17 intervision Note Edited: 0063065 View Revisions
2019-11-09 14:25 intervision Note Edited: 0063065 View Revisions
2019-11-10 03:50 atrol Note Added: 0063066
2019-11-11 03:59 intervision Note Added: 0063069
2019-11-11 03:59 intervision Status feedback => assigned
2019-11-11 07:48 atrol Assigned To atrol =>
2019-11-11 07:48 atrol Status assigned => feedback
2019-11-15 02:45 intervision Note Added: 0063094
2019-11-15 02:45 intervision Status feedback => new
2019-11-15 04:11 intervision Note Edited: 0063094 View Revisions
2019-11-16 09:41 atrol Status new => feedback
2019-11-16 09:41 atrol Note Added: 0063104
2019-11-16 09:55 atrol Note Added: 0063105
2019-11-16 22:42 intervision Note Added: 0063106
2019-11-16 22:42 intervision Status feedback => new
2019-11-16 22:49 intervision Note Added: 0063107
2019-11-16 22:49 intervision File Added: mantis.png
2019-11-16 22:50 intervision Note Edited: 0063106 View Revisions
2019-11-16 22:51 intervision Note Edited: 0063106 View Revisions
2019-11-17 05:00 atrol Status new => feedback
2019-11-17 05:00 atrol Note Added: 0063108
2019-11-19 08:23 intervision Note Added: 0063113
2019-11-19 08:23 intervision Status feedback => new
2019-11-19 11:47 dregad Assigned To => atrol
2019-11-19 11:47 dregad Status new => resolved
2019-11-19 11:47 dregad Resolution reopened => no change required
2019-11-19 11:49 dregad Note Added: 0063114