View Issue Details

IDProjectCategoryView StatusLast Update
0026296mantisbtauthenticationpublic2019-11-17 08:32
Reporterkeessonnema Assigned Toatrol  
PriorityhighSeveritytweakReproducibilityN/A
Status closedResolutionduplicate 
Product Version2.22.1 
Summary0026296: Combine the login screens to create a 'normal' one-page login screen
Description

First of all I want to thank the team for listening to my previous ideas and giving their opinions about them.

Second, I would like to know what the reasoning behind two seperate looginscreens for username and password is. We're using a password-manager (Lastpass) and the seperate loginscreens just aren't convenient for us. I've read up on this on the internet and found a lot of people that share this exact same thought.

I wonder if it would be possible to change the loginscreen to a single page, or a way to create a plugin for it so that I can create my own login screen myself without hacking the core.

A single-page loginscreen is a very convenient way in this day and age with all sorts of password managers.

TagsNo tags attached.

Relationships

duplicate of 0023691 new New login UI is needlessly more complex and prevents use of password managers 

Activities

dregad

dregad

2019-10-28 06:13

developer   ~0063024

The 2-step login process was introduced to allow for 3rd party authentication via plugins. @vboctor authored this and can provide more information.

Issue History

Date Modified Username Field Change
2019-10-22 07:21 keessonnema New Issue
2019-11-01 09:01 atrol Assigned To => atrol
2019-11-01 09:01 atrol Status new => resolved
2019-11-01 09:01 atrol Resolution open => duplicate
2019-11-01 09:01 atrol Relationship added duplicate of 0023691
2019-11-17 08:32 atrol Status resolved => closed