View Issue Details

IDProjectCategoryView StatusLast Update
0026195mantisbtapi restpublic2019-09-27 05:46
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.23.0 
Target Version2.23.0Fixed in Version2.23.0 
Summary0026195: Error requesting issues using saved filter
Description

When the rest api is used to request issues matching an existing filter id, and that filter is saved for the user in a specific project, it returns an error.

For example,: A filter having id 9570 is saved in project 50:
http://../api/rest/issues?page_size=10&page=1&project_id=50&filter_id=9570
Fails

Reason, the rest api executes query in the context of ALL_PROJECTS, eventhough the specific project id is passed as parameter. The error is because that filter is not available in the ALL_PROJECTS context.

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master 5a9ea9bb

2019-09-26 07:58:41

cproensa


Committer: dregad Details Diff
Fix rest issues with project specific filter id

The current project must be set for correctly checking permissions and
retrieving the filter.

Fixes: 0026195
Affected Issues
0026195
mod - api/rest/restcore/issues_rest.php Diff File

Issue History

Date Modified Username Field Change
2019-09-26 07:57 cproensa New Issue
2019-09-26 07:57 cproensa Status new => assigned
2019-09-26 07:57 cproensa Assigned To => cproensa
2019-09-26 08:29 cproensa Note Added: 0062913
2019-09-27 05:38 dregad Changeset attached => MantisBT master 5a9ea9bb
2019-09-27 05:38 cproensa Status assigned => resolved
2019-09-27 05:38 cproensa Resolution open => fixed
2019-09-27 05:38 cproensa Fixed in Version => 2.23.0
2019-09-27 05:46 atrol Target Version => 2.23.0