View Issue Details

IDProjectCategoryView StatusLast Update
0026178mantisbtdb mysqlpublic2019-10-03 14:10
Reporteravr Assigned Toatrol  
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionno change required 
Product Version2.6.0 
Summary0026178: Missing bug_id
Description

Our ticket numbers are reaching 20000 and recently we mis-typed a ticket number in the 18000 range and found it did not exist.
I queried mantis_bug_history_table and it did not exist.

Doing "select distinct bug_id from mantis_bug_history_table order" shows that our max ticket# is about 500 more than this count.

Is there a reason certain bug_ids get skipped? I want to make sure we did not somehow miss tickets. Thank you.

TagsNo tags attached.

Activities

atrol

atrol

2019-09-23 14:19

developer   ~0062894

We use Mysql auto increment functionality to create the bug ids.
You might have deleted issues or there might have occured problems during insert.
https://stackoverflow.com/questions/17798835/auto-increment-skipping-numbers

avr,

This is not a bug or feature request for MantisBT. I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

avr

avr

2019-09-23 14:53

reporter   ~0062895

Understood, thank you.

Issue History

Date Modified Username Field Change
2019-09-23 12:42 avr New Issue
2019-09-23 14:19 atrol Assigned To => atrol
2019-09-23 14:19 atrol Status new => resolved
2019-09-23 14:19 atrol Resolution open => no change required
2019-09-23 14:19 atrol Note Added: 0062894
2019-09-23 14:53 avr Note Added: 0062895
2019-10-03 14:10 atrol Status resolved => closed