View Issue Details

IDProjectCategoryView StatusLast Update
0026152mantisbtuipublic2022-05-12 03:22
ReporterAnsgar Arbeiter Assigned Toatrol  
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionduplicate 
OSWindowsOS VersionWin 8.1 pro 64 
Product Version2.21.2 
Fixed in Version2.26.0 
Summary0026152: submitting new issue: inconsequent handling of unfilled fields
Description

fields category, summary and description have to be filled before you can submit a new issue.
for summary and description you get a "smart" hint pointing to the empty fields.
but for category you get an error message ("APPLICATION ERROR #11").
can it be the same handling for all mandatory fields?

for some browsers (or browser settings), the "back" button clears all field contents, and this can be very annoying
(especially if you made detailed descriptions)

TagsNo tags attached.
Attached Files
Submit_04.png (28,128 bytes)   
Submit_04.png (28,128 bytes)   
Submit_03.png (50,418 bytes)   
Submit_03.png (50,418 bytes)   
Submit_02.png (48,554 bytes)   
Submit_02.png (48,554 bytes)   
Submit_01.png (60,642 bytes)   
Submit_01.png (60,642 bytes)   

Relationships

duplicate of 0028618 resolveddregad Category empty but required does not prevent form submission on Firefox Windows and Safari 
has duplicate 0026198 closedatrol no javascript control for category in bug report page 

Activities

bbodnar

bbodnar

2021-10-18 04:02

reporter   ~0065930

Last edited: 2021-10-23 03:29

<del>@mantis-team: please consider also mandatory custom-fields when solving this issue. Browsers don't keep the form values reliably when navigating back, esp. if using attachements for a new ticket, the form-values get lost.</del>

Ignore this note, the HTML5-flag "required" is set correctly for custom fields in Mantis v2.21.1 and works.

atrol

atrol

2022-03-06 06:37

developer   ~0066334

Will be fixed in 2.26.0 see 0028618