View Issue Details

IDProjectCategoryView StatusLast Update
0025982mantisbtapi soappublic2019-08-08 17:09
ReporterRachu Assigned Todregad  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0025982: SOAP problem
Description

Hello everyone.

I have a problem with the treatment of using SOAP, handling version 1.2.19, and trying to access the url localhost / api / soap / mantisconnect.php? Wsdl is blank and soapui does not recognize the url, if I enter the address localhost / mantistest / api / soap / mantisconnect.wsdl it shows me the wsdl, and with SOAPUI it shows me the methods methods, but when using the method Login and enter the username and password I get no answer, it goes blank.
I use IIS, I don't know if I have to make any additional configuration to the server to allow me to operate the SOAP.

Thank you.

TagsNo tags attached.

Activities

dregad

dregad

2019-08-08 17:09

developer   ~0062536

First of all, please note that MantisBT 1.2 is no longer supported, since December 2016. Moreover, you're not even running the latest release in that branch (1.2.20). Please upgrade to 2.x if you intend to get support.

That being said, the problem you're describing sounds like a configuration issue, and not a bug in MantisBT. I am therefore resolving this issue as "no change required". Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

You are in any case not providing enough information about your configuration, and since I'm not familiar with SOAPUI I'm not sure what "method Login" means. Try this to run this code for a test (change values as appropriate) :

<?php
$s = new SoapClient('http://localhost/mantis/api/soap/mantisconnect.php?wsdl');
$u = 'administrator';
$p = 'root';
print_r($s->mc_login($u, $p));

Issue History

Date Modified Username Field Change
2019-08-08 16:09 Rachu New Issue
2019-08-08 17:09 dregad Assigned To => dregad
2019-08-08 17:09 dregad Status new => resolved
2019-08-08 17:09 dregad Resolution open => no change required
2019-08-08 17:09 dregad Note Added: 0062536