View Issue Details

IDProjectCategoryView StatusLast Update
0025737mantisbtmigrationpublic2019-05-19 16:54
Reporterimmae Assigned Toatrol  
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0025737: Impossible to use postgresql after upgrade
Description

After upgrade from mantisbt 2.11.1 to 2.21.0 mantisbt is unable to start:


APPLICATION ERROR 0000401

Database query failed. Error received from database was #-1: ERROR: invalid input syntax for integer: "TRUE" for the query: SELECT basename, priority, protected FROM mantis_plugin_table WHERE enabled=$1 ORDER BY priority DESC.
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.

The database schema didn’t change (apparently) between those versions: the upgrade only set database_version in mantis_config_table. Maybe some migrations were forgotten for postgresql?

TagsNo tags attached.

Activities

immae

immae

2019-05-06 07:43

reporter   ~0062028

Ok, it turns out I just paid the price of stubbornly migrating my database from mysql to postgresql, changing the columns from smallint to boolean solves the issue

Issue History

Date Modified Username Field Change
2019-05-06 07:11 immae New Issue
2019-05-06 07:43 immae Note Added: 0062028
2019-05-06 08:47 atrol Assigned To => atrol
2019-05-06 08:47 atrol Status new => resolved
2019-05-06 08:47 atrol Resolution open => no change required
2019-05-19 16:54 atrol Status resolved => closed