View Issue Details

IDProjectCategoryView StatusLast Update
0025724mantisbtemailpublic2019-05-20 12:33
Reportercamila luz Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0025724: mantis old tasks not sending email
Description

I have one user with old tasks, and when there are modifications this user don't recieve emails, but in the new tasks the user recieve the all the emails.
We made a lot of teste, change the email and nothing.

Thanks in advance.

TagsNo tags attached.

Activities

dregad

dregad

2019-05-03 10:55

developer   ~0062021

You can try to set $g_log_level = LOG_EMAIL_VERBOSE to get additional details about what is happening.

camila luz

camila luz

2019-05-03 15:21

reporter   ~0062023

When i set only LOG_EMAIL_VERBOSE nothing about the task i need apear, but when i set LOG_EMAIL_RECIPIENT i have this:

2019-05-03 15:10 -03 MAIL email_api.php:975 email_bugnote_add() Note ~44372 added to issue 0010554
2019-05-03 15:10 -03 RECIPIENT email_api.php:283 email_collect_recipients() Issue = 0010554, skip @U94 (reporter disabled)
2019-05-03 15:10 -03 RECIPIENT email_api.php:293 email_collect_recipients() Issue = 0010554, skip @U25 (handler disabled)
2019-05-03 15:10 -03 RECIPIENT email_api.php:347 email_collect_recipients() Issue = 0010554, skip @U10 (note author disabled)
2019-05-03 15:10 -03 RECIPIENT email_api.php:347 email_collect_recipients() Issue = 0010554, skip @U94 (note author disabled)
2019-05-03 15:10 -03 RECIPIENT email_api.php:347 email_collect_recipients() Issue = 0010554, skip @U25 (note author disabled)

Only this, no errors. Is there anything i can do to solve this?

dregad

dregad

2019-05-04 07:06

developer   ~0062025

The xxx disabled means that the users with ID 10, 25 and 94 decided not to receive notifications for new issue notes (E-mail on Note Added) in their user preferences. Definitely not a bug.

camila luz

camila luz

2019-05-06 07:59

reporter   ~0062029

these are the preferences for the user 94. What i need to change please?



94.PNG (88,279 bytes)
94.PNG (88,279 bytes)
camila luz

camila luz

2019-05-10 07:44

reporter   ~0062053

Is there anything i can do?

dregad

dregad

2019-05-10 11:10

developer   ~0062054

Sorry for not replying earlier.

Check your definition for notify_flags (in config_inc.php and also in your database), maybe you have specific settings that block these notifications.

camila luz

camila luz

2019-05-10 14:40

reporter   ~0062055

I dicovered the problem. i have a lot of projects, the configuration of one of then was wrong.
Thanks for the help

Issue History

Date Modified Username Field Change
2019-05-02 13:57 camila luz New Issue
2019-05-03 10:55 dregad Status new => feedback
2019-05-03 10:55 dregad Note Added: 0062021
2019-05-03 15:21 camila luz Note Added: 0062023
2019-05-03 15:21 camila luz Status feedback => new
2019-05-04 07:06 dregad Status new => feedback
2019-05-04 07:06 dregad Note Added: 0062025
2019-05-06 07:59 camila luz File Added: 94.PNG
2019-05-06 07:59 camila luz Note Added: 0062029
2019-05-06 07:59 camila luz Status feedback => new
2019-05-10 07:44 camila luz Note Added: 0062053
2019-05-10 11:10 dregad Status new => feedback
2019-05-10 11:10 dregad Note Added: 0062054
2019-05-10 14:40 camila luz Note Added: 0062055
2019-05-10 14:40 camila luz Status feedback => new
2019-05-10 15:30 atrol Assigned To => dregad
2019-05-10 15:30 atrol Status new => resolved
2019-05-10 15:30 atrol Resolution open => no change required
2019-05-20 12:33 atrol Status resolved => closed