View Issue Details

IDProjectCategoryView StatusLast Update
0025661mantisbtbugtrackerpublic2019-04-21 02:53
ReporterCoreKeeper Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.20.0 
Target Version2.20.1Fixed in Version2.20.1 
Summary0025661: Project versions disappear when set "obsolete"
Description

When I edit a project version, then activating the "obsolete" flag of a version, after the saving the project version disappears. It should be part of the project version list, showing the obsolete flag in the respective column. I cannot create another version of the same name, so it is not deleted, just not shown in the UI any more. It also is not returned using the soap api.

This behaviour is different from earlier mantis versions (e.g. 2.17.1).
I attached a video showing the problem.

TagsNo tags attached.

Activities

CoreKeeper

CoreKeeper

2019-03-28 07:14

reporter  

cproensa

cproensa

2019-03-28 18:59

developer   ~0061793

PR https://github.com/mantisbt/mantisbt/pull/1492

thE_iNviNciblE

thE_iNviNciblE

2019-04-11 20:34

reporter   ~0061905

cool with video, nice idea i have also a screencapture tool for work.

nice job @crpoensa

dregad

dregad

2019-04-18 06:18

developer   ~0061973

For the record, this is a regression introduced by MantisBT master 46c77ace

Related Changesets

MantisBT: master 46c77ace

2019-02-11 19:35:55

cproensa


Committer: vboctor Details Diff
Rewrite project versions cache

Rewrite `version_get_all_rows` so it doesn't perform db queries and rely
in `version_cache_array_rows`.

Rewrite `version_cache_array_rows`to clean up code and improve caching
for non existant projects (eg, ALL_PROJECTS), or projects with no
versions.

Both changes fixes
- A recurrent cache miss when ALL_PROJECT was part of the inheritance
projects scope in a query for versions for a project.
- A potentially wrong cached response for project versions (see 0024821).

Fixes: 0023245, 0024821
Affected Issues
0023245, 0024821, 0025661
mod - core/bug_group_action_api.php Diff File
mod - core/version_api.php Diff File

MantisBT: master-2.20 f82e32fa

2019-03-28 18:56:36

cproensa


Committer: dregad Details Diff
Fix show obsolete versions

Fix version_get_all_rows for a default parameter value of "null".
Regression caused by 46c77ace319216aa6403af4130b83b4deb801b3c

Fixes: 0025661
Affected Issues
0025661
mod - core/version_api.php Diff File

MantisBT: master-2.20 ca5545cc

2019-04-18 06:40:45

dregad

Details Diff
Use VERSION_xxx constants for $p_released param

When calling version_get_all_rows(), use defined constants instead of
relying on true, false or null.

Issue 0025661
Affected Issues
0025661
mod - api/soap/mc_project_api.php Diff File
mod - changelog_page.php Diff File
mod - core/print_api.php Diff File
mod - core/version_api.php Diff File
mod - manage_proj_edit_page.php Diff File

MantisBT: master-2.20 e21eae5d

2019-04-20 02:37:22

vboctor


Committer: GitHub Details Diff
Merge pull request #1492 from cproensa/0025661_fix_show_obsolete_version

Fix show obsolete versions

Fixes 0025661
Affected Issues
0025661
mod - api/soap/mc_project_api.php Diff File
mod - changelog_page.php Diff File
mod - core/print_api.php Diff File
mod - core/version_api.php Diff File
mod - manage_proj_edit_page.php Diff File

Issue History

Date Modified Username Field Change
2019-03-28 07:14 CoreKeeper New Issue
2019-03-28 07:14 CoreKeeper File Added: mantis_2_20_obsolete_version.mp4
2019-03-28 18:55 cproensa Assigned To => cproensa
2019-03-28 18:55 cproensa Status new => assigned
2019-03-28 18:59 cproensa Note Added: 0061793
2019-03-29 06:51 dregad Target Version => 2.20.1
2019-03-29 06:51 dregad Description Updated View Revisions
2019-04-11 20:34 thE_iNviNciblE Note Added: 0061905
2019-04-18 06:15 dregad Changeset attached => MantisBT master 46c77ace
2019-04-18 06:18 dregad Note Added: 0061973
2019-04-20 02:37 dregad Changeset attached => MantisBT master-2.20 f82e32fa
2019-04-20 02:37 dregad Changeset attached => MantisBT master-2.20 ca5545cc
2019-04-20 02:37 vboctor Changeset attached => MantisBT master-2.20 e21eae5d
2019-04-20 02:37 vboctor Assigned To cproensa => vboctor
2019-04-20 02:37 vboctor Status assigned => resolved
2019-04-20 02:37 vboctor Resolution open => fixed
2019-04-20 02:44 vboctor Fixed in Version => 2.20.1
2019-04-20 02:45 vboctor Assigned To vboctor => cproensa
2019-04-21 02:53 vboctor Status resolved => closed