View Issue Details

IDProjectCategoryView StatusLast Update
0025469mantisbtfilterspublic2019-06-09 11:02
Reporterfishgirl Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0025469: Category Filter shows deleted categories
Description

In our Mantis we have several projects (active and deactivated) as well as several categories. The categories "live", they change with time. "Old" categories that are no longer needed are also deleted (Administration -> Manage Projects -> Global Categories -> Delete). Delete categories works. But if I go to the top right on "All projects" and then filter by category, I get all already deleted categories to select. It's illogical, because I already deleted the 'old' categories.

(Google translation, original submission follows)


Guten Tag,

in unserem Mantis haben wir mehrere Projekte (aktive und deaktivierte) als auch mehrere Kategorien. Die Kategorien "leben", sie ändern sich mit der Zeit. "Alte" Kategorien, die nicht mehr benötigt werden, werden auch gelöscht (Verwaltung-->Projekte verwalten--> Globale Kategorien--> Löschen). Kategorien löschen funktioniert. Aber wenn ich rechts oben auf "Alle Projekte" gehe und danach nach Kategorie filtern möchte, bekommen ich alle auch schon gelöschte Kategorien zum auswählen. Das ist irgendwie unlogisch, da ich die 'alte' Kategorien schon gelöscht habe.

TagsNo tags attached.

Activities

atrol

atrol

2019-02-13 09:29

developer   ~0061482

fishgirl,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (2.19.0 at the moment).

If you are running an older version, I recommend that you upgrade to the latest (download from [1]). If after doing so the problem persists, do not hesitate to reopen the issue and provide detailed step-by-step instructions to reproduce the issue.

All information has to be provided in English!
For German support, have a look at our German forum https://www.mantisbt.org/forums/viewforum.php?f=9

The following additional information may also be useful:

  • Exact version of MantisBT, PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?

[1] http://mantisbt.org/download.php

fishgirl

fishgirl

2019-05-29 03:01

reporter   ~0062154

So as we installed a new version of Mantis:

MantisBT-Version 2.21.0
Schema-Version 209
PHP-Version 7.3.1
Datenbanktreiber mysqli
Datenbankversion, 8.0.16
Firefox, IE

The problem is still there: we have different categories (some with "18, 19" in the name, which means year) for tickets, each ticket becomes his category by creation. Tickets are in projects, as soon as project is deactivated his categories will be deleted via "manage-->manage projects-->clobal categories--> delete". But if I open filter and look unter category, I can see all categories ever existed (from years 16,17....), no metter that there are no tickets with such a category between active projects.

I will be pleased to provide pictures.

dregad

dregad

2019-05-29 03:15

developer   ~0062155

@fishgirl instead of pictures, it would be better to provide step-by-step instructions to reproduce the problem starting from a fresh install of MantisBT. Thanks.

fishgirl

fishgirl

2019-05-29 03:30

reporter   ~0062157

The mantis was updated according to the instruction, provided on the following page:

https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html/admin.install.upgrade.html

now to reproduction:

  1. go to "manage-->manage projects-->clobal categories"
  2. create a global category ( fishgirl 1)
  3. go to "report issue", create a new bug
  4. choose for the new bug category "fishgirl1"
  5. closed the bug as it is done
  6. go to "manage-->manage projects-->clobal categories" and delete the category "fishgirl1"
  7. go to "view issues", open "filters" and check if "fishgirl1" is still between avaliabe categories.

In our case the category stays in the filter.

atrol

atrol

2019-05-29 09:17

developer   ~0062159

go to "manage-->manage projects-->clobal categories" and delete the category "fishgirl1"

When trying this I get

APPLICATION ERROR # 1505
Category "fishgirl1" cannot be deleted, because it is associated with one or more issues.
fishgirl

fishgirl

2019-05-29 09:25

reporter   ~0062160

I think I figured it out, if a project has categories, which do not have (all projects) in front, the categories are staying in filter even if the category was deleted from global categories.

atrol

atrol

2019-05-29 09:37

developer   ~0062161

if a project has categories, which do not have (all projects) in front

These are no global categories, but categories assigned to the project.

Goto Manage > Manage Projects
Click on a project name
There is a section Categories where you can delete categories that are asssigned to projects.

fishgirl

fishgirl

2019-05-29 09:42

reporter   ~0062162

yes, thank you, I am aware of that. I was expecting if I delete a category in global categories, they will be deleted in all Projects.

atrol

atrol

2019-05-29 09:54

developer   ~0062163

I was expecting if I delete a category in global categories, they will be deleted in all Projects.

If you delete a global category, it is no longer available in all projects.
Categories that are assigned to a project are not affected by this operation, even if they have the same name like the global one.

Issue History

Date Modified Username Field Change
2019-02-13 04:12 fishgirl New Issue
2019-02-13 09:29 atrol Assigned To => atrol
2019-02-13 09:29 atrol Status new => resolved
2019-02-13 09:29 atrol Resolution open => unable to reproduce
2019-02-13 09:29 atrol Note Added: 0061482
2019-02-24 06:41 atrol Status resolved => closed
2019-05-29 03:01 fishgirl Status closed => feedback
2019-05-29 03:01 fishgirl Resolution unable to reproduce => reopened
2019-05-29 03:01 fishgirl Note Added: 0062154
2019-05-29 03:15 dregad Note Added: 0062155
2019-05-29 03:17 dregad Summary Category Filter zeigt gelöschte Kategorien => Category Filter shows deleted categories
2019-05-29 03:17 dregad Description Updated View Revisions
2019-05-29 03:17 dregad Description Updated View Revisions
2019-05-29 03:30 fishgirl Note Added: 0062157
2019-05-29 03:30 fishgirl Status feedback => assigned
2019-05-29 09:17 atrol Note Added: 0062159
2019-05-29 09:17 atrol Assigned To atrol =>
2019-05-29 09:17 atrol Status assigned => feedback
2019-05-29 09:25 fishgirl Note Added: 0062160
2019-05-29 09:25 fishgirl Status feedback => new
2019-05-29 09:37 atrol Note Added: 0062161
2019-05-29 09:38 atrol Assigned To => atrol
2019-05-29 09:38 atrol Status new => resolved
2019-05-29 09:38 atrol Resolution reopened => no change required
2019-05-29 09:42 fishgirl Note Added: 0062162
2019-05-29 09:54 atrol Note Added: 0062163
2019-06-09 11:02 atrol Status resolved => closed