View Issue Details

IDProjectCategoryView StatusLast Update
0025405mantisbtmarkdownpublic2019-06-09 11:02
Reportertruefriend-cz Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformPC / Notebook / LaptopOSWindows / Linux / Android 
Product Version2.19.0 
Summary0025405: Links on summary, notes, and Details converted to other chars
Description

If added URL to any Report input text replacing special charsets to other charset.

Steps To Reproduce

This is link to forum:
https://www.mantisbt.org/forums/viewtopic.php?f=3&t=26107
but in the URS is ater char "3" and before "t=26... is symbol for AND (&) but Mantis replaced this symbol to "&" where linked to non exist good format URL.
Details is at forum - https://www.mantisbt.org/forums/viewtopic.php?f=3&t=

original format: https://www.mantisbt.org/forums/viewtopic.php?f=3&t=26107

Mantis format: https://www.mantisbt.org/forums/viewtopic.php?f=3&t=26107

TagsNo tags attached.

Relationships

duplicate of 0024810 confirmed Markdown links/code always show HTML entities for Ampersand and Less-than sign 
related to 0024628 assigneddregad Double quotes " and lesser than sign < are shown as HTML entity within Markdown code blocks 

Activities

truefriend-cz

truefriend-cz

2019-01-31 00:06

reporter   ~0061342

Last edited: 2019-01-31 00:19

View 7 revisions

I'm sorry, however, that it is not possible to present a problem when the system can not write it correctly. Excuse for user atrol for poor reproduction of the problem but the error is not on my side this time.

I reproduction problem now as code text:

This is normal link to forum:
https://www.mantisbt.org/forums/viewtopic.php?f=3&t=26107
but in the URS is after char 3 and before t=26... is symbol for AND ...&... but Mantis replaced this symbol to ...&amp(;)... where linked to non exist good format URL.

Original format URL: https://www.mantisbt.org/forums/viewtopic.php?f=3&t=26107
Mantis (badly) format URL: https://www.mantisbt.org/forums/viewtopic.php?f=3&t=26107

Nonono, Edit: Sorry the problem i can not be reproduced because the Mantis system is not capable. You must to figure out.

Issue History

Date Modified Username Field Change
2019-01-31 00:00 truefriend-cz New Issue
2019-01-31 00:06 truefriend-cz Note Added: 0061342
2019-01-31 00:09 truefriend-cz Note Edited: 0061342 View Revisions
2019-01-31 00:12 truefriend-cz Note Edited: 0061342 View Revisions
2019-01-31 00:14 truefriend-cz Note Edited: 0061342 View Revisions
2019-01-31 00:16 truefriend-cz Note Edited: 0061342 View Revisions
2019-01-31 00:17 truefriend-cz Note Edited: 0061342 View Revisions
2019-01-31 00:19 truefriend-cz Note Edited: 0061342 View Revisions
2019-02-01 02:34 atrol Severity feature => minor
2019-02-01 02:34 atrol Category scripting => markdown
2019-02-01 02:34 atrol Steps to Reproduce Updated View Revisions
2019-02-01 02:34 atrol Relationship added related to 0024628
2019-05-28 04:32 dregad Assigned To => dregad
2019-05-28 04:32 dregad Status new => resolved
2019-05-28 04:32 dregad Resolution open => duplicate
2019-05-28 04:32 dregad Relationship added duplicate of 0024810
2019-06-09 11:02 atrol Status resolved => closed