View Issue Details

IDProjectCategoryView StatusLast Update
0025006mantisbtuipublic2018-12-06 02:10
Reporterretr0gradeAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.18.0 
Target VersionFixed in Version 
Summary0025006: Changing order of View Boxes makes them dissapear
Description

I am currently playing around with view box visibility using config option "my_view_boxes" in My View page and I noticed two things connected to visibility of resolved and monitored boxes.

  1. Only one of two view boxes appears in the view. This depends on what value is assigned to which box. The one with higher value assigned is displayed, other is not.
  2. Setting resolved value to 0 makes monitored view box to disappear, no matter what value is set to monitored.
Steps To Reproduce
  1. Add in configuration options my_view_boxes option and set it's value to array below. This makes monitored box visible.

array (
'assigned' => '1',
'reported' => '2',
'resolved' => '3',
'monitored' => '4',
'unassigned' => '0',
'recent_mod' => '0',
'feedback' => '0',
'verify' => '0',
'my_comments' => '0',
)

  1. Change values as below. This will display resolved and hide monitored.

    'resolved' => '4',
    'monitored' => '3',

  2. Set resolved value to 0. This will hide both boxes.

TagsNo tags attached.

Activities

atrol

atrol

2018-11-23 12:20

developer   ~0061002

retr0grade,

I was not able to reproduce your problem.

The following additional information may be useful:

  • Exact version of PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
  • Are there any errors or warnings in web server or PHP logs ?
  • Are there any errors or warnings in browser console ?
retr0grade

retr0grade

2018-11-26 02:13

reporter   ~0061004

OS: Ubuntu 16.04.4 (w/ 4.4.0-104-generic x86_64 kernel)
PHP: 7.0.32
MySQL: 5.7.21
Apache 2.4.18

Only LDAP and SMTP config in config_inc.php. No other modifications.

Installed plugins:

  • Better status colors 1.0.2
  • Email Reporting 0.10.1
  • PasteZone 1.0.1

No errors in server logs or console.

atrol

atrol

2018-11-26 03:15

developer   ~0061006

Last edited: 2018-11-26 03:17

View 3 revisions

Are you able to reproduce the issue without having activated any 3rd party plugin?

If no, please contact the author of the plugin
If yes,

Change code in my_view_page.php, starting from line 88

$t_boxes = config_get( 'my_view_boxes' );
var_dump ($t_boxes);
echo "<br />";
asort( $t_boxes );
reset( $t_boxes );
var_dump ($t_boxes);
die ("Boxes after sort");

I would expect the following output when accessing My View page

array(9) { ["assigned"]=> string(1) "1" ["reported"]=> string(1) "2" ["resolved"]=> string(1) "0" ["monitored"]=> string(1) "3" ["unassigned"]=> string(1) "0" ["recent_mod"]=> string(1) "0" ["feedback"]=> string(1) "0" ["verify"]=> string(1) "0" ["my_comments"]=> string(1) "0" }
array(9) { ["resolved"]=> string(1) "0" ["unassigned"]=> string(1) "0" ["recent_mod"]=> string(1) "0" ["feedback"]=> string(1) "0" ["verify"]=> string(1) "0" ["my_comments"]=> string(1) "0" ["assigned"]=> string(1) "1" ["reported"]=> string(1) "2" ["monitored"]=> string(1) "3" } Boxes after sort

atrol

atrol

2018-12-06 02:10

developer   ~0061042

retr0grade,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

Issue History

Date Modified Username Field Change
2018-11-23 07:26 retr0grade New Issue
2018-11-23 12:20 atrol Status new => feedback
2018-11-23 12:20 atrol Note Added: 0061002
2018-11-26 02:13 retr0grade Note Added: 0061004
2018-11-26 02:13 retr0grade Status feedback => new
2018-11-26 03:15 atrol Status new => feedback
2018-11-26 03:15 atrol Note Added: 0061006
2018-11-26 03:16 atrol Note Edited: 0061006 View Revisions
2018-11-26 03:17 atrol Note Edited: 0061006 View Revisions
2018-12-06 02:10 atrol Assigned To => atrol
2018-12-06 02:10 atrol Status feedback => resolved
2018-12-06 02:10 atrol Resolution open => no change required
2018-12-06 02:10 atrol Note Added: 0061042