View Issue Details

IDProjectCategoryView StatusLast Update
0024605mantisbtplug-inspublic2018-07-12 10:57
ReporterdhofmaAssigned Toatrol 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionno change required 
Product Version2.15.0 
Target VersionFixed in Version 
Summary0024605: Automatically create tickets when creating a new project
Description

Hello everyone,

im new here, and think this is a really good software to manage tasks inside a company.
Is there any way to automatically create several tickets when creating a new project?
Would be very nice if there was an extension for this, it would save me a lot of time.

Thank you in advance.

TagsNo tags attached.

Activities

atrol

atrol

2018-07-12 09:59

developer   ~0060255

I am not sure if understand right what you want, maybe there is no need for a plugin.

You could create some kind of template project with tickets in it.
After creating a new project, copy the tickets from the template project to the new project using the Copy function of the View Issues page.

dhofma

dhofma

2018-07-12 10:08

reporter   ~0060256

Thank you for your reply,
in my Company, there will a lot of projects going on. Of course it wouldnt take much time to copy the tickets, but it would be even nicer if that could be done automatically :D.

atrol

atrol

2018-07-12 10:57

developer   ~0060257

I don't know a plugin for it, at least I didn't find one after having a quick look at http://mantisbt.org/wiki/doku.php/mantisbt:plugins:start and https://github.com/mantisbt-plugins

Such a plugin would have to use event EVENT_MANAGE_PROJECT_CREATE to create the tickets.

To write a hardcoded plugin that fits just your needs (all projects are very similar) should be no big deal.
To write a plugin that is able to deal with any possible Mantis project configuration (e.g. different categories, status values, custom fields, ...) is another story.

I don't see this is a feature that should be part of the Mantis core, as this is no typical use case and there is some core functionality to get it with a few clicks.

dhofma,

This is not a bug or feature request for MantisBT (you are asking for help on how to develop a Mantis plugin). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Issue History

Date Modified Username Field Change
2018-07-12 09:38 dhofma New Issue
2018-07-12 09:59 atrol Status new => feedback
2018-07-12 09:59 atrol Note Added: 0060255
2018-07-12 10:08 dhofma Note Added: 0060256
2018-07-12 10:08 dhofma Status feedback => new
2018-07-12 10:57 atrol Assigned To => atrol
2018-07-12 10:57 atrol Status new => resolved
2018-07-12 10:57 atrol Resolution open => no change required
2018-07-12 10:57 atrol Note Added: 0060257