View Issue Details

IDProjectCategoryView StatusLast Update
0024288mantisbtemailpublic2018-04-29 19:21
ReporterfeidAssigned Toatrol 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionduplicate 
Product Version2.5.1 
Target VersionFixed in Version 
Summary0024288: Change email defaults to not send me an email after I make an update
Description

I do not want to receive email notifications for changes I have made;
Per the guide "https://mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/" and search for g_email_receive_own you will find the following explanation:
$g_email_receive_own
This defines whether users should receive emails for their own actions. This option is defaulted to OFF, hence, users do not receive email notification for their own actions. This can be a source for confusions for users upgrading from MantisBT 0.17.x versions, since in these versions users used to get notified of their own actions.

As I dont find any interface to disable $g_email_receive_own in MantisBT(my version 2.5.1), Could you help to confirm the following two questions:
1, if MantisBT provide interface(like a configuration button in manage page) to disable the $g_email_receive_own;
2, if MantisBT provide interface that each user can disable the $g_email_receive_own by themself ; because not all of the people would like to disable this email notification for their own update;

please let me know if there is anything unclear and looking forward your response;

Thanks,
Fei

TagsNo tags attached.

Relationships

duplicate of 0006372 acknowledged $g_email_receive_own should be web-configurable 

Activities

atrol

atrol

2018-04-13 01:32

developer   ~0059548

1, if MantisBT provide interface(like a configuration button in manage page) to disable the $g_email_receive_own;

Known feature request, see 0006372
You have to change the setting in config_inc.php at the moment

2, if MantisBT provide interface that each user can disable the $g_email_receive_own by themself ; because not all of the people would like to disable this email notification for their own update;

Known feature request, see 0011188

feid

feid

2018-04-18 22:02

reporter   ~0059600

Last edited: 2018-04-18 22:02

View 2 revisions

Hi Atrol,

Thanks for your prompt reply;
item 1 make sense;
and for the question2, in the account_prefs_page.php, when we disable the "E-mail on Note Added"(please see the attached file), then all the notes even added by other ones won't send email notification to me, but what I want is just to ignore the notification for these notes I added by myself;

Does Mantis have any way to support this feature?

Thanks,
Fei



Capture.JPG (84,182 bytes)
Capture.JPG (84,182 bytes)
atrol

atrol

2018-04-22 08:13

developer   ~0059630

Does Mantis have any way to support this feature?

Not out of the box.

You could also implement your own notification rules by writing a plugin.
E.g. there is EVENT_NOTIFY_USER_EXCLUDE to remove users from distribution list.

There is also some work in progress to allow plugins even more influence of notifications.
https://github.com/mantisbt/mantisbt/pull/1335

Issue History

Date Modified Username Field Change
2018-04-12 21:58 feid New Issue
2018-04-13 01:32 atrol Assigned To => atrol
2018-04-13 01:32 atrol Status new => resolved
2018-04-13 01:32 atrol Resolution open => duplicate
2018-04-13 01:32 atrol Note Added: 0059548
2018-04-13 01:32 atrol Relationship added duplicate of 0006372
2018-04-18 22:02 feid File Added: Capture.JPG
2018-04-18 22:02 feid Note Added: 0059600
2018-04-18 22:02 feid Note Edited: 0059600 View Revisions
2018-04-22 08:13 atrol Note Added: 0059630
2018-04-29 19:21 vboctor Status resolved => closed