View Issue Details

IDProjectCategoryView StatusLast Update
0024227mantisbtemailpublic2018-05-13 16:53
ReporterpurpletreeAssigned Toatrol 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2.13.1 
Target VersionFixed in Version 
Summary0024227: email notifications not received and smtp setting not working
Description

Just installed the software. I have tried to do simple config but I am not getting email notifications.
However, I noted I am getting notifications for "send a reminder" perfectly fine. Even in that case, the SMTP config is not used. emails are still sent by server relay only.
Config file screenshot is attached.

TagsNo tags attached.

Activities

purpletree

purpletree

2018-04-05 04:05

reporter  

Screenshot.jpg (95,299 bytes)
Screenshot.jpg (95,299 bytes)
atrol

atrol

2018-04-05 04:16

developer   ~0059439

Last edited: 2018-04-05 04:17

View 2 revisions

purpletree,

concerning the SMTP issue:
You set

$g_smtp_port = '25';
$g_phpMailer_method = 'PHPMAILER_METHOD_SMTP';

it should be

$g_smtp_port = 25;
$g_phpMailer_method = PHPMAILER_METHOD_SMTP;

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

purpletree

purpletree

2018-04-05 07:22

reporter   ~0059442

atrol,
thanks a lot and sorry if it sounded like I was asking for help.
I have confirmed that SMTP settings do not work.
I am running a magento website on same server. There I use SMTP for mailing.
If I put the same credentials here, it does not send any emails.

Following are the parameters I am sending:

$g_phpMailer_method =PHPMAILER_METHOD_SMTP;
$g_smtp_host='in-v3.mailjet.com';
$g_smtp_port=25;
$g_smtp_connection_mode='';
$g_smtp_username='myuser';
$g_smtp_password='mypasswd';

purpletree

purpletree

2018-04-05 07:23

reporter   ~0059443

Note: I have also tried with port 587 and tls, which work for other website too, but not for this.

purpletree

purpletree

2018-04-20 01:23

reporter   ~0059613

hi atrol, by any chance did you have time to look at this?

atrol

atrol

2018-04-22 08:04

developer   ~0059629

I still think this is not a bug or feature request for MantisBT but a configuration issue that should not be treated at this place but in the forums.

I am not able to reproduce the issue and I will set to resolved again, unless you are able to provide step by step instruction to reproduce the issue, starting from a fresh install.

You can enable email logging for Mantis, to trace if Mantis decides to sent email based on your configuration.
https://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.logging

If emails are sent, you have to check the logs of your SMTP server, spam filters, mail client settings, ...

atrol

atrol

2018-05-03 15:22

developer   ~0059735

purpletree,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.

Issue History

Date Modified Username Field Change
2018-04-05 04:05 purpletree New Issue
2018-04-05 04:05 purpletree File Added: Screenshot.jpg
2018-04-05 04:16 atrol Assigned To => atrol
2018-04-05 04:16 atrol Status new => resolved
2018-04-05 04:16 atrol Resolution open => no change required
2018-04-05 04:16 atrol Note Added: 0059439
2018-04-05 04:17 atrol Note Edited: 0059439 View Revisions
2018-04-05 07:22 purpletree Note Added: 0059442
2018-04-05 07:23 purpletree Note Added: 0059443
2018-04-05 07:24 purpletree Status resolved => feedback
2018-04-05 07:24 purpletree Resolution no change required => reopened
2018-04-20 01:23 purpletree Note Added: 0059613
2018-04-20 01:23 purpletree Status feedback => assigned
2018-04-22 08:04 atrol Assigned To atrol =>
2018-04-22 08:04 atrol Status assigned => feedback
2018-04-22 08:04 atrol Note Added: 0059629
2018-05-03 15:22 atrol Assigned To => atrol
2018-05-03 15:22 atrol Status feedback => resolved
2018-05-03 15:22 atrol Resolution reopened => no change required
2018-05-03 15:22 atrol Note Added: 0059735
2018-05-13 16:53 atrol Status resolved => closed