View Issue Details

IDProjectCategoryView StatusLast Update
0023708Plugin - EmailReportingGeneralpublic2017-12-08 20:37
ReporterSchaefT Assigned ToSL-Gundam  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.10.0 
Summary0023708: change the status of existing ticket fails
Description

Again a high commendation to this plugin!!!
After solving the problem with 0023624, maybe there is a solution for the current situation.

After creating a new ticket via EmaiReporting by a reporters email
(which is an outstanding and highly appreciated feature),
this ticket needs feedback.
The developer changes the status to feedback, and the reporter is informed by email.

The reporter replies to the requested feedback from the developer
and the (email) information submitted by the reporter is added as note to the original Ticket.
(up to this point everything is running like it should).

After studying the documentation, the status of this ticket should change to whatever the workflow
in MantisBT defines.
(i.e. new, or in progress)

This unfortunaletly won´t happen.
The ticket remains the status feedback and will not change.

If the reporter logs in with his credentials the status switches from (i.e.) feedback to new
as soon as his note is being added to this ticket.

Are there any known issues with MantisBT 2.8 or 2.9?
Any help is pretty welcome.

Additional Information

running Ubuntu 16.04.1 LTS
fresh and clean install of MantisBT 2.8/2.9

TagsNo tags attached.

Relationships

related to 0023712 closedvboctor mantisbt auth_get_current_user_id can return strings while that is not expected 

Activities

SL-Gundam

SL-Gundam

2017-12-08 13:34

manager   ~0058358

I think found the cause. Created an issue 0023712 for this with MantisBT because i cannot oversee possible other complications

I will also apply a quickfix in EmailReporting

SL-Gundam

SL-Gundam

2017-12-08 13:45

manager   ~0058359

Here is the quickfix
https://github.com/mantisbt-plugins/EmailReporting/commit/3f26defd6dea0cfb2a71b3e015ee100677cf59fa

SchaefT

SchaefT

2017-12-08 17:04

reporter   ~0058363

Your quickfix solved the problem.
Tested with MantiBT 2.8 and 2.9

Thank you so much.

Issue History

Date Modified Username Field Change
2017-12-08 02:51 SchaefT New Issue
2017-12-08 12:47 SL-Gundam Assigned To => SL-Gundam
2017-12-08 12:47 SL-Gundam Status new => assigned
2017-12-08 13:34 SL-Gundam Note Added: 0058358
2017-12-08 13:43 SL-Gundam Relationship added related to 0023712
2017-12-08 13:45 SL-Gundam Note Added: 0058359
2017-12-08 13:45 SL-Gundam Status assigned => resolved
2017-12-08 13:45 SL-Gundam Resolution open => fixed
2017-12-08 17:04 SchaefT Note Added: 0058363
2017-12-08 20:37 SL-Gundam Status resolved => closed