View Issue Details

IDProjectCategoryView StatusLast Update
0021829mantisbtemailpublic2016-11-01 11:01
ReportervboctorAssigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.2 
Target Version2.0.0-rc.1Fixed in Version2.0.0-rc.1 
Summary0021829: Fix $g_mail_priority disabling and default to disabled
Description

There are several issues with this configuration option:

  1. It is not a common practice for services sending emails to set such priority.
  2. As per the documentation for this config option, 0 should disable it, but it doesn't.
  3. It increases the spam score for some email, specially password reset.

See attached screenshots.

I've looked into this because on MantisHub several users have reported that activation emails are sometimes not received.

Tagsmantishub

Relationships

related to 0021830 closedvboctor Remove $g_mail_priority configuration option to reduce spam risk 

Activities

vboctor

vboctor

2016-10-30 01:16

manager  

vboctor

vboctor

2016-10-30 01:45

manager   ~0054355

The following PR fixes the handling of value 0 for the config option as per documentation and changes default to 0.
PR: https://github.com/mantisbt/mantisbt/pull/934

If there is agreement, I can follow up with deprecating this config option completely.

dregad

dregad

2016-10-31 07:09

developer   ~0054356

I believe this should be backported to 1.3 branch.

I'm in favor of deprecating this config option, don't see the added value for it.

atrol

atrol

2016-11-01 11:01

developer   ~0054365

I believe this should be backported to 1.3 branch.
+1

All changes in 2.0.x that are not related to UI or do not introduce new functionality should be backported to 1.3

Related Changesets

MantisBT: master 1b0cc1db

2016-10-30 01:35:46

vboctor

Details Diff
Disable ‘X-Priority’ header for priority 0

Honor the documentation and don’t emit the X-Priority header when value is 0.

Default the configuration option to 0, since having this header set increases
spam ranking as per mailtrap.io analysis specially for password reset emails.

Fixes 0021829
mod - config_defaults_inc.php Diff File
mod - core/email_api.php Diff File
mod - docbook/Admin_Guide/en-US/config/email.xml Diff File

Issue History

Date Modified Username Field Change
2016-10-30 01:16 vboctor New Issue
2016-10-30 01:16 vboctor Status new => assigned
2016-10-30 01:16 vboctor Assigned To => vboctor
2016-10-30 01:16 vboctor File Added: mailtrap_reset_password_priority_header.png
2016-10-30 01:16 vboctor File Added: mailtrap_reset_password_reset_before.png
2016-10-30 01:16 vboctor File Added: mailtrap_reset_password_spam_after.png
2016-10-30 01:16 vboctor Tag Attached: mantishub
2016-10-30 01:45 vboctor Note Added: 0054355
2016-10-30 17:12 vboctor Changeset attached => MantisBT master 1b0cc1db
2016-10-30 17:12 vboctor Status assigned => resolved
2016-10-30 17:12 vboctor Resolution open => fixed
2016-10-30 17:12 vboctor Fixed in Version => 2.0.0-rc.1
2016-10-30 17:14 vboctoradmin Summary Deprecate $g_mail_priority since it is causing emails to be classified as spam => Fix $g_mail_priority disabling and default to disabled
2016-10-30 17:16 vboctoradmin Relationship added related to 0021830
2016-10-30 23:22 vboctor Status resolved => closed
2016-10-31 07:09 dregad Note Added: 0054356
2016-11-01 11:01 atrol Note Added: 0054365