View Issue Details

IDProjectCategoryView StatusLast Update
0021133mantisbtrsspublic2020-03-15 15:23
Reporteratrol Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.9 
Target Version2.24.0Fixed in Version2.24.0 
Summary0021133: Access of non existent image in RSS feeds
Description

File mantis_logo_button.gif has been removed in commit MantisBT master e47a2dcb when our new logo has been introduced.
The file is still referenced in RSS feeds.

issues_rss.php
$t_image_link = $t_path . 'images/mantis_logo_button.gif';

news_rss.php
$t_image_link = config_get( 'path' ) . 'images/mantis_logo_button.gif';

TagsNo tags attached.

Relationships

related to 0007994 closedvboctor New Mantis Logo 
has duplicate 0022135 closedatrol RSS feeds reference non existent image 
has duplicate 0026628 closedatrol issues_rss.php refere to an inexistant ressource 

Activities

dregad

dregad

2020-01-28 07:00

developer   ~0063527

Amazing that the bug has been present for so long (2012), and considering how simple the fix, that nobody bothered to patch it since this report was opened in 2016...

PR https://github.com/mantisbt/mantisbt/pull/1617

atrol

atrol

2020-01-28 07:44

developer   ~0063528

and considering how simple the fix, that nobody bothered to patch it

@dregad I don't remember, maybe because I thought that we need a new image, as the old image was just 88 x 35 pixel.
Maybe also because I looked at an quite / too old RSS specification where 88x31 was the preferred size.

dregad

dregad

2020-01-29 09:28

developer   ~0063533

RSS specification where 88x31 was the preferred size.

Hmm, good point I did not verify that there was a restriction on image size. The RSS 2.0 specification states

Maximum value for width is 144, default value is 88.
Maximum value for height is 400, default value is 31.

Our logo is 232x80, so it actually exceeds the maximum width. I'm not sure what consequence this would have on RSS clients (error, resized image, no display...). I hardly use RSS anymore these days, and I don't know of a local client supporting channel images that I can use for testing (it needs to be local so I can test against my dev box's localhost setup).

Maybe @LewisR or @Camille Desmots can provide feedback on this.

In any case, IMO the proposed patch is no worse than the current situation of referencing the wrong logo ;-)

LewisR

LewisR

2020-01-31 15:08

reporter   ~0063547

Last edited: 2020-01-31 15:12

View 2 revisions

Hmmm... Well, my reading is slightly different. From the text just above the maximum values stated:

Optional elements include <width> and <height>, numbers, indicating the width and height of the image in pixels. <description> contains text that is included in the TITLE attribute of the link formed around the image in the HTML rendering.

which indicates to me that those values are not image size limits but rather value limits when values have been entered using the optional elements.

My feed reader is SeaMonkey, and I don't see these images at all (and I was fairly certain that my own blog includes them - I'll need to look at the xml). Sorry I can't be of more help at this particular moment.

dregad

dregad

2020-02-02 11:04

developer   ~0063548

OK, thanks for the feedback anyway @LewisR.

Related Changesets

MantisBT: master e47a2dcb

2012-05-06 11:30:21

vboctor

Details Diff
New logo, button and favicon.

1. Logo - for now login page and normal pages use the same logo size. In future versions, we may include a slightly larger one for the login page. Didn't want to include this in a minor update, since this is a configurable image name, and hence adding a new logo, may end up with having a mix of two logos.

2. The button is now a scaled version of the logo. For this reason, it is removed from the footer of the login page, but kept on the others.

3. Added the new favicon.
Affected Issues
0014119, 0021133
add - images/mantis_logo_232x80.png Diff File
rm - images/mantis_logo.gif Diff File
rm - images/mantis_logo_button.gif Diff File
mod - config_defaults_inc.php Diff File
mod - core/html_api.php Diff File
mod - images/favicon.ico Diff File

MantisBT: master a91e7e13

2020-01-28 06:55:45

dregad

Details Diff
Use $g_logo_image for RSS feeds

The code was using an hardcoded image name (mantis_logo_button.gif),
obsolete since the introduction of the new MantisBT logo, back in
2012 / 1.2.9 (!)

Fixes 0021133
Affected Issues
0021133
mod - issues_rss.php Diff File
mod - news_rss.php Diff File

Issue History

Date Modified Username Field Change
2016-06-17 03:20 atrol New Issue
2016-06-17 03:20 atrol Relationship added related to 0007994
2017-09-20 16:59 atrol Description Updated View Revisions
2017-09-20 17:00 atrol Relationship added has duplicate 0022135
2020-01-27 08:10 atrol Relationship added has duplicate 0026628
2020-01-28 05:34 dregad Changeset attached => MantisBT master e47a2dcb
2020-01-28 07:00 dregad Assigned To => dregad
2020-01-28 07:00 dregad Status new => assigned
2020-01-28 07:00 dregad Note Added: 0063527
2020-01-28 07:44 atrol Note Added: 0063528
2020-01-29 09:28 dregad Note Added: 0063533
2020-01-31 15:08 LewisR Note Added: 0063547
2020-01-31 15:12 LewisR Note Edited: 0063547 View Revisions
2020-02-02 11:04 dregad Note Added: 0063548
2020-02-02 11:05 dregad Changeset attached => MantisBT master a91e7e13
2020-02-02 11:05 dregad Status assigned => resolved
2020-02-02 11:05 dregad Resolution open => fixed
2020-02-02 11:05 dregad Fixed in Version => 2.24.0
2020-02-02 13:40 atrol Target Version => 2.24.0
2020-03-15 15:23 vboctor Status resolved => closed