View Issue Details

IDProjectCategoryView StatusLast Update
0021100mantisbtmentionspublic2019-09-09 17:27
Reportervboctor Assigned Tocproensa  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version1.3.0-rc.2 
Summary0021100: Support auto-complete for @ mentions in modern UI
Description

The modern UI should provide auto-complete to help users auto-complete user names. Ideally with a preference to users that have already contributed to the issue (reporter, note authors, handler, etc). The involved people can be the suggested list when user just types @ and before typing more letters.

TagsNo tags attached.

Relationships

duplicate of 0025906 assignedsyncguru Add autocomplete inline popup menu for @mentions while typing 
related to 0021099 new Support auto-complete when adding user to monitor list on an issue 

Activities

libregeek

libregeek

2017-07-19 08:26

reporter   ~0057263

We added a similar feature to the MarkDown Editor plugin. However, it doesn't prioritize suggestions, but simply shows usernames based on 3-5 consecutive characters of the username. It's still work in progress, but the basic functionality works for us.

Source code: https://github.com/ejyothi/MantisBT-MarkDownEditor

The auto-complete feature uses Textcomplete library from https://github.com/yuku-t/textcomplete.

atrol

atrol

2019-08-30 05:00

developer   ~0062691

No longer needed as there is 0025906 with assigned developer.

Issue History

Date Modified Username Field Change
2016-06-13 00:40 vboctor New Issue
2016-06-13 02:02 vboctor Relationship added related to 0021099
2017-07-19 08:26 libregeek Note Added: 0057263
2019-07-08 04:57 cproensa Relationship added has duplicate 0025906
2019-08-30 05:00 atrol Assigned To => cproensa
2019-08-30 05:00 atrol Status new => resolved
2019-08-30 05:00 atrol Resolution open => duplicate
2019-08-30 05:00 atrol Note Added: 0062691
2019-08-30 05:00 atrol Relationship replaced duplicate of 0025906
2019-09-09 17:27 atrol Status resolved => closed