View Issue Details

IDProjectCategoryView StatusLast Update
0019892mantisbtdb mssqlpublic2019-12-13 18:06
Reporterm.junaid86@gmail.com Assigned Todregad  
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionno change required 
OSWindows 7 
Product Version1.2.19 
Summary0019892: Getting Error when verify the the New User
Description

I have Setup the Mantis BT on my server. Using MS SQL. it created the Data base and also created the User and send the verification email. but when i clicked on the Linked i got following error.

APPLICATION ERROR 0000401

Database query failed. Error received from database was #0: [Microsoft][ODBC SQL Server Driver]Invalid parameter number for the query: SELECT p.id, p.name, ph.parent_id
FROM mantis_project_table p
LEFT JOIN mantis_project_user_list_table u
ON p.id=u.project_id AND u.user_id=?
LEFT JOIN mantis_project_hierarchy_table ph
ON ph.child_id = p.id
WHERE p.enabled = ? AND
( p.view_state=?
OR (p.view_state=?
AND
u.user_id=? )
)
ORDER BY p.name.

Additional Information

Please Help me to fixed this issue ... I have tried your logged but it failed ... on of the logged said to applied Patch file. i dont knw how to do that. and another log said it will fixed in next released. but it still not fixed i think.

TagsNo tags attached.

Activities

m.junaid86@gmail.com

m.junaid86@gmail.com

2015-06-28 22:08

reporter   ~0050992

I have been working on this since two days ... but unable to setup the Mantis BT.

dregad

dregad

2015-06-29 06:33

developer   ~0050994

Last edited: 2015-06-29 06:33

View 2 revisions

Can you please verify whether this problem exists using version 1.3.0-beta.2
https://www.mantisbt.org/download.php

m.junaid86@gmail.com

m.junaid86@gmail.com

2015-06-30 22:35

reporter   ~0050995

Hi
Thanks for your Feedback ..after using the new version i am not sure whether above thing resolve or not. because i am getting an error on when i try to install

SYSTEM WARNING
'Invalid argument supplied for foreach()' in 'D:\Published\IRSMantisbt\admin\install.php' line 660

Notice: Undefined index: config_id in D:\Published\IRSMantisbt\core\config_api.php on line 140

Notice: Undefined index: user_id in D:\Published\IRSMantisbt\core\config_api.php on line 141

Notice: Undefined index: project_id in D:\Published\IRSMantisbt\core\config_api.php on line 142

Notice: Undefined index: type in D:\Published\IRSMantisbt\core\config_api.php on line 143

Notice: Undefined index: value in D:\Published\IRSMantisbt\core\config_api.php on line 143

Notice: Undefined index: access_reqd in D:\Published\IRSMantisbt\core\config_api.php on line 144

dregad

dregad

2015-07-01 10:37

developer   ~0051000

The reason I mentioned 1.3.0b2 is that there are a number of issues with MSSQL support in 1.2.x, most of which I hope will be fixed by a new release of the underlying DB abstraction layer we use (ADOdb).

With regards to the error messages, it looks like you did not start with a fresh install of 1.3.x (existing config_inc.php file) - this is a known issue, see 0017805. You can either install a nightly build, apply the patch in the mentioned issue, or remove your config file.

For the record, I don't use MSSQL and don't have access to it - I work on Linux environments, so I'm not able to test these things.

dregad

dregad

2019-12-03 07:11

developer   ~0063171

We are resolving this issue as "no change required", because it was reported against an old version of MantisBT which is no longer supported.

We recommend that you upgrade to the latest stable version [1]; if after doing so the problem still exists, do not hesitate to reopen the issue.

[1] http://www.mantisbt.org/download.php

Issue History

Date Modified Username Field Change
2015-06-28 22:07 m.junaid86@gmail.com New Issue
2015-06-28 22:08 m.junaid86@gmail.com Note Added: 0050992
2015-06-29 06:33 dregad Status new => feedback
2015-06-29 06:33 dregad Note Added: 0050994
2015-06-29 06:33 dregad Note Edited: 0050994 View Revisions
2015-06-30 22:35 m.junaid86@gmail.com Note Added: 0050995
2015-06-30 22:35 m.junaid86@gmail.com Status feedback => new
2015-07-01 10:37 dregad Note Added: 0051000
2015-07-01 10:37 dregad Status new => feedback
2019-12-03 07:11 dregad Assigned To => dregad
2019-12-03 07:11 dregad Status feedback => resolved
2019-12-03 07:11 dregad Resolution open => no change required
2019-12-03 07:11 dregad Note Added: 0063171
2019-12-13 18:06 atrol Status resolved => closed