View Issue Details

IDProjectCategoryView StatusLast Update
0016889mantisbtapi soappublic2017-09-11 10:57
Reportervenkateshmpr Assigned Toatrol  
PriorityhighSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
PlatformWindowsOSProfessional 
Summary0016889: Not able to extract closed issue with the SOAP API
Description

Hi MantisBT Team,

I am developing one C# Application to extract data from MantisBT and Export Data to MantisBT using the SOAP API. When try extracting issues it does not return the Closed issues. Is there any way to all the issues from Mantis Including the Closed issues.

Here is the Syntax i have used
client.mc_project_get_issues(connection_username, connection_password, "0", "1", "-1")

Thanks and Regards
Venkatesan

TagsNo tags attached.

Relationships

related to 0010969 closedrombert The issue closed can not be found by mc_project_get_issues API? 

Activities

atrol

atrol

2014-01-28 15:06

developer   ~0039223

Have a look at http://www.mantisbt.org/forums/viewtopic.php?f=3&t=20599
Does this answer your question / fix your issue?

Be aware that you will stress your server if there are a lot of closed issues.

venkateshmpr

venkateshmpr

2014-01-29 00:26

reporter   ~0039227

Last edited: 2014-01-29 02:40

View 2 revisions

Yes Thanks Mr.Atrol,

The Test case which is provided in the case 0010969 is not extracting the closed issue. After Changing the value to

$g_hide_status_default = META_FILTER_NONE;

it works fine extracts all the issues including closed one.

One quick questing is there any possibilities to change this value programmatic ally.

Thanks and Regards
Venkatesan

atrol

atrol

2014-01-29 02:39

developer   ~0039229

Reminder sent to: rombert

The Test case which is provided in the case 0010969 is not extracting the closed issue.

Maybe you want to check this.

atrol

atrol

2014-01-29 02:49

developer   ~0039230

One quick questing is there any possibilities to change this value programmatic ally.

I had a quick look, but didn't find one.

venkateshmpr,

This is not a bug or feature request for MantisBT (you are asking for help on how to configure the system). I am therefore resolving this issue as "no change required".

Please use the forums, the mantisbt-help mailing list or IRC to get support on customizing and using MantisBT (refer to http://www.mantisbt.org/support.php for links and further details).

Especially the mailing list mantisbt-soap-dev ist the best one for questions related to SOAP API.

Issue History

Date Modified Username Field Change
2014-01-27 04:11 venkateshmpr New Issue
2014-01-28 15:06 atrol Note Added: 0039223
2014-01-28 15:06 atrol Status new => feedback
2014-01-28 15:07 atrol Relationship added related to 0010969
2014-01-29 00:26 venkateshmpr Note Added: 0039227
2014-01-29 00:26 venkateshmpr Status feedback => new
2014-01-29 02:39 atrol Note Added: 0039229
2014-01-29 02:40 atrol Note Edited: 0039227 View Revisions
2014-01-29 02:49 atrol Note Added: 0039230
2014-01-29 02:49 atrol Status new => resolved
2014-01-29 02:49 atrol Resolution open => no change required
2014-01-29 02:49 atrol Assigned To => atrol
2014-02-10 04:54 atrol Status resolved => closed