View Issue Details

IDProjectCategoryView StatusLast Update
0015550mantisbtbugtrackerpublic2013-03-15 16:21
Reportercunhamc Assigned Todregad  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version1.2.14 
Summary0015550: Send email doen´t work
Description

Good morning,
I'm having problem with sending email. I setup according to the manual, the SMTP information is correct, but emails do not arrive. There is no error message appears, just not sent the emails.

TagsNo tags attached.

Activities

dregad

dregad

2013-02-27 18:01

developer   ~0035325

Use the admin view to

  • test the e-mail sending functionality.
  • check if e-mails remain in the queue
    If yes, make sure you did not setup your system to send mail asynchronously (i.e. with cron job), and if you did, make sure the cron job works
    Try to set $g_log_level =LOG_EMAIL and check the log file.
cunhamc

cunhamc

2013-02-28 08:47

reporter   ~0035327

Last edited: 2013-02-28 08:47

View 2 revisions

Hi dregad.
I try used the test_email.php and this doen´t work.
a received the follow message: "Testing Mail - PROBLEMS SENDING MAIL TO: test_email@vbsall.com.br. Please check your php/mail server settings."
I set the "$g_log_level =LOG_EMAIL" in the file "config.inc.php", but where are found the log file?

Thanks in advanced.

dregad

dregad

2013-02-28 09:12

developer   ~0035328

Depends where you specified it... see $g_log_destination

cunhamc

cunhamc

2013-02-28 10:12

reporter   ~0035329

Ok.
there isn't $g_log_destination in 'config.inc.php'.
I add $g_log_destination in 'config.inc.php', i try the send email, but the log file did not create.

I need setup something in my 'php.ini'?
My server is running Linux/Debian 6.

cunhamc

cunhamc

2013-02-28 13:12

reporter   ~0035330

Folk´s, my english is very bad, but i´m trying...

I tried outher script '/mantis/scripts/send_emails.php' and receive the follow message: '#!/usr/bin/php -q send_emails.php is not allowed to run through the webserver.'.
What is this? How i fix this problem?

dregad

dregad

2013-03-01 06:11

developer   ~0035340

send_emails.php is meant to be executed from command-line, not from your browser, that's the reason you get the error message.

Make sure the logfile destination you specify is writable by your web server.

cunhamc

cunhamc

2013-03-01 08:55

reporter   ~0035347

Dregad,

The log file was create. In log file i got the follow message:
2013-03-01 10:10 BRT mail ERROR: Message Could not be sent - SMTP Error: Could not authenticate.
But the configuration is right, i tested this configuration in outlook and it worked.

dregad

dregad

2013-03-01 11:06

developer   ~0035352

This error is triggered when a connection was established to your SMTP server, and it requires authentication but you did not provide it (or incorrectly). Please make sure $g_smtp_username and $g_smtp_password are properly set.

cunhamc

cunhamc

2013-03-01 12:46

reporter   ~0035355

The both parameter ($g_smtp_username and $g_smtp_password) i set correctly. I dont know why dont work.
below follow my 'config_inc.php'. I think it may be some error with SMTP MODE, my SMTP server does not use SSL and TLS.

$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'smtp.vbsinformatica.com.br';
$g_smtp_username = 'noreply@vbsinformatica.com.br';
$g_smtp_passoword = '*****';
$g_from_name = 'Mantis Bug Tracker';
$g_smtp_connection_mode = '';
$g_smtp_port = 25;
$g_administrator_email = 'noreply@vbsinformatica.com.br';
$g_webmaster_email = 'noreply@vbsinformatica.com.br';
$g_from_email = 'noreply@vbsinformatica.com.br';
$g_return_path_email = 'noreply@vbsinformatica.com.br';
$g_allow_blank_email = ON;
$g_enable_email_notification = ON;
$g_validate_email = ON;
$g_email_send_using_cronjob = ON;
$g_log_level = LOG_EMAIL | LOG_EMAIL_RECIPIENT | LOG_FILTERING | LOG_AJAX;
$g_log_destination = 'file:/var/www/mantis.log';
dregad

dregad

2013-03-01 18:01

developer   ~0035358

cunhamc,

I see nothing wrong with your config. If your SMTP server does not require TLS/SSL, then your setting of $g_smtp_connection_mode = '' is correct.

The message you see in the log is not caused by MantisBT, it is triggered by your SMTP server because the provided credentials are not correct, as I mentioned previously. I have some doubts that $g_smtp_username = 'noreply@vbsinformatica.com.br' is the correct user for connecting.

In any case, this is not a bug or feature request for MantisBT, but a system configuration problem and therefore I am resolving this issue. Please use the forums, the mantisbt-help mailing list or IRC to get support on customizing and using MantisBT (see http://www.mantisbt.org/support.php)

Issue History

Date Modified Username Field Change
2013-02-27 11:57 cunhamc New Issue
2013-02-27 18:01 dregad Note Added: 0035325
2013-02-27 18:01 dregad Status new => feedback
2013-02-28 08:47 cunhamc Note Added: 0035327
2013-02-28 08:47 cunhamc Status feedback => new
2013-02-28 08:47 cunhamc Note Edited: 0035327 View Revisions
2013-02-28 09:12 dregad Note Added: 0035328
2013-02-28 09:12 dregad Status new => feedback
2013-02-28 10:12 cunhamc Note Added: 0035329
2013-02-28 10:12 cunhamc Status feedback => new
2013-02-28 13:12 cunhamc Note Added: 0035330
2013-03-01 06:11 dregad Note Added: 0035340
2013-03-01 06:11 dregad Status new => feedback
2013-03-01 08:55 cunhamc Note Added: 0035347
2013-03-01 08:55 cunhamc Status feedback => new
2013-03-01 11:06 dregad Note Added: 0035352
2013-03-01 11:06 dregad Status new => feedback
2013-03-01 12:46 cunhamc Note Added: 0035355
2013-03-01 12:46 cunhamc Status feedback => new
2013-03-01 18:01 dregad Note Added: 0035358
2013-03-01 18:01 dregad Status new => resolved
2013-03-01 18:01 dregad Resolution open => no change required
2013-03-01 18:01 dregad Assigned To => dregad
2013-03-15 16:21 atrol Status resolved => closed