View Issue Details

IDProjectCategoryView StatusLast Update
0015339mantisbtadministrationpublic2013-03-19 03:45
Reporteryany Assigned Todregad  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Product Version1.2.12 
Summary0015339: When a developer goes on Holiday...
Description

How should a developer handle the situation in Mantis when he/she goes on holiday but it would be important for the company to have at least one colleague who gets all the issue notifications (email) during that time?

For instance I am the responsive for a category and for all issues that are reported with that category I get an email and of course the issue is assigned automatically to me. However when I go on holiday, nobody else will be notified with those issues and my colleagues won't see them as new or unassigned because all of them are already assigned to me.

Two questions:

  • What is the simplest way to let other colleagues to be notified about my own issues temporarily while I'm on holiday (but still get those issues assigned to me)
  • If there is no such a feature in Mantis, can this be a feature request? :)
Additional Information

I imagine an option in the user preferences where I can name a user (or more users) to be notified and a checkbox whether I am on a holiday or not. I that checkbox is checked (on holiday) then a red notification line should appear on the top of every page that I have checked that option and do not forget about it.

During holiday, listed developers may see the given issues as their own issues, but I am not sure about this.

TagsNo tags attached.

Relationships

duplicate of 0011080 closedcommunity Add a feature to reflect that a user is absent 

Activities

yany

yany

2013-01-02 05:21

reporter   ~0034652

Perhaps another option would be nice if the user can not name any colleague who could replace him/her in his/her job to automatically send back a notification to the reporter (as the emails works usually).

cas

cas

2013-01-02 06:03

reporter   ~0034653

One could connect a group mail-address to your account while on holiday.
Alternative could be to write a plugin that allows for adding an email to the issue. This could be done either within the issue or perhaps even better, within your account settings.

atrol

atrol

2013-01-02 06:34

developer   ~0034656

  • What is the simplest way to let other colleagues to be notified about my own issues temporarily while I'm on holiday (but still get those issues assigned to me)

Temporary change your e-mail address in your account settings

yany

yany

2013-01-02 06:58

reporter   ~0034657

@atrol: Then I won't have those emails waiting in my inbox as well. All this issue is about to have everything the same in mantis during holiday, except that someone else should be notified as well and handle the issue if/when it is necessary.

@cas:

  • Group mail address would be a huge administration overhead just because of holidays and mantis.
  • issue-specific email is a no-solution, how could know the reporter side if a new email address should be attached to the "just-reported" issue? They even don't have to know that I'm on holiday and also they don't have to know if a particular issue is going to be assigned to a colleague who is on holiday (remember, they just set the category)
thraxisp

thraxisp

2013-01-02 07:07

reporter   ~0034658

Would the "monitor" function not work for this? The developers taking over could monitor the issue for activity, and once they contribute a bug note, they will see all traffic on the issue.

As far as a "vacation alert" goes, this is probably better done in your mail client.

yany

yany

2013-01-02 08:07

reporter   ~0034659

Monitor? But when?

Situation:

  • I'm on holiday.
  • A reporter uploads an issue
  • I got a mail about that (noone else)
  • ???

How could others get to know about that report? Or should I send a mail to my colleagues before going on holiday with such a message: "Please take a look at all newly reported issues assigned to me till oct. 29, and subscribe to all of them please to monitor them." ?

I think I dont understand this "monitor hint" or it's a no way too. But thanks for the suggestions I appreciate them all.

dregad

dregad

2013-01-02 08:21

developer   ~0034660

yany, I believe the best way to deal with your requirement would be by setting up a conditional response agent in your e-mail client, i.e. if (sender = Mantis) then foward to XYZ

atrol

atrol

2013-01-02 08:30

developer   ~0034661

0010207 might also be an option for it.

dregad

dregad

2013-01-02 09:19

developer   ~0034663

True, but that requires patching Mantis ;)

yany

yany

2013-01-02 09:33

reporter   ~0034665

dregad, yes, unfortunately I can not see other solution too however it could be hard to do it if some dumber web interface is used for emails where there is no option to make filtered forwards. I don't think this is a real solution but if it's only me who see place for this kind of feature then issue can be closed. ;) And thank you for your support.

cas

cas

2013-01-02 10:58

reporter   ~0034666

Last edited: 2013-01-02 10:59

View 3 revisions

My intention was that any developer could add a backup to his account.
This person would get informed also as soon as this function would be activated within the My Account settings. So not per issue but general by developer (or mantis user to be precise).

yany

yany

2013-01-02 11:06

reporter   ~0034668

cas, sounds very close to my thoughts in additional information section (sorry if I wasn't so clear :$)

cas

cas

2013-01-02 11:14

reporter   ~0034669

"During holiday, listed developers may see the given issues as their own issues, but I am not sure about this." most likely would mean patching mantis.
Not too difficult as a patch, see no direct option plugin-wise (or am i missing something here?).

Notifying the user that this checkbox is activated and ensuring his/her backup receives the email, can be done by plugin.
Optionally start and end-date (11080) could be provided to automate this backup functionality.

dregad

dregad

2013-01-02 17:33

developer   ~0034678

yany (in reply to 0015339:0034665)

I don't think this is a real solution

I did not mean to say this was a "real" solution to your issue, just the easiest workaround immediately available

but if it's only me who see place for this kind of feature then issue can be closed.

I'm sure others would be interested in this kind of feature, no reason to close your report.

And thank you for your support.

Welcome.

cas

cas

2013-01-04 06:35

reporter  

Holidays090.zip (5,020 bytes)
cas

cas

2013-01-04 06:36

reporter   ~0034698

attached an initial version,please test

cas

cas

2013-01-05 05:16

reporter   ~0034706

updates will be provided via issue 11080

dregad

dregad

2013-01-06 06:03

developer   ~0034710

Considering that cas is now working on a plugin to implement the requested feature, I'm resolving this as duplicate of 0011080, please follow up there.

yany

yany

2013-01-08 10:18

reporter   ~0034741

Thank you, I follow the events there...

Issue History

Date Modified Username Field Change
2013-01-02 05:18 yany New Issue
2013-01-02 05:21 yany Note Added: 0034652
2013-01-02 06:03 cas Note Added: 0034653
2013-01-02 06:33 atrol Relationship added related to 0011080
2013-01-02 06:34 atrol Note Added: 0034656
2013-01-02 06:58 yany Note Added: 0034657
2013-01-02 07:07 thraxisp Note Added: 0034658
2013-01-02 08:07 yany Note Added: 0034659
2013-01-02 08:21 dregad Note Added: 0034660
2013-01-02 08:21 dregad Status new => feedback
2013-01-02 08:30 atrol Note Added: 0034661
2013-01-02 09:19 dregad Note Added: 0034663
2013-01-02 09:33 yany Note Added: 0034665
2013-01-02 09:33 yany Status feedback => new
2013-01-02 10:58 cas Note Added: 0034666
2013-01-02 10:59 cas Note Edited: 0034666 View Revisions
2013-01-02 10:59 cas Note Edited: 0034666 View Revisions
2013-01-02 11:06 yany Note Added: 0034668
2013-01-02 11:14 cas Note Added: 0034669
2013-01-02 17:33 dregad Note Added: 0034678
2013-01-02 17:33 dregad Status new => acknowledged
2013-01-04 06:35 cas File Added: Holidays090.zip
2013-01-04 06:36 cas Note Added: 0034698
2013-01-05 05:16 cas Note Added: 0034706
2013-01-06 06:03 dregad Note Added: 0034710
2013-01-06 06:03 dregad Relationship replaced duplicate of 0011080
2013-01-06 06:03 dregad Status acknowledged => resolved
2013-01-06 06:03 dregad Resolution open => duplicate
2013-01-06 06:03 dregad Assigned To => dregad
2013-01-08 10:18 yany Note Added: 0034741
2013-01-17 18:29 atrol Status resolved => closed