View Issue Details

IDProjectCategoryView StatusLast Update
0014032mantisbtfeaturepublic2014-09-23 18:05
Reporterdhaun Assigned Todregad  
PrioritylowSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.2.9 
Target Version1.2.12Fixed in Version1.2.12 
Summary0014032: Allow setting the type of Gravatar identicon
Description

In MantisBT up until 1.2.8, you used to be able to set the type of identicon (i.e. the type of the default user photo when there was no specific photo available) like so:

$g_default_avatar = 'wavatar';

Since that option has been removed in 1.2.9, this no longer works and we're now stuck with the bland pattern identicon.

Can we please have a new option so that we can select the type of identicon (identicon, wavatar, monsterid)?

Additional Information

See http://blog.gravatar.com/2008/04/22/identicons-monsterids-and-wavatars-oh-my/ for the available options.

TagsNo tags attached.

Relationships

related to 0013992 closedvboctor Use Gravatar generated patterns based on email hash for users who don't have avatar 
related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 

Activities

dhaun

dhaun

2012-03-11 15:06

reporter   ~0031426

Since I can't set a relationship: This is due to the changes for issue 0013992

rombert

rombert

2012-03-11 16:49

reporter   ~0031427

Reminder sent to: vboctor

Victor, you might be interested in this report.

Alyndri

Alyndri

2012-03-12 17:18

reporter   ~0031438

This is an issue for our company also. Our team's in a fluster because our default used to be our company logo and now its changed to some weird design.

cyberchriss

cyberchriss

2012-07-20 08:35

reporter   ~0032351

We also had to turn off gravatar feature on our company site, because of these ugly, little placeholders.
I suggest to show nothing, if there is no gravatar and reintergrate the default avatar option which is a nice feature for companies.

dregad

dregad

2012-08-15 09:00

developer   ~0032573

Reintroduced the functionality allowing administrator to use either one of Gravatar's default images (e.g. identicon, wavatar...) or a custom one (identified by an URL), through configuration of $g_show_avatar.

grangeway

grangeway

2013-04-05 17:56

reporter   ~0036181

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master-1.2.x f710546a

2012-08-15 05:32:37

dregad

Details Diff
Allow custom default avatar icons

Following implementation of 0013992, it was no longer possible for
administrators to define a custom default avatar, as Mantis forced use
of Gravatar's 'identicon'.

This commit reintroduces that functionality, and allows use of either
one of Gravatar's default images or a custom one (identified by an URL),
through appropriate configuration of $g_show_avatar.

Fixes 0014032
Affected Issues
0014032
mod - config_defaults_inc.php Diff File
mod - core/print_api.php Diff File
mod - core/user_api.php Diff File
mod - docbook/administration_guide/en/configuration.sgml Diff File

MantisBT: master 06b7b96f

2012-08-15 05:32:37

dregad

Details Diff
Allow custom default avatar icons

Following implementation of 0013992, it was no longer possible for
administrators to define a custom default avatar, as Mantis forced use
of Gravatar's 'identicon'.

This commit reintroduces that functionality, and allows use of either
one of Gravatar's default images or a custom one (identified by an URL),
through appropriate configuration of $g_show_avatar.

Fixes 0014032
Affected Issues
0014032
mod - config_defaults_inc.php Diff File
mod - core/print_api.php Diff File
mod - core/user_api.php Diff File
mod - docbook/Admin_Guide/en-US/Configuration.xml Diff File

MantisBT: master-1.2.x fd20db77

2012-08-15 23:56:07

dregad

Details Diff
Maintain old behavior for default gravatar icons

This is a follow up commit for f710546a49e67cc6d014c46013269415b46a181e
that ensures installations using $g_show_avatar = ON maintain the same
behavior as before. In other words, setting the config to ON is
equivalent to 'identicon'.

Fixes 0014032
Affected Issues
0014032
mod - config_defaults_inc.php Diff File
mod - core/user_api.php Diff File
mod - docbook/administration_guide/en/configuration.sgml Diff File

MantisBT: master 3b4ea93d

2012-08-15 23:56:07

dregad

Details Diff
Maintain old behavior for default gravatar icons

This is a follow up commit for 06b7b96f19834e30d5beaaa2dcb97e4e7f49a28e
that ensures installations using $g_show_avatar = ON maintain the same
behavior as before. In other words, setting the config to ON is
equivalent to 'identicon'.

Fixes 0014032
Affected Issues
0014032
mod - config_defaults_inc.php Diff File
mod - core/user_api.php Diff File
mod - docbook/Admin_Guide/en-US/Configuration.xml Diff File