View Issue Details

IDProjectCategoryView StatusLast Update
0010969mantisbtapi soappublic2016-12-01 11:39
Reportersnails Assigned Torombert  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
OSwin xp sp3 
Product Version1.1.6 
Fixed in Version1.2.0 
Summary0010969: The issue closed can not be found by mc_project_get_issues API?
Description

I have built a tool by C# for exporting all issues to csv file.
I found the issues that was closed can not be get by mc_project_get_issues?
Is that correct?Or is there a way which can get issues closed?

TagsNo tags attached.

Relationships

related to 0021996 feedback Service mc_project_get_issues not return closed issues 
related to 0022001 assigneddregad FilterTest::testGetProjectClosedIssues should fail but does not 
related to 0014747 closedrombert Cannot retrieve closed tickets with mc_project_get_issues 
related to 0016889 closedatrol Not able to extract closed issue with the SOAP API 

Activities

rombert

rombert

2009-10-26 18:16

reporter   ~0023366

2 tests added to confirm that mc_project_get_issues work as expected.

Related Changesets

MantisBT: master-1.2.x 895b7a14

2009-10-26 22:05:11

rombert

Details Diff
Fixes 0010969: Verify that closed issues are retrieved by mc_project_get_issues

Following a bug report which hints that mc_project_get_issues may be ignoring
closed issues, two tests are introduced:

- verify that a newly created issue is retrieved by mc_project_get_issues
with the correct id;
- verify that a newly created issue with closed status is retrieved by
mc_project_get_issues;
Affected Issues
0010969
add - tests/soap/FilterTest.php Diff File

MantisBT: master 571ed585

2009-10-26 22:05:11

rombert

Details Diff
Fixes 0010969: Verify that closed issues are retrieved by mc_project_get_issues

Following a bug report which hints that mc_project_get_issues may be ignoring
closed issues, two tests are introduced:

- verify that a newly created issue is retrieved by mc_project_get_issues
with the correct id;
- verify that a newly created issue with closed status is retrieved by
mc_project_get_issues;
Affected Issues
0010969
add - tests/soap/FilterTest.php Diff File

Issue History

Date Modified Username Field Change
2009-09-20 22:34 snails New Issue
2009-09-21 23:37 vboctor Status new => acknowledged
2009-10-26 18:15 rombert Status acknowledged => assigned
2009-10-26 18:15 rombert Assigned To => rombert
2009-10-26 18:16 rombert Note Added: 0023366
2009-10-26 18:16 rombert Status assigned => resolved
2009-10-26 18:16 rombert Resolution open => unable to reproduce
2009-10-26 18:20 rombert Resolution unable to reproduce => fixed
2009-10-26 18:20 rombert Fixed in Version => 1.3.0-beta.1
2009-10-26 18:20 rombert Changeset attached master-1.2.x 895b7a14 =>
2009-10-26 18:20 rombert Changeset attached master 571ed585 =>
2009-10-28 03:03 vboctor Fixed in Version 1.3.0-beta.1 => 1.2.2
2010-02-22 14:35 jreese Status resolved => closed
2012-09-26 13:22 dregad Relationship added related to 0014747
2014-01-28 15:07 atrol Relationship added related to 0016889
2016-12-01 08:28 dregad Relationship added related to 0021996
2016-12-01 11:39 dregad Relationship added related to 0022001