View Issue Details

IDProjectCategoryView StatusLast Update
0010236mantisbtcustomizationpublic2016-04-24 06:19
ReporterprabhuranganAssigned Tovboctor  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.2.0a3 
Summary0010236: Due_date field is not shown in All Column Fields?
Description

Due_date field cannot be seen in any of the view_issue, bug_update. It is there in bug_advanced_update page, however if i update that field it is not updating; Instead the default due_date in the bug table.

TagsNo tags attached.

Activities

cas

cas

2009-03-20 09:36

reporter   ~0021130

Thi is correct, I already have adjusted scripts for that which i will make availabel later today.

prabhurangan

prabhurangan

2009-03-20 09:53

reporter   ~0021131

@cas

Thanks for your early reply.

2009-03-20 12:22

 

DueDate_column.zip (10,758 bytes)
cas

cas

2009-03-20 12:24

reporter   ~0021132

Attached zip contain3 files which belong in the core directory.
As always, first make a backup.
should only be used as of 1.2.0a3

cas

cas

2009-03-21 04:13

reporter   ~0021138

Last edited: 2009-03-21 04:24

This post looks wrongly placed. I just posted those scripts needed to embed the due date column in a number of places.
You talk about the csv_import (issue most likely is about formatting).
Adding this field on the overview page can be done on the mange_column page.
As for showing on the bug_update pages, remember Mantis shows it only on the advanced page so you have to adjust the code to show up in other pages.

2009-03-21 05:25

 

due_date_report.zip (11,484 bytes)
cas

cas

2009-03-21 05:26

reporter   ~0021139

Attached my files to enable seeing/adjusting due date on the simple reports.

prabhurangan

prabhurangan

2009-03-21 05:48

reporter   ~0021140

@cas

I have an issue with this, i have made the patch work done by you, regarding due_date, in my view_issue, bug_update and bug_update page. However if i update the due_date(ie. im setting up the due date), but it is not seen in view_issues_page.php.

In view_issues page the due_date column is still empty, it is not showing the updated due_date.

prabhurangan

prabhurangan

2009-03-21 05:54

reporter   ~0021141

Also how to set the 'due_date' or any other column field to be mandatory, while creating bugs or updating bugs

cas

cas

2009-03-23 04:43

reporter   ~0021147

I suppose you mean in this page, view_all_bug_page.php?
Go to manege configuration, manage columns and add the due-date field to the view issues columns.
make sure you do it for the right project !

prabhurangan

prabhurangan

2009-03-23 04:51

reporter   ~0021148

@cas

Yes cas. I have done with what you said; however if i create a new bug, and set any date for 'due_date' field, it is not updated. And again when we view the created bug, the 'due_date' field is empty.

Please to make sure, can you please create a new bug, and set an 'due_date' for it and look it in view.php page for the particular bug that you have created recently.

I think the queries for 'bug_create' and 'bug_update' has to be updated.

cas

cas

2009-03-23 06:55

reporter   ~0021150

The due_date has a default value of "1970-01-01 00:00:01" so will always be filled.
In addition, you need the lines in conf_inc.php:
$g_due_date_update_threshold = REPORTER;
$g_due_date_view_threshold = VIEWER;
In case you need to have a due-date, just fill it with todays date.
Then open up bugreport(advanced_)page.php and change this line:
$f_due_date = date_get_null();
into:
$f_due_date = mktime(0,0,0,date("m"),date("d"),date("Y"));

No need to change anything else.

prabhurangan

prabhurangan

2009-03-23 07:27

reporter   ~0021151

Dear Cas,

I did the same, but the due_date does not gets set.

What I did is, reported a new bug, in which i have filled 'due_date' field and other required fields, and submit the report and when it redirects to view bug page, i do not see the due_date field filled. Instead it is being empty.

Can you please refer to it.

prabhurangan

prabhurangan

2009-03-23 07:28

reporter   ~0021152

In case if we need to set the due_date to future date, it wont be an issue, am i right? Because i gave some future date in due_date field.

cas

cas

2009-03-23 09:53

reporter   ~0021153

Is your installation accessible from the outside?

prabhurangan

prabhurangan

2009-03-23 10:11

reporter   ~0021154

Last edited: 2009-03-30 01:04

No cas it can't be accessible.

cas

cas

2009-03-23 12:06

reporter   ~0021156

Sorry,
all works fine in my version 1.2.0a3.
Perhaps you need to review all adjustements made in this post.

prabhurangan

prabhurangan

2009-03-23 12:18

reporter   ~0021157

Cas

Could you please zip/attach of mantis 1.2.0a3 which you have done and so that i can check with the changes you have made. The php files under 'mantis1.2.0a3/core/' and 'mantis1.2.0a3/'.

2009-03-23 12:35

 

duedate.zip (37,744 bytes)
cas

cas

2009-03-23 12:35

reporter   ~0021158

Attached, renamed config_inc.php

prabhurangan

prabhurangan

2009-03-24 00:47

reporter   ~0021167

Dear Cas

Even in the code which you have send me, has the same issue which i am facing. In report issues page, i am having due_date field, with the 'current_date' but once we click the 'SUBMIT' button to create issues.

Then in the view_issues page of the particular bug that we have created does not have the due_date to be set; Instead it is seen empty.

Let me attach you the screen shot of it. 'report_issue_scren_shot.gif' and 'view_issues_screen_shot.gif'

2009-03-24 00:47

 

view_issues_screen_shot.gif (77,590 bytes)   
view_issues_screen_shot.gif (77,590 bytes)   

2009-03-24 00:48

 

report_issue_screen_shot.gif (56,104 bytes)   
report_issue_screen_shot.gif (56,104 bytes)   
prabhurangan

prabhurangan

2009-03-24 00:49

reporter   ~0021168

@cas

You could see the screen shot, i am selecting tomorrow's date as 'due_date' in report_issues page, but which is not been seen in view_issues page.

cas

cas

2009-03-24 03:21

reporter   ~0021169

Check your database, updating fails hence showing null.

prabhurangan

prabhurangan

2009-03-24 03:32

reporter   ~0021170

yes cas; i have checked my database, it is not updating. In my database; due_date field is DATETIME and NOT NULL with default value '1970-01-01 00:00:00'

But then there is some issue in update query, am i right? Also for me while creating bug also i face the same issue;

Can you please send me your 'bug_api.php' where we have function for bug_create and bug_update.

Or could you please let me the know the exact place to change/tune the query to update or create bug with due_date field.

prabhurangan

prabhurangan

2009-03-24 04:13

reporter   ~0021172

Cas

Sorry cas, it is my mistake; due_date accepts only '2009-03-24 00:00:00' this format, but i was trying to '03-24-09' this format. So it throws an error as incorrect date function.

The function which you are using 'mktime(0,0,0, date("d"), date("m"), date("y"));' with this how to attain the format for '2009-03-24 00:00:00' with DATETIMe format.

cas

cas

2009-03-24 05:04

reporter   ~0021174

You can define your date settings in config_inc.php (see config_inc_defaults.php)

prabhurangan

prabhurangan

2009-03-25 00:59

reporter   ~0021183

Yes cas, thanx a lot and one more issue i am facing; In FC10(linux) machine, if i select today's date say '2009-03-25', using the 'date picker' and while viewing in the text box, it shows as '2009-03-24' it is reducing one day. But it is working fine in windows machine.

What ever date i am selecting one day it is reducing.

prabhurangan

prabhurangan

2009-03-25 01:17

reporter   ~0021184

Also, i have checked the same code that is in linux machine, working fine in windows machine.

Does the date format depends on apache or php.

prabhurangan

prabhurangan

2009-03-25 05:02

reporter   ~0021186

@Cas

I have to make the due_date field as a mandatory field in report_issue page, update_issue page, how to perform it...

Regards,
Prabhu

prabhurangan

prabhurangan

2009-03-25 10:03

reporter   ~0021189

@cas

among the attachments you have given me, I see a file named 'custom_function_inc.php'. What for it is used. Because i did not use it anywhere.

Please let me know where the file should be placed, and how it is handled....

prabhurangan

prabhurangan

2009-03-26 00:39

reporter   ~0021192

@cas

While reporting a new bug, If i am not selecting any date for due_date field, it should highlight with the default date, but it is not getting the default date in view_issues page, instead i could see the default date in the view_all_issues page.

cas

cas

2009-03-26 03:57

reporter   ~0021193

As for the additional file see http://www.mantisbt.org/bugs/view.php?id=10237

As for the date, I have difficulty giving an answer since it will vary upon your config of the date settings.

prabhurangan

prabhurangan

2009-03-26 04:18

reporter   ~0021194

@cas

my date configuration is as

short_date='Y-m-d'
normal_date='Y-m-d H:s'
common_date='Y-m-d H:s T'

Can you please brief me why the date selected is reduced to one day, when testing in LINUX(FC10) machine.

cas

cas

2009-03-26 04:29

reporter   ~0021196

As for the reduction of 1 day, I guess this was by design. If it needs to be done by March 26, it should be finished on March 25th.
By prefilling the fiedl when creating the issue, the field to me looks mandatory.

As for the customfield, if you want it to be mandatory, make sure you also select it to be required on the correct douments.

prabhurangan

prabhurangan

2009-03-26 04:36

reporter   ~0021197

@cas

However, i do not see this pre-filling of 1 day in windows machine.

I have my mantis 1.2.0a3 application both in LINUX and windows machine, which has the same code, but in linux as you said it was by design, '1' day is reduced.

But it should also function the same way in Windows. But it is not..

Do you have any idea or have you faced this.....

cas

cas

2009-03-26 14:36

reporter   ~0021217

Sorry, works the same for me.

prabhurangan

prabhurangan

2009-03-31 00:45

reporter   ~0021324

@cas

could you please help me out in issue 0010255, how to add 'updated by' username who updates a particular bug, in view_all_bug_page.php.

prabhurangan

prabhurangan

2009-04-01 06:36

reporter   ~0021351

@cas & All

Thanks cas. If you find any solution for this 'due_date' field with different functionalities in LINUX and WINDOWS, Please let me know.

And regarding http://www.mantisbt.org/bugs/view.php?id=10255, I have added a new column in 'mantis_bug_table' and wrote a TRIGGER FUNCTION in 'mantis_bug_history_table'. And added 'updated_by' field in 'mantis/core/columns_api.php' file.

But this is not a perfect solution i am sure.. If you find any solution please let me know..

Thanks a lot for your help.

vboctor

vboctor

2016-04-12 22:48

manager   ~0052947

As per this instance, due_date is available as a column for View Issues, Print Issues, CSV Export and Excel Export. Am I missing something here?

cas

cas

2016-04-13 03:21

reporter   ~0052948

This is no longer an issue and should have been closed.
Now all handled via standard mantis.

Issue History

Date Modified Username Field Change
2009-03-20 07:41 prabhurangan New Issue
2009-03-20 09:36 cas Note Added: 0021130
2009-03-20 09:53 prabhurangan Note Added: 0021131
2009-03-20 12:22 cas File Added: DueDate_column.zip
2009-03-20 12:24 cas Note Added: 0021132
2009-03-21 04:13 cas Note Added: 0021138
2009-03-21 04:24 cas Note Edited: 0021138
2009-03-21 05:25 cas File Added: due_date_report.zip
2009-03-21 05:26 cas Note Added: 0021139
2009-03-21 05:48 prabhurangan Note Added: 0021140
2009-03-21 05:54 prabhurangan Note Added: 0021141
2009-03-23 04:43 cas Note Added: 0021147
2009-03-23 04:51 prabhurangan Note Added: 0021148
2009-03-23 06:55 cas Note Added: 0021150
2009-03-23 07:27 prabhurangan Note Added: 0021151
2009-03-23 07:28 prabhurangan Note Added: 0021152
2009-03-23 09:53 cas Note Added: 0021153
2009-03-23 10:11 prabhurangan Note Added: 0021154
2009-03-23 12:06 cas Note Added: 0021156
2009-03-23 12:18 prabhurangan Note Added: 0021157
2009-03-23 12:35 cas File Added: duedate.zip
2009-03-23 12:35 cas Note Added: 0021158
2009-03-24 00:47 prabhurangan Note Added: 0021167
2009-03-24 00:47 prabhurangan File Added: view_issues_screen_shot.gif
2009-03-24 00:48 prabhurangan File Added: report_issue_screen_shot.gif
2009-03-24 00:49 prabhurangan Note Added: 0021168
2009-03-24 03:21 cas Note Added: 0021169
2009-03-24 03:32 prabhurangan Note Added: 0021170
2009-03-24 04:13 prabhurangan Note Added: 0021172
2009-03-24 05:05 cas Note Added: 0021174
2009-03-25 00:59 prabhurangan Note Added: 0021183
2009-03-25 01:17 prabhurangan Note Added: 0021184
2009-03-25 05:02 prabhurangan Note Added: 0021186
2009-03-25 10:03 prabhurangan Note Added: 0021189
2009-03-26 00:39 prabhurangan Note Added: 0021192
2009-03-26 03:57 cas Note Added: 0021193
2009-03-26 04:18 prabhurangan Note Added: 0021194
2009-03-26 04:29 cas Note Added: 0021196
2009-03-26 04:36 prabhurangan Note Added: 0021197
2009-03-26 14:36 cas Note Added: 0021217
2009-03-30 01:04 prabhurangan Note Edited: 0021154
2009-03-31 00:45 prabhurangan Note Added: 0021324
2009-04-01 06:36 prabhurangan Note Added: 0021351
2016-04-12 22:48 vboctor Note Added: 0052947
2016-04-13 03:21 cas Note Added: 0052948
2016-04-14 10:36 vboctor Assigned To => vboctor
2016-04-14 10:36 vboctor Status new => resolved
2016-04-14 10:36 vboctor Resolution open => fixed
2016-04-24 06:19 atrol Status resolved => closed