PostgreSQL configuration

Get help from other users here.

Moderators: Contributor, Developer

PostgreSQL configuration

Postby HUN73R » Feb 26, 2008 11:47 am

Hi,

this is my first post, and I´m new on Mantis.

I´m trying to configure Instant Mantis (v1.1.1) on a Apache server (v2.0.63 - win32) with PHP (v5.2.6 - win32).
The Apache and PHP are properly set and running...

but I´m having problems to set up the Mantis to access a PostgreSQL (v8.2.5-1) database.

OS: WinXP SP2

I searched the web but didn´t find anything useful.

Any help is welcome!! :D

Thank you,
HUN73R.
HUN73R
 
Posts: 21
Joined: Feb 26, 2008 11:27 am
Location: Campinas, SP - Brazil

Re: PostgreSQL configuration

Postby smig1o » Feb 27, 2008 7:58 am

HUN73R wrote:Hi,

this is my first post, and I´m new on Mantis.

I´m trying to configure Instant Mantis (v1.1.1) on a Apache server (v2.0.63 - win32) with PHP (v5.2.6 - win32).
The Apache and PHP are properly set and running...

but I´m having problems to set up the Mantis to access a PostgreSQL (v8.2.5-1) database.

OS: WinXP SP2

I searched the web but didn´t find anything useful.

Any help is welcome!! :D

Thank you,
HUN73R.


Owwww... my head..
Can you be more descriptive?
What kind of problems??
We arnet a wizards...
'Press any key to continue or any other key to quit'
smig1o
 
Posts: 39
Joined: Nov 30, 2006 7:26 am
Location: Poznan - PL

Re: PostgreSQL configuration

Postby HUN73R » Feb 27, 2008 9:09 am

Owwww... my head..
Can you be more descriptive?
What kind of problems??
We arnet a wizards...


Ok, sorry..

I don´t know which files to change, nor which params are needed..

I can run the Mantis using mysql, but I do need it running on PostgreSQL

There´s a "config_inc.php" file below the \mantis folder...I changed it, now it looks like:
<?php $g_hostname='localhost';$g_db_type='pgsql';$g_database_name='mantis_db';$g_db_username='postgres';$g_db_password='postgres'; ?>

Is it right?
what else do I have to do?

When I try the "install.php", the shown result is all good except for "Checking PHP support for database type" and "Attempting to connect to database as admin"

I´m really lost hehe

Thank you again!
HUN73R
HUN73R
 
Posts: 21
Joined: Feb 26, 2008 11:27 am
Location: Campinas, SP - Brazil

Re: PostgreSQL configuration

Postby HUN73R » Feb 28, 2008 1:42 pm

Ok guys,

that was an error in "php.ini" file!

the line responsible for identify pgsql was commented =/

now everything is ok =)

thank for your attention!

HUN73R.
HUN73R
 
Posts: 21
Joined: Feb 26, 2008 11:27 am
Location: Campinas, SP - Brazil

Re: PostgreSQL configuration

Postby smig1o » Feb 28, 2008 2:55 pm

Add two wings of bats, a dragon scale, 2 breaths of frog
I knew it will work!!!
'Press any key to continue or any other key to quit'
smig1o
 
Posts: 39
Joined: Nov 30, 2006 7:26 am
Location: Poznan - PL

Re: PostgreSQL configuration

Postby HUN73R » Feb 29, 2008 11:40 am

hahaha you were right xD

but now I have other problem..

when I try to log on as 'Administrator / root', the system shows "Your account may be disabled or blocked or the username/password you entered is incorrect"

I checked the data base and there´s an account with these values, so it should connect and log on, right?

I know these doubts are too foolish, but consider please! I´m new on Mantis and PHP...and I need your help =)

Thank you again!

HUN73R.
HUN73R
 
Posts: 21
Joined: Feb 26, 2008 11:27 am
Location: Campinas, SP - Brazil


Return to Help

Who is online

Users browsing this forum: Bing [Bot] and 11 guests