Dokuwiki integration CSP errors after upgrade

Get help from other users here.

Moderators: Contributor, Developer

Dokuwiki integration CSP errors after upgrade

Postby TomR » Nov 14, 2017 11:01 am

Dokuwiki integration gives all kind of CSP errors after upgrade 1.2.20 -> 2.x

Upgrading from 1.2.20 to version 2.x leads to a lot of CSP errors when opening wiki pages with wiki integration from MantisBT
Attachments
CSP-Dokuwiki.png
Developer Tools
CSP-Dokuwiki.png (75.39 KiB) Viewed 186 times
TomR
 
Posts: 48
Joined: Aug 01, 2006 5:22 am

Re: Dokuwiki integration CSP errors after upgrade

Postby TomR » Nov 15, 2017 7:33 am

https://www.mantisbt.org/bugs/view.php?id=19576 seems to solve the problem,
But that effectively disables CSP al together which seems a bit drastic.

In config_inc.php
Code: Select all
$g_custom_headers = array( 'Content-Security-Policy:' );
TomR
 
Posts: 48
Joined: Aug 01, 2006 5:22 am

Re: Dokuwiki integration CSP errors after upgrade

Postby atrol » Nov 16, 2017 4:34 am

Also to follow up for other users https://www.mantisbt.org/bugs/view.php?id=23635
Please use Search before posting and read the Manual
Use Mantis2Go to try MantisBT on Windows or to reproduce issues
atrol
Site Admin
 
Posts: 6711
Joined: Mar 26, 2008 4:37 pm
Location: Germany


Return to Help

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 22 guests