Email Settings for Company Email not sending emails

Get help from other users here.

Moderators: Contributor, Developer

Email Settings for Company Email not sending emails

Postby mckintyre » Nov 11, 2017 2:17 am

First of all, I setup my Mantis for localhost use only but I want to send emails to the accounts I created.
I am using XAMPP on Windows 10. I'm using the latest Mantis2.8

YES, I WAS ABLE TO UNCOMMENT: extension=php_openssl.dll;

My problem is this, I tried testing with the gmail settings and I was able to send emails thru Gmail. So that's about it with GMAIL.

I now want to send emails using our host server which is bluehost.

I followed many configurations but to no avail.

I checked the email_queue.php and all the emails were still there and was not sending.
I tried the testing email button which is pointed to my company email I get this error all the time:

"Testing Mail - PROBLEMS SENDING MAIL TO: xxxxx.xxxxx@xxxx.com. Please check your php/mail server settings."


here is my config_inc.php email configuration
-------------------------------------------------------------------------------------------------
$g_allow_signup = ON;
$g_enable_email_notification = ON;
$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'mail.domain.com';
$g_smtp_connection_mode = 'tls';
$g_smtp_port = 465;
$g_smtp_username = 'xxxxx.xxxxx@xxxx.com';
$g_smtp_password = '***************';
$g_administrator_email = 'xxxxx.xxxxx@xxxx.com';
$g_webmaster_email = 'xxxxx.xxxxx@xxxx.com';
--------------------------------------------------------------------------------------------------
mckintyre
 
Posts: 3
Joined: Nov 11, 2017 2:01 am

Re: Email Settings for Company Email not sending emails

Postby pavelbedi » Nov 11, 2017 6:05 am

I have problem too. If I set camosoft@camosoft.cz it not work, but if I set name@camosoft.cz it work. It is strange. PHP mail() work only if I test it, but for notifications not working.
pavelbedi
 
Posts: 2
Joined: Nov 08, 2017 3:26 pm

Re: Email Settings for Company Email not sending emails

Postby Frans » Nov 11, 2017 10:56 am

Same here:

$g_enable_email_notification = ON; //enables the email messages
$g_phpMailer_method = PHPMAILER_METHOD_SMTP;
$g_smtp_host = 'smtp.mail.xxxxxxxxx';
$g_smtp_connection_mode = 'tls';
$g_smtp_port = 587;
$g_smtp_username = xxxxx'; //user mail address
$g_smtp_password = 'xxxxx'; //user mail password
$g_administrator_email = xxxxx'; //this is the administrator email address



been trying for hrs now. MantisBT 2.8.0, scheme 209
Frans
 
Posts: 2
Joined: Nov 11, 2017 10:49 am

Re: Email Settings for Company Email not sending emails

Postby Frans » Nov 11, 2017 6:31 pm

There has been an updat eon my last post:

My provider is blocking is actively. Reason:

Domain unknown
Sender is forged (different From: header and smtp MAIL FROM: addresses)
SPF verification failed


That is, again, after carefully following the explanations in tuits. Now, i can dive inside code but i was hoping that i could take care of my own code and this was helkping me... ;)
Frans
 
Posts: 2
Joined: Nov 11, 2017 10:49 am

Re: Email Settings for Company Email not sending emails

Postby mckintyre » Nov 13, 2017 3:55 am

UPDATE ON MY ISSUE.

----------------------------------------------------THIS IS WHAT THE LOG FILE SAYS--------------------------------------------------------------------------
2017-11-13 09:37 CET MAIL email_api.php:527 email_signup() Signup Email = brylle.mckintyre@x-gears.com, Hash = Wsr835ELGl6U4uwTorMWAXz9ol5HiTcZ_8VAxmoeTWuxXDib1DNIp9bnNHZWufn9UzO3beXpz14O4JE1e-Ac, User = @U6
2017-11-13 09:37 CET MAIL email_api.php:581 email_notify_new_account() New account for user bryllemckintyre
2017-11-13 09:37 CET MAIL email_api.php:599 email_notify_new_account() New Account Notify for email = 'mantisxgears@gmail.com'
2017-11-13 09:37 CET MAIL email_api.php:527 email_signup() Signup Email = bry.aldwin@gmail.com, Hash = U5corhiuuxPzwiGWYortlBmzWRDCbr33A0bmsnVAu17SumKJf8g2i5dTaBmanWExYU_i4yrcr7Kef1RFlNEK, User = @U7
2017-11-13 09:37 CET MAIL email_api.php:581 email_notify_new_account() New account for user brylle
2017-11-13 09:37 CET MAIL email_api.php:599 email_notify_new_account() New Account Notify for email = 'mantisxgears@gmail.com'
----------------------------------------------------------------------------------------------------------------------------------------------------------------------

I AM ABLE TO GET NOTIFICATIONS FOR:
-mantisxgears@gmail.com
-bry.aldwin@gmail.com

BUT I DON'T GET ANY IN MY:
-brylle.mckintyre@x-gears.com

I HAVE TESTED THE MAIL TEST UNDER /mantis/admin/email_queue.php
and it says: "Your PHP mail settings appear to be correctly set."

BUT I STILL DO NOT GET ANY NOTIFICATIONS ON MY WEBMAIL.
mckintyre
 
Posts: 3
Joined: Nov 11, 2017 2:01 am

Re: Email Settings for Company Email not sending emails

Postby pavelbedi » Nov 19, 2017 11:00 am

I've solved it!

Code: Select all
$g_return_path_email = 'email@domain.com';

must be same as
Code: Select all
$g_smtp_username = 'email@domain.com';
pavelbedi
 
Posts: 2
Joined: Nov 08, 2017 3:26 pm


Return to Help

Who is online

Users browsing this forum: Google [Bot] and 13 guests