Signup new users automatically doesn't work

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Contributor, Developer

Signup new users automatically doesn't work

Postby che » Dec 08, 2011 4:36 pm

but is set to yes.
Please, help to debug it, I really need this feature

Mantis 1.2.8
EmailReporting 0.8.4

(btw, maybe I should use 0.90? But I can't find it)
che
 
Posts: 2
Joined: Dec 08, 2011 4:22 pm

Re: Signup new users automatically doesn't work

Postby SL-Gundam » Dec 09, 2011 12:19 pm

Please go here and follow the links for the source code: http://www.mantisbt.org/wiki/doku.php/m ... lreporting

MantisBT dev team made a change in 1.2.6 which glitched the user creation process a little bit. It is fixed in 0.9.0-DEV
SL-Gundam
 
Posts: 191
Joined: Jul 06, 2011 9:17 am

Re: Signup new users automatically doesn't work

Postby che » Dec 09, 2011 3:14 pm

I went to <path_to_mantis>/plugins, moved existing EmailReporting to EmailReporting.bak, then
git clone https://github.com/mantisbt-plugins/EmailReporting.git

I see in Managing plugins Email Reporting 0.9.0-DEV, but now it become a little bit worse:
- no delete of processed email from the mailbox
- still no auto add new users
che
 
Posts: 2
Joined: Dec 08, 2011 4:22 pm

Re: Signup new users automatically doesn't work

Postby SL-Gundam » Dec 10, 2011 2:34 pm

run bur_report_mail manually to see if it produces any errors while processing emails

also please give me more information about your environment (webserver, mail server, OS etc.)
SL-Gundam
 
Posts: 191
Joined: Jul 06, 2011 9:17 am

Re: Signup new users automatically doesn't work

Postby MCBurner » Jan 19, 2012 10:02 am

Hi.

I'm going to add my problem with the email reporting plugin to this thread as it's almost the same. Almost - because it stopped working!

The problem: I've used the plugin very successfull also with auto signup enabled. All bug reports sent via email were picked up, the user account was created if it doesn't exist and the bug report was created.
But it stopped two days ago to do so. And I really can't find the reason. The emails still come to the same box and if I check them - they are all marked as read. And that means - the plugin still picks them up.
But now only emails sent from already known users are successfully created as bug reports.

Any idea? I did no changes to Mantis since last week (no code changes, no plugins, no config changes).

Thanks in advance.

Regards.
My Mantis Installation: MantisBT-Version 1.2.8 - Schema-Version 183
Plugins: Email Reporting 0.8.4 used with WebMail (IMAP)
WebServer OS Linux 2.6.32-37 Ubuntu
PHP Version 5.3.8-nmm1
MySQL Server Version: 5.1.43
MCBurner
 
Posts: 18
Joined: Nov 14, 2011 7:56 am

Re: Signup new users automatically doesn't work

Postby SL-Gundam » Jan 19, 2012 11:27 am

The same also applies to you. We need more information about your environment (webserver, mail server, OS, version of MantisBT, version of EmailReporting etc.).
SL-Gundam
 
Posts: 191
Joined: Jul 06, 2011 9:17 am

Re: Signup new users automatically doesn't work

Postby MCBurner » Jan 20, 2012 4:22 am

I've added some info about my installation to my signature. Hope that helps.

In meantime I found out that the creation of tickets still works if I set the plugin to use the "Enable fallback to default reporter" function. The "Preferred username for new user creations " option is now set to name, but it either doesn't work with "email address" or "email address without domain name". I also can say that there are no new entries in the mantis db tables "mantis_user_table" or "mantis_bug_table". I only wanted to highlight that because in the past I had sometimes problems with tickets created by email because they were assigned to a wrong category and finally not shown in Mantis - but they were in the database.

I could live with the default reporter fallback enabled but this means I can't email to the sender directly from Mantis. Not a good idea.... :-(
My Mantis Installation: MantisBT-Version 1.2.8 - Schema-Version 183
Plugins: Email Reporting 0.8.4 used with WebMail (IMAP)
WebServer OS Linux 2.6.32-37 Ubuntu
PHP Version 5.3.8-nmm1
MySQL Server Version: 5.1.43
MCBurner
 
Posts: 18
Joined: Nov 14, 2011 7:56 am

Re: Signup new users automatically doesn't work

Postby SL-Gundam » Jan 20, 2012 9:04 pm

This is the same problem as earlier specified in this topic. This is not something that suddenly stopped working

The MantisBT team was nice enough to change the name of some constants in version 1.2.6, namely:
- USERLEN renamed to DB_FIELD_SIZE_USERNAME
- REALLEN renamed to DB_FIELD_SIZE_REALNAME

So it stopped working when you upgraded MantisBT to 1.2.6 or higher

To fix this you need to upgrade EmailReporting to 0.9.0-DEV. Go here to find out how to get that version: http://www.mantisbt.org/wiki/doku.php/m ... lreporting

Keep in mind that thats a development version and so it is not recommended for production environments. So understand the risks before you update EmailReporting
SL-Gundam
 
Posts: 191
Joined: Jul 06, 2011 9:17 am

Re: Signup new users automatically doesn't work

Postby MCBurner » Jan 23, 2012 5:55 am

SL-Gundam wrote:This is the same problem as earlier specified in this topic. This is not something that suddenly stopped working


That's not correct for my situation. I've never used an older version of Mantis. Since the first day I'm using it it was 1.2.8. And the plugin worked before.
But I'm going to check the 0.9dev version which may solve it.

Regards.
My Mantis Installation: MantisBT-Version 1.2.8 - Schema-Version 183
Plugins: Email Reporting 0.8.4 used with WebMail (IMAP)
WebServer OS Linux 2.6.32-37 Ubuntu
PHP Version 5.3.8-nmm1
MySQL Server Version: 5.1.43
MCBurner
 
Posts: 18
Joined: Nov 14, 2011 7:56 am

Re: Signup new users automatically doesn't work

Postby MCBurner » Jan 23, 2012 6:23 am

Yup - upgrade to 0.9dev also fixed my problem. So I'm now still wondering why it worked before - but there's no need to investigate :-)
Thanks!!
My Mantis Installation: MantisBT-Version 1.2.8 - Schema-Version 183
Plugins: Email Reporting 0.8.4 used with WebMail (IMAP)
WebServer OS Linux 2.6.32-37 Ubuntu
PHP Version 5.3.8-nmm1
MySQL Server Version: 5.1.43
MCBurner
 
Posts: 18
Joined: Nov 14, 2011 7:56 am


Return to EmailReporting

Who is online

Users browsing this forum: No registered users and 1 guest