"-ERR Protocol error: 16" with POP3 Exchange 2010

This plugin allows you to report an issue in MantisBT by sending an email to a particular mail account

Moderators: Contributor, Developer

"-ERR Protocol error: 16" with POP3 Exchange 2010

Postby jordanvanbergen » Jul 11, 2013 2:26 pm

Using EmailReporting 0.9.0-DEV to get a pop3 e-mail account we get the following message:

"-ERR Protocol error: 16"

On this website http://it.ubc.ca/projects/completed_pro ... own_Issues we read:

EUDORA
Certificate Error using POP/IMAP/SMTP using Eudora (Mac)
(SOLUTION FOUND)

The Exchange 2007 environment is using a new security certificate called a Unified Communications Certificate which doesn't work very well with legacy e-mail applications. Customers may receive the following error: "Error while checking mail for <<Dominant>>: I said: PASS And then the POP server said: -ERR Protocol error: 16"

To resolve this error, use the following steps:

a) In Eudora, click on the "File" menu at the top of the screen and select "New Text Document".
b) In the New Text Document window, enter the following text:
x-eudora-setting:12909=PLAIN
c) The text will turn blue. Double-click on the blue text.
d) Click the "Set Setting" button.
e) Restart the Eudora e-mail application.
f) You should now be able to receive/send mail now.

Using Telnet everythings works or using a tool like email remover. So the POP3 user/password combination is working with other clients. Clients tested: telnet / outlook 2010 and E-mail remover: http://www.email-remover.com/

Only Email Reporing 0.8.2-DEV and 0.9.0-DEV are giving this "-ERR Protocol error: 16" error message.

Anyone knows what's going on?

Best regards
Jordan
jordanvanbergen
 
Posts: 2
Joined: Jul 11, 2013 2:20 pm

Re: "-ERR Protocol error: 16" with POP3 Exchange 2010

Postby SL-Gundam » Jul 11, 2013 4:09 pm

What kind of "Authentication method" are you using for the mailbox in the EmailReporting settings?

I'm using EmailReporting 0.9.0-DEV just fine against POP3 Exchange 2010.
SL-Gundam
 
Posts: 422
Joined: Jul 06, 2011 9:17 am

Re: "-ERR Protocol error: 16" with POP3 Exchange 2010

Postby jordanvanbergen » Jul 12, 2013 2:38 am

SL-Gundam wrote:What kind of "Authentication method" are you using for the mailbox in the EmailReporting settings?

I'm using EmailReporting 0.9.0-DEV just fine against POP3 Exchange 2010.


I was using USER. With APOP it's working now. Please let me know if you are using APOP as well as all other "Authentication methods" will fail with an -ERR protocol number (16/17) error.

Best regards
Jordan
jordanvanbergen
 
Posts: 2
Joined: Jul 11, 2013 2:20 pm

Re: "-ERR Protocol error: 16" with POP3 Exchange 2010

Postby SL-Gundam » Jul 12, 2013 10:08 am

I'm using "USER".

It might be that you've set Exchange 2010 to be stricter on what kind of authentications are allowed. Plain or USER is the very base authentication available and the least secure one
SL-Gundam
 
Posts: 422
Joined: Jul 06, 2011 9:17 am

Re: "-ERR Protocol error: 16" with POP3 Exchange 2010

Postby pablopb » Aug 07, 2017 2:15 pm

believe me that I am still using Eudora under osx 10.6.8 (cos I am still using FreeHand), and I had this problem that I resolve with this steps. A lot of thanks, it was helpfull. Ed.
pablopb
 
Posts: 1
Joined: Aug 07, 2017 2:10 pm


Return to EmailReporting

Who is online

Users browsing this forum: No registered users and 4 guests