Upgrade de vieille version

MantisBT forum for users who prefer to ask and answer questions in French.

Moderators: Contributor, Developer

Upgrade de vieille version

Postby tichod » Dec 04, 2017 5:03 am

Bonjour.

Je dois upgrader une vieille version de Mantis (1.2.8), et il se trouve que je découvre en même temps ce produit (bien entendu, celui qui a construit le binz à l'origine n'est plus là).
J'aimerais avoir vos recommandations en termes de méthodologie, car pour le moment, je rencontre quelques difficultés.

Config Prod source : Windows 2003 R2/WAMP 2.1/Apache 2.2.17/PHP 5.3.5/MySQL 5.5.8/Mantis 1.2.8
Config Prod cible : Windows 2003 R2/WAMP 3.0.6/Apache 2.4.23/PHP 7.0.10/MySQL 5.7.14/Mantis 2.8.0
Config serveur intermédiaire : Windows 2008 R2/WAMP 3.0.6/Apache 2.4.23/PHP 7.0.10/MySQL 5.7.14
==> je compte à cette occasion mettre tout à jour sur le serveur de PROD, à savoir Mantis ET WAMP.
==> je compte utiliser le serveur intermédiaire pour construire/recetter la config cible, avant de la reverser sur le serveur de PROD. Pour ce faire, je pense faire :
  • clonage Mantis existant (1.2.8 sur WAMP 3.0.6) ;
  • upgrade 1.2.8 -> 2.8.0 ;
  • transfert vers serveur de PROD.

Ce que j'ai fait pour le moment :
  • parcouru les docs que j'ai pu trouver ;
  • installation Mantis 1.2.8 sur le serveur intermédiaire : j'aboutis à l'ouverture de session OK avec le compte admin par défaut ;
  • sauvegarde de la BDD de PROD ;
  • tentative d'import de la sauvegarde dans le serveur intermédiaire, et là message d'erreur :
Code: Select all
ERROR at line 21031: Unknown command '\a'.

J'ai donc des données de format bizarre qui font planter l'import.

Avant de creuser d'avantage cette question de plantage d'import, avez-vous des commentaires plus généraux sur ma façon de procéder ?

Merci.
tichod
 
Posts: 2
Joined: Dec 04, 2017 4:36 am

Re: Upgrade de vieille version

Postby tichod » Dec 04, 2017 10:57 am

Réponse à ma propre question : j'ai apparemment pu faire l'upgrade sur mon serveur intermédiaire. Je vais recetter ça.
L'erreur à l'import du dump de BDD a été résolue en utilisant MySQL Workbench au lieu de PHPMyAdmin + ligne de commande.
En parallèle de la recette, je vais réfléchir à la façon de remonter la version 2.8.0 en PROD.
tichod
 
Posts: 2
Joined: Dec 04, 2017 4:36 am


Return to French

Who is online

Users browsing this forum: No registered users and 4 guests