View Issue Details

IDProjectCategoryView StatusLast Update
0009990mantisbtfilterspublic2009-06-26 12:02
ReporteriboltzAssigned Togiallu 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.1.6 
Target VersionFixed in Version 
Summary0009990: "Assigned to" filter breaks when set to "any"
Description

The moment I have no more issues that are unassigned, the view all issues page with "Assigned to" filter set to "any" will not show any issues at all anymore, also, the color code legend underneath the issue table disappears.

When I set the "Assigned to" filter to any particular user, the table is rendered correctly with the color code legend underneath the issue table, even if its empty (because no issue has been assigned to that user).

Brand new install of 1.1.6 - no mods, no plugins etc

TagsNo tags attached.

Relationships

duplicate of 0008538 closedgiallu View Issues page isn't fully rendered when Assigned To field is set to [any] (the default) 
related to 0009997 closedgrangeway Add check for Zend Optimizer version 

Activities

iboltz

iboltz

2008-12-19 13:54

reporter   ~0020431

Correction: Even IF I do have an unassigned issue, setting the "assigned to" filter to "any" will make the whole bugs table disappear, including the color code legend underneath the issue table.

I wonder why nobody else seems to be seeing this; I've tried 1.1.5 as well and the issue is there. On my current 1.0.5 I've never seen this. For good measure I also tried 1.2.0a2 and there, the "view all bugs" page directly throws a white page, without anything showing at all.

iboltz

iboltz

2008-12-19 14:06

reporter   ~0020432

When I set $g_dhtml_filters = OFF I do get a table header at the least, still no bugs listed though and no color legend.

grangeway

grangeway

2008-12-20 19:30

reporter   ~0020450

Hello,

Just to work out whether there's anything special about your setup whilst we look at this:

  1. Do you have any php plugins loaded ? e.g. APC, zend cache etc
  2. what version of php are you on ?

Paul

iboltz

iboltz

2008-12-21 11:56

reporter   ~0020458

Hi Paul, thanks for taking the time.

-I'm on a westhost VPS with PHP Version 5.2.1
-Zend is running (Zend Engine v2.2.0, Zend Extension Manager v1.2.0, Zend Optimizer v3.2.2) could be a few more things, I'm not much of a sysad.

From my php.info (I can post the whole thing if you want):

Configure Command './configure' '--prefix=/usr/local/php' '--enable-safe-mode' '--enable-sockets' '--enable-ftp' '--enable-mbstring' '--enable-dbx' '--enable-dio' '--enable-memory-limit' '--enable-bcmath' '--enable-calendar' '--enable-dbase' '--enable-exif' '--enable-mbregex' '--enable-track-vars' '--enable-soap' '--enable-zend-multibyte' '--enable-dba' '--disable-mbstr-enc-trans' '--with-dom' '--with-bz2' '--with-pear' '--with-ldap=/usr/local/php/dependencies' '--with-xmlrpc' '--with-gd' '--with-openssl' '--with-imap-ssl' '--with-regex=system' '--with-config-file-path=/etc' '--with-apxs2=/usr/sbin/apxs' '--with-gettext=/usr/local/php/dependencies' '--with-jpeg-dir=/usr/local/php/dependencies' '--with-png-dir=/usr/local/php/dependencies' '--with-ttf=/usr/local/php/dependencies' '--with-pgsql=/usr/local/php/dependencies' '--with-mysql=/usr/local/php/dependencies' '--with-mysqli=/usr/local/php/dependencies/bin/mysql_config' '--with-pdo-mysql=/usr/local/php/dependencies' '--with-pdo-pgsql=/usr/local/php/dependencies' '--with-mssql=/usr/local/php/dependencies' '--with-db4=/usr/local/php/dependencies' '--with-freetype-dir=/usr/local/php/dependencies' '--with-iconv=/usr/local/php/dependencies' '--with-iconv-dir=/usr/local/php/dependencies' '--with-gmp=/usr/local/php/dependencies' '--with-t1lib=/usr/local/php/dependencies' '--with-mhash=/usr/local/php/dependencies' '--with-mcrypt=/usr/local/php/dependencies' '--with-zlib=/usr/local/php/dependencies' '--with-expat-dir=/usr/local/php/dependencies' '--with-xsl=/usr/local/php/dependencies' '--with-libxml-dir=/usr/local/php/dependencies' '--with-curl=/usr/local/php/dependencies' '--with-imap=/home/php5/src/dependencies/imap-2006f' '--with-pspell=/usr/local/php/dependencies' '--with-magickwand=/usr/local/php/dependencies'
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety disabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, compress.bzip2, compress.zlib, https, ftps
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters string.rot13, string.toupper, string.tolower, string.strip_tags, convert., consumed, convert.iconv., bzip2., zlib.

grangeway

grangeway

2008-12-21 16:44

reporter   ~0020460

Hello iboltz,

From what you originally said I get the impression you are only getting half the page rendered i.e. the page doesn't finish with the final </html> as it stops before hand.

In the past, when we've had users reporting these sorts of problems, it's sometimes between the case they are running different versions of PHP to core dev's, and also addon modules that mess with php internals e.g. zend optimiser.

I dont know what else you are running, but if you are finding the page stops rendering half way through with no error (i.e. not closing </html>', i'd be inclined to look at zend optimer (you are on 3.2.2, I believe latest release is 3.3.3), and PHP (5.2.1 vs recently release 5.2.8)

Paul

iboltz

iboltz

2008-12-21 17:01

reporter   ~0020461

Last edited: 2008-12-23 09:41

Hi Paul,

so your suggestion would be to upgrade zend and php? Whats weird though is that I am running mantis 1.0.5 without any problem on that same vps. Anything else that could be the culprit?

Thanks,
Ingo

giallu

giallu

2008-12-23 03:19

reporter   ~0020469

This is a duplicate of 0008538 and most likely a problem with zend optimizer + debug_backtrace; on comment 0008538:0017602 the user claims to have solved the issue by upgrading just Zend Optimizer to 3.3.3.

see http://www.google.com/search?q=zend+optimizer+debug_backtrace for details

iboltz

iboltz

2008-12-23 10:06

reporter   ~0020474

setting $g_show_assigned_names = OFF solved the issue. Thanks!

Issue History

Date Modified Username Field Change
2008-12-18 17:19 iboltz New Issue
2008-12-19 13:54 iboltz Note Added: 0020431
2008-12-19 14:06 iboltz Note Added: 0020432
2008-12-20 19:30 grangeway Note Added: 0020450
2008-12-21 11:56 iboltz Note Added: 0020458
2008-12-21 16:44 grangeway Note Added: 0020460
2008-12-21 17:01 iboltz Note Added: 0020461
2008-12-23 03:19 giallu Note Added: 0020469
2008-12-23 03:19 giallu Relationship added duplicate of 0008538
2008-12-23 03:19 giallu Status new => resolved
2008-12-23 03:19 giallu Resolution open => duplicate
2008-12-23 03:19 giallu Assigned To => giallu
2008-12-23 09:41 iboltz Note Edited: 0020461
2008-12-23 10:06 iboltz Note Added: 0020474
2008-12-24 03:31 vboctor Relationship added related to 0009997
2009-06-26 12:02 vboctor Status resolved => closed