MantisBT

View Issue Details Jump to Notes ] Wiki ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0009826mantisbtbugtrackerpublic2008-11-17 15:152013-08-28 11:42
Reporterolegos 
Assigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.2.0a2 
Target Version1.2.12Fixed in Version1.2.12 
Summary0009826: Single project user should default to the project, not All Projects
DescriptionApparently if a user has access to only one project, the project selection box at top right isn't shown anymore in version 1.2 (it was there in 1.0.8 and I believe 1.1.3). That's good (less confusing to the user), except for the following problem.

The View Issues screen seems to default to All Projects selection. The categories shown include [project], and the menu shows links appropriate for All Projects. For example, if a user is globally Viewer, but Reporter on the project, the "Report Issue" link isn't shown. (In prior versions, I told my users to select a project from the project selection box to be able to report issues. Confusing, but better than not being able to report issues at all.)

This is important, because many of my Reporters have lost ability to report new issues. They can still do it if they go into one of existing bugs -- but that's even more confusing and cumbersome (if there are no open bugs, if it's a new project, etc.)
Tags2.0.x check
Attached Files

- Relationships
related to 0015721closedgrangeway Functionality to consider porting to master-2.0.x 
related to 0016337closeddregad Creating the first project on a fresh install causes error 2800 
has duplicate 0013234closedatrol Can't report issue when no project selected 
has duplicate 0011322closeddregad incorrect rights with only 1 authorized project 
has duplicate 0012673closeddregad User not found in "Assigned to" list 
related to 0014268acknowledged "Report Issue" is missing if the user has access to only private projects, but has not selected a project from the dropdown. 
related to 0015200closedvboctor Anonymous access is broken 

-  Notes
User avatar (0019919)
olegos (reporter)
2008-11-17 15:16
edited on: 2008-11-17 15:24

By the way, even selecting the project as default in My Account : Preferences (where both the project and All Projects are still shown) doesn't help.

Edit: Actually it seems that I had to logout & log back in for the default project in Preferences to take effect. So maybe that's a good work-around for now.

User avatar (0025089)
Chi-Yu (reporter)
2010-04-09 08:48
edited on: 2010-04-09 08:51

This one is still around in 1.2.0 and the easiest way to fix it is probably to bring back the project selection box.

Else, you'd have to check if the user is still assigned to more than 1 project and change the default project if that is not the case. But this would also mean that someone who is assigned to 2 projects and has "All Projects" as default would be force-switched to project 1 when he/she is removed from project 2 and it won't revert back to "All Projects" when you assign him/her to project 3.

Another solution is to display the project selection box if:

- the user is assigned to just 1 project AND
- the default project is currently set to "All Projects"

That way, people who don't know about account preferences can't get "stuck" on the "All Projects" view. This could avoid some confusion.

This "bug" causes a lot of confusion in very restrictive environments where all projects are private and the default global access level is just "viewer".

User avatar (0029469)
tloudev (reporter)
2011-08-12 07:28

Sorry for duplicating, I didn't find it :-(
Will anybody do something with it?
User avatar (0030932)
marcovtwout (reporter)
2012-01-18 06:39

*bump* For us this is a common case (client gets guest account and submitter access for one project). They are now stuck, but there are two possible workarounds:

- Set project as default project and relog
- Add to url bar: /bug_report_page.php

The current situation is not acceptable.
User avatar (0032818)
dregad (developer)
2012-09-10 09:34

This should be fixed now.

Testing and feedback would be appreciated (please download a nightly build starting tomorrow or get the patch from github)
User avatar (0036144)
grangeway (developer)
2013-04-05 17:56

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

- Related Changesets
MantisBT: master-1.2.x b1a1bbae
Timestamp: 2012-09-10 05:56:00
Author: dregad
Details ] Diff ]
User with access to single project defaults to it, not all projects

Since 1.2, if a user has access to only one project, the project
selection box at top right isn't shown. This was causing issues as new
users accounts have 'All projects' as their default:

 - user can't report issues (no link for all projects)
 - categories displayed are prefixed with [project]

Until this commit, users had to define their (single) project as default
using preferences to work around the problem; this is no longer needed.

Function html_login_info() now sets the current project as appropriate
if user has only access to a single one, and also defines that as the
default.

The account preferences page has also been modified to only include 'All
projects' in the selection list when user has more than one project
available.

Fixes 0009826, 0014268
mod - account_prefs_inc.php Diff ] File ]
mod - core/html_api.php Diff ] File ]
MantisBT: master cfa022bc
Timestamp: 2012-09-10 05:56:00
Author: dregad
Details ] Diff ]
User with access to single project defaults to it, not all projects

Since 1.2, if a user has access to only one project, the project
selection box at top right isn't shown. This was causing issues as new
users accounts have 'All projects' as their default:

 - user can't report issues (no link for all projects)
 - categories displayed are prefixed with [project]

Until this commit, users had to define their (single) project as default
using preferences to work around the problem; this is no longer needed.

Function html_login_info() now sets the current project as appropriate
if user has only access to a single one, and also defines that as the
default.

The account preferences page has also been modified to only include 'All
projects' in the selection list when user has more than one project
available.

Fixes 0009826, 0014268
mod - account_prefs_inc.php Diff ] File ]
mod - core/html_api.php Diff ] File ]

- Issue History
Date Modified Username Field Change
2008-11-17 15:15 olegos New Issue
2008-11-17 15:16 olegos Note Added: 0019919
2008-11-17 15:24 olegos Note Edited: 0019919
2008-11-18 01:48 vboctor Status new => acknowledged
2010-04-09 08:48 Chi-Yu Note Added: 0025089
2010-04-09 08:51 Chi-Yu Note Edited: 0025089 View Revisions
2011-08-12 03:31 atrol Relationship added has duplicate 0013234
2011-08-12 07:28 tloudev Note Added: 0029469
2012-01-18 06:39 marcovtwout Note Added: 0030932
2012-07-13 07:16 atrol Relationship added related to 0014268
2012-09-10 09:29 dregad Changeset attached => MantisBT master-1.2.x b1a1bbae
2012-09-10 09:29 dregad Assigned To => dregad
2012-09-10 09:29 dregad Status acknowledged => resolved
2012-09-10 09:29 dregad Resolution open => fixed
2012-09-10 09:29 dregad Fixed in Version => 1.2.12
2012-09-10 09:29 dregad Changeset attached => MantisBT master cfa022bc
2012-09-10 09:34 dregad Note Added: 0032818
2012-09-10 09:34 dregad Target Version => 1.2.12
2012-09-13 10:36 dregad Relationship added has duplicate 0011322
2012-09-13 10:37 dregad Relationship added has duplicate 0012673
2012-11-10 18:54 dregad Status resolved => closed
2012-11-11 17:31 dregad Relationship added related to 0015200
2013-04-05 17:56 grangeway Status closed => acknowledged
2013-04-05 17:56 grangeway Note Added: 0036144
2013-04-05 19:28 grangeway Relationship added related to 0015721
2013-04-06 03:40 dregad Status acknowledged => closed
2013-04-06 07:23 grangeway Status closed => acknowledged
2013-04-06 09:22 dregad Tag Attached: 2.0.x check
2013-04-06 09:23 dregad Status acknowledged => closed
2013-08-28 11:42 dregad Relationship added related to 0016337


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.1036 seconds.
memory usage: 3,115 KB
Powered by Mantis Bugtracker