View Issue Details

IDProjectCategoryView StatusLast Update
0009742mantisbtdb mssqlpublic2015-03-15 19:58
ReporterneethuvAssigned Todregad 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.2Fixed in Version1.3.0-beta.2 
Summary0009742: Unable to install Mantis 1.1.2 with MS SQL
Description

I have to install manis with SQL server 2005 express.

I have downloaded mantis 1.1.2. Downloded wamp server supporting PHP 5.2.6 .
Then on installing manis by selecting MS SQL (experimental), hostname as Driver{SQL Server};SERVER=D867DTRV\SQLEXPRESS;DATABASE=Mantis;UID=mantisadmin;PWD=admin

config_inc.php file was modified as
$g_hostname = 'Driver={SQL Server};SERVER=D867DTRV\SQLEXPRESS;DATABASE=Mantis;UID=mantisadmin;PWD=admin;';
$g_db_username = "mantisadmin";
$g_db_password = "admin";
$g_database_name = "mantis";
$g_db_type = "odbc_mssql";

But I am getting the error
"BAD database is not supported by PHP. Check that it has been compiled into your server."

Please provide the necessary steps that need to be done to install mantis. Whether mantis will work fine with MS SQL.

TagsNo tags attached.

Relationships

has duplicate 0011871 closedatrol Error while Installing Mantis 1.2.0 + PHP 5.1.2 

Activities

jreese

jreese

2008-10-24 08:47

reporter   ~0019673

You need to install and enable the mssql extensions for PHP before you can use Mantis with an MSSQL database. You'll need to look at the PHP documentation and the documentation for your WAMP stack to figure out how to do this.

neethuv

neethuv

2008-10-28 08:40

reporter   ~0019707

Getting the following Attached error (Bad Does the Adminstrator have access to the database)

The user created in the SQl server has sys admin privilege.

i have enabled the php extension for ms sql in the php.ini file

TCP/IP connections on port 1433 is enabled.

Set the following settings in php.ini file
mssql.textlimit = 20971520
mssql.textsize = 20971520
magic_quotes_gpc = Off

also checked the ms sql connectivitiy

<?php

if (function_exists('mssql_connect'))
{
echo "Okay, fn is there";
}
else
{
echo "Hmmm .. fn is not even there";
}

?>

This is also working fine.

But still unable to install mantis. The error that is displayed seems to be not the actual error. The actual error cannot be identified.

2008-10-28 08:42

 

Error.JPG (147,036 bytes)
Error.JPG (147,036 bytes)

2008-10-28 08:42

 

config_inc.php (2,608 bytes)
<?php
# Mantis - a php based bugtracking system

# Copyright (C) 2000 - 2002  Kenzaburo Ito - kenito@300baud.org
# Copyright (C) 2002 - 2007  Mantis Team   - mantisbt-dev@lists.sourceforge.net

# Mantis is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 2 of the License, or
# (at your option) any later version.
#
# Mantis is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with Mantis.  If not, see <http://www.gnu.org/licenses/>.

	# --------------------------------------------------------
	# $Id: config_inc.php.sample,v 1.19.2.2 2007-10-25 17:13:42 giallu Exp $
	# --------------------------------------------------------

	# This sample file contains the essential files that you MUST
	# configure to your specific settings.  You may override settings
	# from config_defaults_inc.php by assigning new values in this file

	# Rename this file to config_inc.php after configuration.

	###########################################################################
	# CONFIGURATION VARIABLES
	###########################################################################

	# In general the value OFF means the feature is disabled and ON means the
	# feature is enabled.  Any other cases will have an explanation.

	# Look in http://www.mantisbt.org/manual or config_defaults_inc.php for more
	# detailed comments.

	# --- database variables ---------

	# set these values to match your setup
	$g_hostname      = "Driver={SQL Server};SERVER=C114USS;DATABASE=test1;UID=mantis;PWD=mantis;";
	$g_db_username   = "mantis";
	$g_db_password   = "mantis";
	$g_database_name = "test1";
	$g_db_type       = "odbc_mssql";

	# --- email variables -------------
	$g_administrator_email  = 'administrator@example.com';
	$g_webmaster_email      = 'webmaster@example.com';

	# the "From: " field in emails
	$g_from_email           = 'noreply@example.com';

	# the return address for bounced mail
	$g_return_path_email    = 'admin@example.com';

	# --- file upload settings --------
	# This is the master setting to disable *all* file uploading functionality
	#
	# The default value is ON but you must make sure file uploading is enabled
	#  in PHP as well.  You may need to add "file_uploads = TRUE" to your php.ini.
	$g_allow_file_upload	= ON;
?>
config_inc.php (2,608 bytes)
neethuv

neethuv

2008-10-28 08:47

reporter   ~0019708

please provide the necessary steps by which i can install mantis with MS SQL

grangeway

grangeway

2014-02-17 13:26

reporter   ~0039442

Marking as Suspended

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-03-27 19:12

reporter   ~0039770

MSSQL support is currently known broken. We are going to be replacing the DB Layer in Mantis to fix this properly after the next release.

I'd strongly advise using MYSQL for now.

The new DB layer already contains the appropriate fixes for MS SQL Support.

grangeway

grangeway

2014-05-16 15:00

reporter   ~0040314

MantisBT currently supports Mysql and has support for other database engines.

The support for other databases is known to be problematic.

Having implemented the current database layer into Mantis 10 years ago, I'm currently working on replacing the current layer.

If you are interested in using Mantis with non-mysql databases - for example, Oracle, PGSQL or MSSQL, and would be willing to help out testing the new database layer, please drop me an email at paul@mantisforge.org

In the meantime, I'd advise running Mantis with Mysql Only to avoid issues.

Thanks
Paul

dregad

dregad

2015-03-14 14:02

developer   ~0049217

Despite the fact that I am not actually able to test whether the problem is truly resolved since I don't have access to a MSSQL server setup, I'm marking this issue as fixed in 1.3.x on the grounds that the recent updates in ADOdb (which contain many improvements in the MSSQL driver) are likely to address it.

Should the problem persist (using a nightly build or a version > 1.3.0-beta.1), feel free to reopen this issue or to create a new one.

Issue History

Date Modified Username Field Change
2008-10-24 07:13 neethuv New Issue
2008-10-24 08:47 jreese Note Added: 0019673
2008-10-24 08:47 jreese Status new => resolved
2008-10-24 08:47 jreese Resolution open => no change required
2008-10-24 08:47 jreese Assigned To => jreese
2008-10-28 08:40 neethuv Note Added: 0019707
2008-10-28 08:40 neethuv Status resolved => feedback
2008-10-28 08:40 neethuv Resolution no change required => reopened
2008-10-28 08:42 neethuv File Added: Error.JPG
2008-10-28 08:42 neethuv File Added: config_inc.php
2008-10-28 08:47 neethuv Note Added: 0019708
2008-10-28 09:05 jreese Status feedback => assigned
2008-10-28 09:05 jreese Assigned To jreese => grangeway
2012-09-21 18:25 atrol Relationship added has duplicate 0011871
2012-09-21 18:25 atrol Category installation => db mssql
2014-02-17 13:26 grangeway Note Added: 0039442
2014-03-27 19:12 grangeway Note Added: 0039770
2014-03-27 19:12 grangeway Status assigned => resolved
2014-03-27 19:12 grangeway Resolution reopened => suspended
2014-03-28 04:18 atrol Status resolved => assigned
2014-04-12 19:33 grangeway Target Version => 1.3.0-beta.1
2014-05-16 15:00 grangeway Note Added: 0040314
2014-05-23 15:08 grangeway Project mantisbt => @24@
2014-11-07 14:23 atrol Assigned To grangeway =>
2014-11-07 14:23 atrol Status assigned => new
2014-11-07 14:23 atrol Project @24@ => mantisbt
2014-12-08 02:10 atrol Target Version 1.3.0-beta.1 => 1.3.0-beta.2
2015-03-14 14:02 dregad Note Added: 0049217
2015-03-14 14:02 dregad Status new => resolved
2015-03-14 14:02 dregad Fixed in Version => 1.3.0-beta.2
2015-03-14 14:02 dregad Resolution suspended => fixed
2015-03-14 14:02 dregad Assigned To => dregad
2015-03-15 19:58 dregad Status resolved => closed