2014-12-18 03:31 EST

View Issue Details Jump to Notes ] Wiki ]
IDProjectCategoryView StatusLast Update
0008651mantisbtchange logpublic2008-04-19 04:10
Reporterfoo 
Assigned Tojreese 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
Product Version1.1.0rc3 
Target VersionFixed in Version1.2.0a1 
Summary0008651: Display release date in changelog for released version
DescriptionA nice option would be to append the release date after the version number in the change log entry. Currently we use the notes to describe this, but that's redundant, as the releases have a date field; why not make it automatic and just use that?
Tagspatch
Attached Files
  • png file icon 8651_raster.PNG (55,278 bytes) 2008-03-07 07:59 - 
    png file icon 8651_raster.PNG (55,278 bytes) 2008-03-07 07:59 + 
  • patch file icon changelog.patch (2,486 bytes) 2008-04-04 09:43 - 
    Index: lang/strings_english.txt
    ===================================================================
    --- lang/strings_english.txt	(revision 5155)
    +++ lang/strings_english.txt	(working copy)
    @@ -921,6 +921,7 @@
     $s_edit_project_version_title = 'Edit Project Version';
     $s_update_version_button = 'Update Version';
     $s_released = 'Released';
    +$s_not_released = 'Not Yet Released';
     $s_obsolete = 'Obsolete';
     
     # manage_proj_version_update.php
    @@ -1310,6 +1311,7 @@
     $s_http_auth_realm = "Mantis Login";
     
     $s_bug = "issue";
    +$s_bugs = "issues";
     $s_add_new_relationship = "New relationship";
     $s_add_new_relationship_button = "Add";
     $s_this_bug = "Current issue";
    @@ -1511,4 +1513,4 @@
     # mind mapping
     $s_mindmap = 'Mindmap';
     $s_freemind_export = 'Freemind Export';
    -?>
    \ No newline at end of file
    +?>
    Index: changelog_page.php
    ===================================================================
    --- changelog_page.php	(revision 5155)
    +++ changelog_page.php	(working copy)
    @@ -31,11 +31,22 @@
     	function print_version_header( $p_version_id ) {
     		$t_project_id   = version_get_field( $p_version_id, 'project_id' );
     		$t_version_name = version_get_field( $p_version_id, 'version' );
    +		$t_version_released = version_get_field( $p_version_id, 'released' );
    +		$t_release_timestamp = version_get_field( $p_version_id, 'date_order' );
     		$t_project_name = project_get_field( $t_project_id, 'name' );
     
     		$t_release_title = string_display( $t_project_name ) . ' - ' . string_display( $t_version_name );
    +		
    +		if ( (bool) $t_version_released ) {
    +			$t_release_date = ' (' . strtolower( lang_get('released') ) . ' ' . date( config_get( 'short_date_format' ), $t_release_timestamp ) . ')';
    +		} else {
    +			$t_release_date = ' (' . strtolower( lang_get( 'not_released' ) ) . ')';
    +		}
    +
     		echo '<tt>';
    -		echo '<br />', $t_release_title, '<br />';
    +		echo '<br />', $t_release_title, $t_release_date, '<br />';
    +		
    +		$t_release_title = $t_project_name . ' - ' . $t_version_name . $t_release_date;
     		echo str_pad( '', strlen( $t_release_title ), '=' ), '<br />';
     	}
     	
    @@ -217,6 +228,14 @@
     				helper_call_custom_function( 'changelog_print_issue', array( $t_issue_set_id, $t_issue_set_level ) );
     			}
     
    +			if ( $t_issues_resolved == 1 ) {
    +				echo "[{$t_issues_resolved} " . lang_get( 'bug' ) . ']';
    +				echo "<br />";
    +			} else if ( $t_issues_resolved > 1 ) {
    +				echo "[{$t_issues_resolved} " . lang_get( 'bugs' ) . ']';
    +				echo "<br />";
    +			}
    +
     			echo '</tt>';
      		}			
     
    
    patch file icon changelog.patch (2,486 bytes) 2008-04-04 09:43 + 
  • patch file icon changelog+roadmap.patch (3,562 bytes) 2008-04-07 17:44 - 
    Index: lang/strings_english.txt
    ===================================================================
    --- lang/strings_english.txt	(revision 5156)
    +++ lang/strings_english.txt	(working copy)
    @@ -921,6 +921,8 @@
     $s_edit_project_version_title = 'Edit Project Version';
     $s_update_version_button = 'Update Version';
     $s_released = 'Released';
    +$s_not_released = 'Not Yet Released';
    +$s_scheduled_release = 'Scheduled For Release';
     $s_obsolete = 'Obsolete';
     
     # manage_proj_version_update.php
    @@ -1310,6 +1312,7 @@
     $s_http_auth_realm = "Mantis Login";
     
     $s_bug = "issue";
    +$s_bugs = "issues";
     $s_add_new_relationship = "New relationship";
     $s_add_new_relationship_button = "Add";
     $s_this_bug = "Current issue";
    @@ -1511,4 +1514,4 @@
     # mind mapping
     $s_mindmap = 'Mindmap';
     $s_freemind_export = 'Freemind Export';
    -?>
    \ No newline at end of file
    +?>
    Index: changelog_page.php
    ===================================================================
    --- changelog_page.php	(revision 5156)
    +++ changelog_page.php	(working copy)
    @@ -31,11 +31,22 @@
     	function print_version_header( $p_version_id ) {
     		$t_project_id   = version_get_field( $p_version_id, 'project_id' );
     		$t_version_name = version_get_field( $p_version_id, 'version' );
    +		$t_version_released = version_get_field( $p_version_id, 'released' );
    +		$t_release_timestamp = version_get_field( $p_version_id, 'date_order' );
     		$t_project_name = project_get_field( $t_project_id, 'name' );
     
     		$t_release_title = string_display( $t_project_name ) . ' - ' . string_display( $t_version_name );
    +		
    +		if ( (bool) $t_version_released ) {
    +			$t_release_date = ' (' . strtolower( lang_get('released') ) . ' ' . date( config_get( 'short_date_format' ), $t_release_timestamp ) . ')';
    +		} else {
    +			$t_release_date = ' (' . strtolower( lang_get( 'not_released' ) ) . ')';
    +		}
    +
     		echo '<tt>';
    -		echo '<br />', $t_release_title, '<br />';
    +		echo '<br />', $t_release_title, $t_release_date, '<br />';
    +		
    +		$t_release_title = $t_project_name . ' - ' . $t_version_name . $t_release_date;
     		echo str_pad( '', strlen( $t_release_title ), '=' ), '<br />';
     	}
     	
    @@ -217,6 +228,14 @@
     				helper_call_custom_function( 'changelog_print_issue', array( $t_issue_set_id, $t_issue_set_level ) );
     			}
     
    +			if ( $t_issues_resolved == 1 ) {
    +				echo "[{$t_issues_resolved} " . lang_get( 'bug' ) . ']';
    +				echo "<br />";
    +			} else if ( $t_issues_resolved > 1 ) {
    +				echo "[{$t_issues_resolved} " . lang_get( 'bugs' ) . ']';
    +				echo "<br />";
    +			}
    +
     			echo '</tt>';
      		}			
     
    Index: roadmap_page.php
    ===================================================================
    --- roadmap_page.php	(revision 5156)
    +++ roadmap_page.php	(working copy)
    @@ -31,11 +31,16 @@
     	function print_version_header( $p_version_row ) {
     		$t_project_id   = $p_version_row['project_id'];
     		$t_version_name = $p_version_row['version'];
    +		$t_version_timestamp = $p_version_row['date_order'];
     		$t_project_name = project_get_field( $t_project_id, 'name' );
     
     		$t_release_title = string_display( $t_project_name ) . ' - ' . string_display( $t_version_name );
    +		$t_scheduled_release_date = ' (' . strtolower( lang_get( 'scheduled_release' ) ) . ' ' . date( config_get( 'short_date_format' ), $t_version_timestamp ) . ')';
    +
     		echo '<tt>';
    -		echo '<br />', $t_release_title, '<br />';
    +		echo '<br />', $t_release_title, $t_scheduled_release_date, '<br />';
    +
    +		$t_release_title = $t_project_name . ' - ' . $t_version_name . $t_scheduled_release_date;
     		echo str_pad( '', strlen( $t_release_title ), '=' ), '<br />';
     	}
     
    
    patch file icon changelog+roadmap.patch (3,562 bytes) 2008-04-07 17:44 + 

- Relationships
has duplicate 0007834closedgiallu Release dates in changelog and roadmap 
related to 0006215closedgiallu Add fixed bug count to change log 
related to 0005158closedgiallu Changelog count 
+ Relationships

-  Notes
User avatar

~0017283

herringm (reporter)

Last edited: 2008-03-07 08:07

I attached a mockup showing one potential way to show release dates for versions on the Change Log page. This raster also includes a total issue count to quickly give an idea of how many fixes/enhancements were addressed in a particular version (0005158).

Thoughts?

Oops! Just realized I forgot to extend the "=" under the version title to the end of the release date.

User avatar

~0017289

vboctor (administrator)

Sounds good to me. Let's see others feedback.
User avatar

~0017512

plegall (reporter)

I'm very interested in such a feature.

The problem is that currently (Mantis 1.1.0 is installed on talendforge.org/bugs) mantis_project_version_table.date_order is used to order released. And the date I set is absolutely not the release date (I want a sort order different because I don't want to mix branches).

so I suggest a new mantis_project_version_table.order (int) + mantis_project_version_table.released_date
User avatar

~0017551

herringm (reporter)

Patch attached. Does not address new release_date column for versions.
User avatar

~0017560

stefang (reporter)

Hi Herringm,

I've implemented your patch in to Mantis 1.1.1 and it works fine so far.

The only thing I had to change was to remove the "strtolower" functions in the changelog_page.php, because german umlauts would not be converted correctly and are shown as carets in the page.

Thanks for the patch,
Stefan
User avatar

~0017562

herringm (reporter)

Stefang,

If you have the mbstring extension installed give multi-byte function overloading a try. Instead of calling the single-byte function the multi-byte equivalent will be called which should be able to handle the umlauts.

http://us2.php.net/manual/en/ref.mbstring.php [^]
http://us2.php.net/manual/en/ref.mbstring.php#mbstring.overload [^]
User avatar

~0017567

herringm (reporter)

Last edited: 2008-04-07 17:45

Second patch attached which includes similar fixes/enhancements to Roadmap.
Patch created against trunk r5156.

User avatar

~0017574

jreese (reporter)

Fix committed to SVN trunk, 1.2.x r5157:

- Added config options 'show_roadmap_dates' and 'show_changelog_dates' defaulting to ON
- Cleaned up and optimized some code.
+  Notes

- Issue History
Date Modified Username Field Change
2007-12-06 11:06 foo New Issue
2008-03-07 07:59 herringm File Added: 8651_raster.PNG
2008-03-07 08:05 herringm Note Added: 0017283
2008-03-07 08:07 herringm Note Edited: 0017283
2008-03-08 02:06 vboctor Note Added: 0017289
2008-03-31 16:21 plegall Note Added: 0017512
2008-04-04 09:43 herringm File Added: changelog.patch
2008-04-04 09:43 herringm Tag Attached: patch
2008-04-04 09:46 herringm Note Added: 0017551
2008-04-07 04:56 stefang Note Added: 0017560
2008-04-07 09:04 herringm Note Added: 0017562
2008-04-07 17:44 herringm Note Added: 0017567
2008-04-07 17:44 herringm File Added: changelog+roadmap.patch
2008-04-07 17:45 herringm Note Edited: 0017567
2008-04-08 11:54 jreese Status new => resolved
2008-04-08 11:54 jreese Fixed in Version => 1.2.0
2008-04-08 11:54 jreese Resolution open => fixed
2008-04-08 11:54 jreese Assigned To => jreese
2008-04-08 11:54 jreese Note Added: 0017574
2008-04-19 04:10 vboctor Status resolved => closed
2008-04-21 09:58 giallu Relationship added related to 0006215
2008-04-21 09:59 giallu Relationship added related to 0005158
2008-04-21 10:01 giallu Relationship added has duplicate 0007834
+ Issue History