View Issue Details

IDProjectCategoryView StatusLast Update
0008626mantisbtfilterspublic2017-01-31 04:02
Reporterrunner80Assigned Tocproensa 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.7 
Target Version2.1.0Fixed in Version2.1.0 
Summary0008626: Filter forgets custom date filtering
Description

If I filter with a custom date the filtering delivers the right results. But if I then apply a further filter like 'status' the custom date filter goes back to default. I could reproduce this behaviour with different platforms and Mantis versions from 1.0.1 to 1.0.7.

Steps To Reproduce

1) Create a custom field with type date and apply it to a project.
2) Use this custom field as a filter in view_all_bug_page
3) Click 'Filter'
4) Use a second filter like 'status'
5) Click 'Filter' again

TagsNo tags attached.

Relationships

has duplicate 0014709 closedcproensa In the filter page, the customized fields are resets without any reason 
has duplicate 0011213 closedcproensa Custom date field filter dissapears when changing sort by filter 
child of 0021935 closedcproensa Filter api refactoring, manage stored filters 

Activities

runner80

runner80

2008-09-12 09:04

reporter   ~0019392

Just confirmed issue in 1.1.2 build. Is there no solution yet?

runner80

runner80

2009-04-24 03:26

reporter   ~0021655

And again in 1.1.6.

atrol

atrol

2011-09-14 12:26

developer   ~0029715

Reproducible with 1.2

cproensa

cproensa

2016-10-19 12:20

developer   ~0054277

PR: https://github.com/mantisbt/mantisbt/pull/862

Issue History

Date Modified Username Field Change
2007-11-30 08:12 runner80 New Issue
2008-09-12 09:04 runner80 Note Added: 0019392
2009-04-24 03:26 runner80 Note Added: 0021655
2011-09-14 12:26 atrol Note Added: 0029715
2011-09-14 12:26 atrol Status new => confirmed
2011-09-14 12:41 atrol Relationship added related to 0011213
2016-05-31 18:36 cproensa Relationship added duplicate of 0014709
2016-10-19 12:20 cproensa Assigned To => cproensa
2016-10-19 12:20 cproensa Status confirmed => assigned
2016-10-19 12:20 cproensa Note Added: 0054277
2016-10-19 12:23 cproensa Relationship deleted 0014709
2016-10-19 12:23 cproensa Relationship added has duplicate 0014709
2016-10-19 12:23 cproensa Relationship deleted related to 0011213
2016-10-19 12:23 cproensa Relationship added has duplicate 0011213
2016-11-20 15:59 cproensa Relationship added child of 0021935
2017-01-14 17:34 cproensa Status assigned => resolved
2017-01-14 17:34 cproensa Resolution open => fixed
2017-01-14 17:34 cproensa Fixed in Version => 2.1.0
2017-01-14 17:35 cproensa Target Version => 2.1.0
2017-01-31 04:02 vboctor Status resolved => closed