View Issue Details

IDProjectCategoryView StatusLast Update
0008503mantisbtfeaturepublic2017-04-21 17:40
ReporterqipsAssigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version2.0.0-beta.1 
Summary0008503: Have "send reminder" as a button rather than a not so visible link at the top of the issue
Description

On several occasions I got feedback from my users that the "send reminder" link was just not easy enough to find. All of their permissable actions where on the button row but not the "send reminder" action which they valued so much.

I defined an extra button in the html_api nothing too fancy. Did a search and could not find any issue related to this. Below the code.

Additional Information

1) Add the below code in the html_api.php to the html_buttons_view_bug_page function; for example just below the Monitor/Unmonitor section.

#Send reminder button
echo '<td class="center">';
if ( !current_user_is_anonymous() && access_has_bug_level( config_get( 'bug_reminder_threshold' ), $p_bug_id ) ) {
html_button_bug_send_reminder( $p_bug_id );
}
echo '</td>';

2) Add the below code to the html_api.php ; for example just below the html_button_bug_unmonitor function.

--------------------

Print a button to send reminder about the given bug

function html_button_bug_send_reminder( $p_bug_id ) {
html_button( 'bug_reminder_page.php', lang_get( 'bug_reminder' ) ,
array( 'bug_id' => $p_bug_id ) );
}

3) Optional: I also update the language file to have the button display "Inform a collaegue" rather then "send a reminder"

TagsNo tags attached.

Activities

atrol

atrol

2017-04-12 03:50

developer   ~0056497

Send a reminderis a button since version 2.0

Related Changesets

MantisBT: master 56249022

2014-07-13 16:07:15

Rafik Robeal

Details Diff
Use helper function to print button links
mod - account_delete.php Diff File
mod - adm_config_report.php Diff File
mod - admin/move_attachments_page.php Diff File
mod - bug_file_upload_inc.php Diff File
mod - bug_report.php Diff File
mod - bug_update_page.php Diff File
mod - bug_view_inc.php Diff File
mod - bugnote_edit_page.php Diff File
mod - bugnote_view_inc.php Diff File
mod - core/access_api.php Diff File
mod - core/html_api.php Diff File
mod - core/print_api.php Diff File
mod - core/relationship_api.php Diff File
mod - main_page.php Diff File
mod - manage_plugin_page.php Diff File
mod - manage_proj_edit_page.php Diff File
mod - manage_proj_page.php Diff File
mod - manage_tags_page.php Diff File
mod - manage_user_create.php Diff File
mod - manage_user_page.php Diff File
mod - manage_user_reset.php Diff File
mod - news_view_page.php Diff File
mod - permalink_page.php Diff File
mod - proj_doc_page.php Diff File
mod - query_view_page.php Diff File
mod - tag_update_page.php Diff File
mod - tag_view_page.php Diff File
mod - view_all_inc.php Diff File

Issue History

Date Modified Username Field Change
2007-10-23 16:32 qips New Issue
2017-04-12 03:50 atrol Assigned To => atrol
2017-04-12 03:50 atrol Status new => resolved
2017-04-12 03:50 atrol Resolution open => fixed
2017-04-12 03:50 atrol Note Added: 0056497
2017-04-12 07:07 dregad Fixed in Version => 2.0.0-beta.1
2017-04-12 07:08 dregad Changeset attached => MantisBT master 56249022
2017-04-21 17:40 atrol Status resolved => closed