MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008301mantisbtadministrationpublic2007-08-23 08:032011-08-05 02:36
Reporterstappel 
Assigned Toatrol 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version1.1.0a4 
Target VersionFixed in Version 
Summary0008301: APPLICATION ERROR #200 (...._id) was not found
DescriptionWhen switching between projects when on any of the management pages will give an APPLICATION ERROR #200.
can be a A required parameter to this page (project_id) was not found. or A required parameter to this page (user_id) was not found. error.
depeneds on which page.

it looks a bit like bug 0007125
Steps To Reproduceexample:
- create 2 projects.
- goto the "manage projects" page
- select one of the projects. (just any).
- now use the "project selector" (on the top right of the page) to select a project.
=> A required parameter to this page (project_id) was not found.

example 2:
- create 2 projects and some user
- goto the "manage users"
- select one of the users, just any.
- now use the "project selector" (on the top right of the page) to select a project.
=> A required parameter to this page (user_id) was not found.
TagsNo tags attached.
Attached Files

- Relationships
related to 0006006confirmed Manage project doesn't refresh 
has duplicate 0008507closedgiallu Mantis crashes when switching projects 
has duplicate 0008793closedgiallu APPLICATION ERROR #200 while trying to switch to project from "Manage project" panel 
has duplicate 0009352closedgiallu required parameter (project_id) was not found 

-  Notes
User avatar (0016767)
giallu (developer)
2008-01-22 18:00

I'm not sure if it's really related, but it seems this was sort of a no-op in earlier releases, and turned to be an error lately.
User avatar (0017787)
Paramonov Alexander (reporter)
2008-05-07 00:16

Please add to file manage_proj_cat_edit_page.php
before line 82: "<input type="submit" class="button" value="<?php echo lang_get( 'update_category_button' ) ?>" />"
This:
<input type="hidden" name="project_id" value="<?php echo string_attribute( $f_project_id ) ?>" />
and there resolve this problem.
I test is on svn 5247.
User avatar (0017840)
giallu (developer)
2008-05-15 09:42

I tried to apply the modification (please, next time attach a diff) but neither example 1 nor example 2 seems to be fixed.

If you want to help, I'd appreciate a comprehensive fix for all manage_* pages, which should probably be by implementing 0006006
User avatar (0027885)
atrol (developer)
2011-01-10 16:56

stappel, this issue is not reproducible with current version of MantisBT.
Feel free to reopen the issue if there are still problems after upgrading.

- Issue History
Date Modified Username Field Change
2007-08-23 08:03 stappel New Issue
2008-01-22 17:57 giallu Relationship added has duplicate 0008507
2008-01-22 17:58 giallu Relationship added has duplicate 0008793
2008-01-22 18:00 giallu Relationship added related to 0006006
2008-01-22 18:00 giallu Note Added: 0016767
2008-05-07 00:16 Paramonov Alexander Note Added: 0017787
2008-05-15 09:42 giallu Note Added: 0017840
2008-07-07 03:06 giallu Relationship added has duplicate 0009352
2011-01-10 16:56 atrol Note Added: 0027885
2011-01-10 16:56 atrol Status new => resolved
2011-01-10 16:56 atrol Resolution open => unable to reproduce
2011-01-10 16:56 atrol Assigned To => atrol
2011-08-05 02:36 atrol Status resolved => closed


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.1454 seconds.
memory usage: 3,021 KB
Powered by Mantis Bugtracker