View Issue Details

IDProjectCategoryView StatusLast Update
0008250mantisbtadministrationpublic2014-12-08 00:34
ReporterfmanAssigned Todhx 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0008250: Create Project - Show upload path defined in absolute_path_default_upload_folder
Description

I think i better to see the absolute_path_default_upload_folder, when you are creating a Project and has configured DISK as upload method.

Now a blank input is showed, and when you upload a file, the value
present on config var g_absolute_path_default_upload_folder is used.

I will prefer the value for upload path will be saved as project definition data.

On additional info, you will find the modified code.

Additional Information

<?php
if ( config_get( 'allow_file_upload' ) ) {
$t_file_path = config_get( 'absolute_path_default_upload_folder' );
?>
<tr class="row-2">
<td class="category">
<?php echo lang_get( 'upload_file_path' ) ?>
</td>
<td>
<input type="text" name="file_path" size="70" maxlength="250"
value="<?php echo($t_file_path) ?>" />
</td>
</tr>
<?php
}
?>

TagsNo tags attached.

Relationships

related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 
related to 0010676 closeddhx File upload error if we have not setted the project file folder 

Activities

dhx

dhx

2009-06-16 17:17

reporter   ~0022181

Fix applied. The path is only shown to administrators because of security concerns with revealing paths to project managers, etc.

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036392

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master 7871f6cf

2009-06-16 21:06:06

dhx

Details Diff
Show default upload path when creating project

Implementation of bug 0008250

When creating a project, the user has an option to specify a separate
upload folder on a per-project basis. Previously this field was left
blank by default. This patch shows the default value to the user - as
long as they're an administrator. This helps make it a little easier to
see if a new path needs to be specified that is different from the
default. For security reasons the absolute upload path is only shown to
administrators.
mod - manage_proj_create_page.php Diff File
mod - manage_proj_create.php Diff File

Issue History

Date Modified Username Field Change
2007-08-10 09:40 fman New Issue
2007-08-10 11:42 vboctor Status new => acknowledged
2007-08-10 11:42 vboctor Target Version => 1.1.0
2007-09-25 02:19 vboctor Target Version 1.1.0 => 1.2.0
2008-07-12 18:19 giallu Target Version => 1.2.0
2009-05-04 14:27 siebrand Target Version 1.2.2 => 1.x.x
2009-06-16 17:17 dhx Note Added: 0022181
2009-06-16 17:17 dhx Assigned To => dhx
2009-06-16 17:17 dhx Status acknowledged => resolved
2009-06-16 17:17 dhx Resolution open => fixed
2009-06-16 17:17 dhx Target Version 1.x.x => 1.2.2
2009-06-16 17:20 dhx Changeset attached master 7871f6cf =>
2009-06-23 15:29 jreese Status resolved => closed
2009-07-04 00:20 vboctor Relationship added related to 0010676
2011-12-27 12:57 atrol Fixed in Version => 1.3.0-beta.1
2013-04-05 17:57 grangeway Status closed => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036392
2013-04-05 18:15 grangeway Relationship added related to 0015721
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2013-07-19 16:36 atrol Target Version 1.2.0rc1 => 1.3.0-beta.1
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check
2014-12-08 00:34 vboctor Status resolved => closed