View Issue Details

IDProjectCategoryView StatusLast Update
0007952mantisbttime trackingpublic2014-09-23 18:05
ReporterfmanAssigned Todregad 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version1.1.0a3 
Target Version1.2.6Fixed in Version1.2.6 
Summary0007952: Minor Improvement - Add label near time used
Description

IMHO it would be good, will displaying notes with time tacking values, add a label (Time used or Time worked, or Time spent) to the right of time value:

Example:

Now -> 12:30
I have spend a lot of time

With change suggested:

     Time worked: 12:30
     I have spend a lot of time
TagsNo tags attached.

Relationships

related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 

Activities

vboctor

vboctor

2007-05-18 03:12

manager   ~0014553

Makes sense. I wonder if other people have feedback on this. Any objections on adding it? What string to use?

jci000

jci000

2007-05-18 07:32

reporter   ~0014555

Sounds nice. What about the possibility to see the total amount of time worked on that issue?

vboctor

vboctor

2007-05-18 11:33

manager   ~0014559

jci000, wouldn't that be a different feature? I am assuming that after listing all the notes, there is an entry that shows the aggregated time, right? Or it can even come before the notes. Something similar to the "Users Monitoring this Issue" or "Issue Relationships".

I would suggest you report a new issue for this feature.

jci000

jci000

2007-05-19 03:32

reporter   ~0014562

Last edited: 2007-05-19 03:40

Yes vboctor you are right. I've created issue 0007990 for this.

fman

fman

2007-05-23 02:12

reporter   ~0014601

Last edited: 2007-05-23 02:15

My 5 cents to solve this:

// Add to strings_english.txt
$s_time_worked='Time worked=';

// in bugnote_view_inc.php
$Id: bugnote_view_inc.php,v 1.38 2007/02/20 05:49:00 vboctor
line 174:
case TIME_TRACKING:
if ( access_has_bug_level( config_get( 'time_tracking_view_threshold' ), $f_bug_id ) ) {
echo '' . lang_get( 'time_worked' ) , $v3_time_tracking_hhmm, '

';
}
break;

I've suppresed <big> because IMHO, gives too much emphasis

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036447

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Related Changesets

MantisBT: master-1.2.x 0c6d0135

2011-07-14 10:22:46

Damien Regad

Details Diff
Fix 0007952: Add a label next to time spent in bug notes

Also reduced the font size back to normal, because with the added label the
large font put too much emphasis on the time spent vs the bugnote text.
mod - bugnote_view_inc.php Diff File
mod - lang/strings_english.txt Diff File

MantisBT: master c50db060

2011-07-14 10:31:09

Damien Regad

Details Diff
Fix 0007952: Add a label next to time spent in bug notes

Also reduced the font size back to normal, because with the added label the
large font put too much emphasis on the time spent vs the bugnote text.
mod - bugnote_view_inc.php Diff File
mod - css/default.css Diff File
mod - lang/strings_english.txt Diff File

Issue History

Date Modified Username Field Change
2007-05-10 04:44 fman New Issue
2007-05-18 03:12 vboctor Note Added: 0014553
2007-05-18 03:12 vboctor Status new => feedback
2007-05-18 07:32 jci000 Note Added: 0014555
2007-05-18 11:33 vboctor Note Added: 0014559
2007-05-19 03:32 jci000 Note Added: 0014562
2007-05-19 03:40 jci000 Note Edited: 0014562
2007-05-23 02:12 fman Note Added: 0014601
2007-05-23 02:13 fman Note Edited: 0014601
2007-05-23 02:14 fman Note Edited: 0014601
2007-05-23 02:15 fman Note Edited: 0014601
2011-07-14 13:39 dregad Assigned To => dregad
2011-07-14 13:39 dregad Status feedback => assigned
2011-07-14 13:39 dregad Target Version => 1.2.6
2011-07-15 11:41 Changeset attached => MantisBT master-1.2.x 0c6d0135
2011-07-15 11:41 anonymous Status assigned => resolved
2011-07-15 11:41 anonymous Resolution open => fixed
2011-07-15 11:41 anonymous Fixed in Version => 1.2.6
2011-07-15 11:41 Changeset attached => MantisBT master c50db060
2011-07-26 09:53 jreese Status resolved => closed
2013-04-05 17:57 grangeway Status closed => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036447
2013-04-05 18:09 grangeway Relationship added related to 0015721
2013-04-06 03:43 dregad Status acknowledged => closed
2013-04-06 07:22 grangeway Status closed => acknowledged
2013-04-06 09:22 dregad Tag Attached: 2.0.x check
2013-04-06 09:23 dregad Status acknowledged => closed
2014-09-23 18:05 grangeway Tag Detached: 2.0.x check