View Issue Details

IDProjectCategoryView StatusLast Update
0007708mantisbtfeaturepublic2017-01-31 04:02
ReporterulfkAssigned Tocproensa 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.0.5 
Target Version2.1.0Fixed in Version2.1.0 
Summary0007708: Feature: multiple sorting of problem informations
Description

Would be cool to have the possibility for multiple sorting for the problem columns.

Maybe to sort 1st by: updated
2nd by: category
and 3rd by: severity

That would be good for a better overview for special problems or problems in one case.
Maybe someone only works on problems in text so he/she can sort it in that way to fix all these problems by sverity.

TagsNo tags attached.

Relationships

related to 0006732 closedcproensa Sorting issue lists isn't stable (each sort scrambles previous sort) 
child of 0021935 closedcproensa Filter api refactoring, manage stored filters 

Activities

atrol

atrol

2010-08-15 11:00

developer   ~0026324

Sorting by two columns is possible by using the "Sort by" link

cproensa

cproensa

2016-10-17 17:04

developer   ~0054256

We are resolving this issue as "no change required", because it was reported against an old version of MantisBT which is no longer supported.

We recommend that you upgrade to the latest stable version [1]; if after doing so the problem still exists, do not hesitate to reopen the issue.

[1] http://www.mantisbt.org/download.php

atrol

atrol

2016-10-17 17:08

developer   ~0054257

@cproensa why do you set to resolved?
The user is asking to be able to sort by three or even more columns, but we support just sorting by two columns.

cproensa

cproensa

2016-10-17 17:24

developer   ~0054259

@atrol is right.

This can be kept as the request to sort on >2 columns

cproensa

cproensa

2016-10-18 05:30

developer   ~0054261

included in PR 862

cproensa

cproensa

2017-01-14 17:41

developer   ~0055128

@atrol
with the fixes in PR 988, a filter can now sort by an arbitrary number of properties. For example, it does so when sorting directly by clicking on column headers.
However, the display and setting by the filter form is limited to 3 properties by the UI.
Can we close this as resolved?

cproensa

cproensa

2017-01-14 17:59

developer   ~0055130

I am solving this
For further improvements in the filter UI, it can be reported as related to 0016854

Issue History

Date Modified Username Field Change
2007-01-09 05:18 ulfk New Issue
2010-08-15 11:00 atrol Note Added: 0026324
2016-10-17 17:04 cproensa Assigned To => cproensa
2016-10-17 17:04 cproensa Status new => resolved
2016-10-17 17:04 cproensa Resolution open => no change required
2016-10-17 17:04 cproensa Note Added: 0054256
2016-10-17 17:08 atrol Note Added: 0054257
2016-10-17 17:24 cproensa Status resolved => acknowledged
2016-10-17 17:24 cproensa Note Added: 0054259
2016-10-17 17:42 cproensa Relationship added related to 0006732
2016-10-17 17:51 atrol Resolution no change required => open
2016-10-18 05:30 cproensa Status acknowledged => assigned
2016-10-18 05:30 cproensa Note Added: 0054261
2016-11-20 15:59 cproensa Relationship added child of 0021935
2017-01-14 17:41 cproensa Note Added: 0055128
2017-01-14 17:59 cproensa Status assigned => resolved
2017-01-14 17:59 cproensa Resolution open => fixed
2017-01-14 17:59 cproensa Note Added: 0055130
2017-01-14 18:00 cproensa Fixed in Version => 2.1.0
2017-01-14 18:00 cproensa Target Version => 2.1.0
2017-01-31 04:02 vboctor Status resolved => closed