View Issue Details

IDProjectCategoryView StatusLast Update
0007632mantisbtinstallationpublic2014-12-08 00:34
ReporterrobocoderAssigned Todregad 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.0.6 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0007632: Create operational database user at time of installation
Description

Changes:

  • install.php: ServerInfo() needs to be connected, so move call earlier;
    null check before version_compare (segfault);
    add code to create operational user (if different from admin) with privileges;
    change fopen flag from 'x' (introduced in php 4.3.2) to 'w';
    misc changes for consistency and conformance to coding guidelines

  • schema.php: change XS to X (to upgrade to ADODB 4.93a)

Diffs against mantis 1.0.6 attached.

Additional Information

While I stubbed the code for Oracle, MSSQL, and PostgreSQL, I only tested this on MySQL.

TagsNo tags attached.

Relationships

related to 0007635 closeddregad Install script can't get MySQL version if database user doesn't exist or doesn't have access privileges 

Activities

2006-12-07 11:38

 

mantis.diffs (16,169 bytes)
dregad

dregad

2013-10-16 11:08

developer   ~0038279

Due to the amount of changes between Mantis 1.0 and current release, as well as underlying ADOdb library, it is not possible to apply this patch.

Many improvements have been made in the master branch on this, so if the problem is not resolved there, please feel free to reopen the issue and submit an updated patch.

Thank you.

Related Changesets

MantisBT: master e23da69a

2013-10-17 11:46:56

dregad

Details Diff
Various fixes and improvements to the installer

Fixes 0009701 0016357 0007632 (and potentially others as well)
mod - admin/install.php Diff File
add - javascript/install.js Diff File

Issue History

Date Modified Username Field Change
2006-12-07 11:38 robocoder New Issue
2006-12-07 11:38 robocoder File Added: mantis.diffs
2008-05-03 19:24 grangeway Status new => assigned
2008-05-03 19:24 grangeway Assigned To => grangeway
2013-10-16 11:08 dregad Note Added: 0038279
2013-10-16 11:08 dregad Status assigned => resolved
2013-10-16 11:08 dregad Resolution open => no change required
2013-10-16 11:08 dregad Assigned To grangeway => dregad
2013-10-16 11:08 dregad Relationship added related to 0007635
2013-10-17 13:09 dregad Changeset attached => MantisBT master e23da69a
2013-10-17 13:09 dregad Resolution no change required => fixed
2013-10-17 13:09 dregad Fixed in Version => 1.3.0-beta.1
2014-01-24 11:06 atrol Target Version => 1.3.0-beta.1
2014-12-08 00:34 vboctor Status resolved => closed