View Issue Details

IDProjectCategoryView StatusLast Update
0007214mantisbtprintingpublic2014-01-20 16:38
ReportertandlerAssigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status newResolutionreopened 
Product Version1.0.3 
Target VersionFixed in Version 
Summary0007214: Export issues from mantis to a freemind mindmap
Description

I've written a script to export the issue list as a freemind mindmap (.mm), see http://freemind.sourceforge.net/

The idea is to be able to easily and quickly browse many issues with one offline data set and use the nice freemind UI. This is e.g. very helpful to get an overview of new issues, and one can take advantage of the nice structuring possibilities of freemind.

I would be glad to hear your comments / feedback!

Tagspatch

Relationships

related to 0008610 acknowledged Display in line an attached freemind map 

Activities

2006-06-21 04:15

 

mm_export.php 2006-06-21.gz (2,487 bytes)
tandler

tandler

2006-06-21 04:19

reporter   ~0013001

PS: Usage hint: just put this script in the mantis directory and call the URL directly (or link it from the view issues page).

PPS: There seems to be a problem if the current filter lists many issues (>100). Then, the file is not generated. Could this be a timeout problem? Could anyone please provide some help for me here?

tandler

tandler

2006-06-21 04:20

reporter   ~0013002

PPPS: freemind uses a XML based file format (see also 0004024)

tandler

tandler

2006-06-21 04:25

reporter   ~0013003

PPPPS: It would be nice to integrate this with the freemind flash browser http://www.efectokiwano.net/mm/
This would allow to easily browse issues directly in the browser, with rich information and excellent speed.

tandler

tandler

2006-06-23 08:10

reporter   ~0013023

The problem that the export fails with many issues (0007214:0013001) comes from a memory limit for the php engine at our mantis installation. It seems that the script needs a lot of memory, I guess for collecting all the information on relationships. If anybody has some hints on how this can be improved, I'd be glad.

2006-06-28 07:53

 

tandler

tandler

2006-06-28 08:00

reporter   ~0013043

The freemind flash browser can retreive the mindmap directly from the php script, so you can nicely generate a mindmap view of you current issue list (see screenshot).

BTW: Using this visualization I quickly noticed that there's really a difference between sub-issues (children) and dependent issues (that are not necessarily sub-issues), see 0004639. Only sub-issues should be displayed as sub-nodes.

2006-07-06 07:48

 

mm_export 2006-07-06.zip (3,677 bytes)
tandler

tandler

2006-07-06 07:54

reporter   ~0013076

I've added a small update 'mm_export 2006-07-06.zip'.

  • mindmap now also includes reporter, handler, project, category
  • mm_export.php has a type_page parameter that should be set to "flash" if used directly from the freemind flash browser
  • mindmap.html to include the freemind flash browser in mantis

to include it in mantis:

  • unzip the architve to the mantis directory
  • add to view_all_inc.php after the 'csv_export.php' line some links, e.g.:

echo ' ';
print_bracket_link( 'mm_export.php', 'Freemind Export' );
echo ' ';
print_bracket_link( 'mindmap.html', 'Mindmap' );

vboctor

vboctor

2006-08-06 03:38

manager   ~0013200

Following are some comments:

  • You didn't include the swf flash file. Is this something that we can distribute with Mantis?
  • Always follow the "if" with a space.
  • All "if" statements must have { } even if they have one statement as their body.
  • Put an empty line before / after an IF block.
  • Rename mm* functions to mindmap* and move them to core/mindmap_api.php
  • Rename script to mindmap_export.php.
  • Shouldn't clicking on mm_export.php export the file rather than displaying it in the browser?
deboutv

deboutv

2006-08-07 04:13

reporter   ~0013206

There are missing file to display the mindmaps.html file, no?

  • flashobject.js
tandler

tandler

2006-08-07 04:46

reporter   ~0013208

Thanks for your comments! I'll make the suggested code style changes as soon as I have some time.

I didn't include the freemind flash browser in the gz I uploaded here. I looked at the website (http://www.efectokiwano.net/mm/) but I didn't found any hint about the license for the browser. I'll try to figure this out.

Regarding the file / function names: There any /many/ different mind map applications, so i decided to use the name of the freemind file extension (.mm), to distinguish it from MinManager '.mmap' etc. So I'd vote for keeping "mm". Ok?

The mm_export.mm should export the file directly. That's what it does on my machine here, at least. Doesn't it work for you?

player

player

2006-08-07 05:39

reporter   ~0013210

Last edited: 2006-08-07 05:40

It seems that browser is GNU GPL licenced
http://freemind.sourceforge.net/wiki/index.php/Flash_browser

player

player

2006-08-07 06:01

reporter   ~0013211

also I have a problem with IE (with Opera all works fine). After a promt to download a file (namely mm_export.php not mindmap) is appeared an error about site missing.

vboctor

vboctor

2006-09-15 02:06

manager   ~0013389

Would it be possible to re-add the attachments.

2006-09-15 03:02

 

mm_export 2006-07-06-new.zip (3,677 bytes)

2006-09-15 03:02

 

mm_export.php 2006-06-21-new.gz (2,487 bytes)
deboutv

deboutv

2006-09-15 03:04

reporter   ~0013391

Last edited: 2006-09-15 03:12

I have uploaded the original files that I have downloaded.

cristianovicente

cristianovicente

2007-01-30 18:57

reporter   ~0013985

Hi tandler, I have noticed this same problem when trying to export the image to a JPEG file using "big" files (around 93 kB).

I have to be honest: I really didn't get what you have been trying to do. Do you have any suggestion for me, to export as a JPEG file?

Cristiano.
Brazil

cristianovicente

cristianovicente

2007-01-31 09:04

reporter   ~0013987

Hi Tandler, could you remove the file that I attached yesterday?
Thanks

tandler

tandler

2007-11-28 03:10

reporter   ~0016315

Hi cristianovicente, what problem did you have? I didn't get it, sorry. I don't have the permission to remove attached files, maybe some admin can help here? --Peter

2008-01-19 15:39

 

freemind+xml-V0.2.zip (8,388 bytes)
tandler

tandler

2008-01-19 15:44

reporter   ~0016724

Last edited: 2008-01-19 15:46

Hi, it took a while ... but now I uploaded a diff with the changes requested by Victor (0007214:0013200). I also included the freemind flash browser. I'm happy to hear any comments. --Peter
PS: V0.2.1 also contains the swf and in addition to the diff also all modified files (view_all_inc.php from mantis 1.1.1)

2008-01-19 15:45

 

freemind+xml-V0.2.1.zip (57,939 bytes)
vboctor

vboctor

2008-01-20 21:44

manager   ~0016739

I've tried it on 1.2.x and it required some changes since the categories are now indexed by ids. Other than that it worked well.

  • Is the xml export related in any way to mindmap or is this a different feature?

  • xml_get_default_filename() - remove xml_api and add this is a helper_get_default_filename( $p_ext ) function in helper_api.php. This function should take in an extension and comes up with a defaulted file name.

  • The export script needs to urlencode the filename. See csv_export.php for an example.

  • Would be nice if we can put all flash viewer related files in one folder, rather than dump them in the root Mantis folder.

  • Would be very handy if you can provide a 1.1.x and 1.2.x version of your patch (for developers 1.2.x is more important), so up to you.

  • Use "@@@" as markers for TODOs rather than #### ToDo

  • Use phpDoc format for function documentation, see http://en.wikipedia.org/wiki/PHPDoc

  • For the contributed files to be included in Mantis core, they will have to use the standard Mantis header (see 1.2.x branch).
tandler

tandler

2008-02-16 16:52

reporter   ~0017072

xml export is not related at all, I just was too lazy to pack two zips, sorry! maybe I split this again.
victor, what is the planned deadline for 1.2 contributions ...?

vboctor

vboctor

2008-02-16 19:15

manager   ~0017080

Our plan is to get 1.2.0a1 out sometime in March. So ideally we should get the major features in asap. No strict deadlines in place yet.

2008-02-27 12:34

 

freemind+xml-V0.3 (mantis-1.2-svn-5021).zip (47,405 bytes)
tandler

tandler

2008-02-27 12:38

reporter   ~0017209

Hi Victor, I just uploaded V0.3 of the freemind and xml features which now work with svn (rev. 5021). I think I followed all your recommendations. Anything else? -- Peter

vboctor

vboctor

2008-03-15 02:35

manager   ~0017360

Fixed in svn:5118
http://mantisbt.svn.sourceforge.net/mantisbt/?rev=5118&view=rev

I've gone through your patch and did the following:

  1. Excluded the XML export. There is another issue in this bug tracker for exporting XML. This work should be integrated with that effort.

  2. Some misc. updates to match standards (although the patch was already in good shape from this perspective).

  3. Replaced hard-coded English strings with localized strings.

  4. Renamed some files and change the freemind browser viewer page to be an html page.

  5. Added documentation to Docbook. More to come later.

  6. Added a configuration option to enable / disable this feature.

  7. Removed the "Issues" node since it wasn't adding value.
tandler

tandler

2008-03-17 04:26

reporter   ~0017384

Thanks for checking in!! I had added the "Issues" node to have a nices layout, but I guess that's a matter of personal preference.

tandler

tandler

2010-11-02 17:54

reporter   ~0027226

I've updated the freemind export & browser to use the new plugin system since it seems to have been excluded from he core system: http://blog.teambits.de/2010/11/02/mantis-plugin-freemind-export-and-browser/

Issue History

Date Modified Username Field Change
2006-06-21 04:15 tandler New Issue
2006-06-21 04:15 tandler File Added: mm_export.php 2006-06-21.gz
2006-06-21 04:19 tandler Note Added: 0013001
2006-06-21 04:20 tandler Note Added: 0013002
2006-06-21 04:25 tandler Note Added: 0013003
2006-06-23 08:10 tandler Note Added: 0013023
2006-06-28 07:53 tandler File Added: Mantis-Freemind-Flashbrowser screenshot 80%.png
2006-06-28 08:00 tandler Note Added: 0013043
2006-07-06 07:48 tandler File Added: mm_export 2006-07-06.zip
2006-07-06 07:54 tandler Note Added: 0013076
2006-08-06 03:38 vboctor Note Added: 0013200
2006-08-07 04:13 deboutv Note Added: 0013206
2006-08-07 04:46 tandler Note Added: 0013208
2006-08-07 05:39 player Note Added: 0013210
2006-08-07 05:40 player Note Edited: 0013210
2006-08-07 06:01 player Note Added: 0013211
2006-09-15 02:06 vboctor Note Added: 0013389
2006-09-15 03:02 deboutv File Added: mm_export 2006-07-06-new.zip
2006-09-15 03:02 deboutv File Added: mm_export.php 2006-06-21-new.gz
2006-09-15 03:04 deboutv Note Added: 0013391
2006-09-15 03:12 deboutv Note Edited: 0013391
2007-01-30 18:54 cristianovicente File Added: Completo delimitar problema pesquisa.mm
2007-01-30 18:57 cristianovicente Note Added: 0013985
2007-01-31 09:04 cristianovicente Note Added: 0013987
2007-02-01 01:00 vboctor File Deleted: Completo delimitar problema pesquisa.mm
2007-11-27 10:57 vboctor Relationship added related to 0008610
2007-11-28 03:10 tandler Note Added: 0016315
2008-01-19 15:39 tandler File Added: freemind+xml-V0.2.zip
2008-01-19 15:44 tandler Note Added: 0016724
2008-01-19 15:45 tandler File Added: freemind+xml-V0.2.1.zip
2008-01-19 15:46 tandler Note Edited: 0016724
2008-01-20 21:44 vboctor Note Added: 0016739
2008-02-16 16:52 tandler Note Added: 0017072
2008-02-16 19:15 vboctor Note Added: 0017080
2008-02-27 12:34 tandler File Added: freemind+xml-V0.3 (mantis-1.2-svn-5021).zip
2008-02-27 12:38 tandler Note Added: 0017209
2008-03-15 02:35 vboctor Status new => resolved
2008-03-15 02:35 vboctor Fixed in Version => 1.2.0
2008-03-15 02:35 vboctor Resolution open => fixed
2008-03-15 02:35 vboctor Assigned To => vboctor
2008-03-15 02:35 vboctor Note Added: 0017360
2008-03-17 04:26 tandler Note Added: 0017384
2008-04-19 04:10 vboctor Status resolved => closed
2010-11-02 17:54 tandler Note Added: 0027226
2010-11-02 17:54 tandler Status closed => feedback
2010-11-02 17:54 tandler Resolution fixed => reopened
2011-01-07 18:17 vboctor Tag Attached: patch
2011-01-07 18:17 vboctor Assigned To vboctor =>
2011-01-07 18:17 vboctor Status feedback => new
2014-01-20 16:38 atrol Fixed in Version 1.2.0a1 =>