MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007122mantisbtbugtrackerpublic2006-05-22 06:102012-09-23 09:56
Reporterkonstbel 
Assigned Todregad 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformOSOS Version
Product Version1.0.3 
Target VersionFixed in Version 
Summary0007122: Problems with changing "project" on Report Issue page in FireFox
DescriptionWhen I enter the Report Issue page, I have the problem with changing "Project" in the drop-down list. When I select another project, Mantiss refreshes the page and returns the project to the previous state.
Sometimes it works, but mainly not.
The problem occures when using Firefox as a browser.
Tagserror, reporting
Attached Files

- Relationships
related to 0003574closeddregad Not able to switch between projects 

-  Notes
User avatar (0013804)
sebastien (reporter)
2006-12-11 21:48

I have the same issue.
I tried Mantis 1.0.6, Mantis 1.1.0a1 and Mantis 1.1.0a2.
Without any success.
User avatar (0016394)
omeslo (reporter)
2007-12-07 08:23

Same here, I'm surprised this issue hasn't come up yet, since it has been present at least since 1.0.6.
This problem only seems to occur on windows based servers, and not on my linux server.
What actually happens: When selecting a project, mantis is always showing the project with id=1, no matter what (sub)project the user actually selected. If this id is not present in the project table, it defaults to 'all projects'

imho, the severity should be scaled up a bit, as this issue is blocking for firefox users using mantis on a windows server.
User avatar (0016397)
konstbel (reporter)
2007-12-07 09:29

What version of Firefox are you using?
2+ works well for me now (sorry for not reporting that)
User avatar (0016400)
omeslo (reporter)
2007-12-07 12:04

(sorry too)
2.0.0.11
User avatar (0016423)
konstbel (reporter)
2007-12-10 04:12

Hmm, that is strange. I also have 2.0.0.11.
I think, this is a configuration problem, may be you disabled JavaScript or something else important for Mantis.
I have reported this issue, but now I have no problem with Firefox 2.0.0.11 and Mantis 1.0.7
User avatar (0016425)
konstbel (reporter)
2007-12-10 04:22

By the way, I have noticed, that if you work with Mantis from two windows of Firefox or Internet Explorer, the changes in filters in one window influence the another. I'm not sure if this a bug or a feature :-) but sometimes this is inconvenient.
Moreover, sometimes (very rare) I observed that filter settings of one user change the display of another, when two users _simultaneously_ posts their changes to the database.
User avatar (0017510)
tiagomatos (reporter)
2008-03-31 15:07

Hi!

I had the same problem...while using any browser with a proxy!

Browsers were caching the page bug_report[advanced].php... and only by hitting refresh the right project ID was selected.

I opted for using the solution from http://uk3.php.net/header [^]

PHP scripts often generate dynamic content that must not be cached by the client browser or any proxy caches between the server and the client browser. Many proxies and clients can be forced to disable caching with:
<?php
header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT"); // Date in the past
?>

Hope it helps!
User avatar (0017524)
thE_iNviNciblE (reporter)
2008-04-01 15:34

i can confirm this bug... but since update to mantis 1.1.1 it's quite ok... with the application error message...
User avatar (0017663)
vipart (reporter)
2008-04-23 05:54

I can confirm this bug in Mantis 1.1.1 on Unix server (Ubuntu). It doesn't depend on browser or Web server. It is because of proxy cache.
User avatar (0029945)
Dieter Soergel (reporter)
2011-10-12 03:43

We encounter this behaviour always after installing a new version of Mantis.
Currently we have FireFox 7.0.x installed on several machines.
Clearing the browser cache did not help.
Our workaround is, we remove the cookies. After that Mantis works as expected.
User avatar (0032835)
dregad (developer)
2012-09-13 10:22

Unable to reproduce this on 1.2.11

- Issue History
Date Modified Username Field Change
2006-05-22 06:10 konstbel New Issue
2006-12-11 21:48 sebastien Note Added: 0013804
2007-12-07 08:23 omeslo Note Added: 0016394
2007-12-07 09:29 konstbel Note Added: 0016397
2007-12-07 12:04 omeslo Note Added: 0016400
2007-12-10 04:12 konstbel Note Added: 0016423
2007-12-10 04:12 konstbel Tag Attached: reporting
2007-12-10 04:22 konstbel Note Added: 0016425
2008-03-31 15:07 tiagomatos Note Added: 0017510
2008-04-01 15:32 thE_iNviNciblE Tag Attached: error
2008-04-01 15:34 thE_iNviNciblE Note Added: 0017524
2008-04-23 05:54 vipart Note Added: 0017663
2011-10-12 03:43 Dieter Soergel Note Added: 0029945
2012-09-13 10:21 dregad Relationship added related to 0003574
2012-09-13 10:22 dregad Note Added: 0032835
2012-09-13 10:22 dregad Status new => resolved
2012-09-13 10:22 dregad Resolution open => unable to reproduce
2012-09-13 10:22 dregad Assigned To => dregad
2012-09-23 09:56 atrol Status resolved => closed


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.0913 seconds.
memory usage: 3,068 KB
Powered by Mantis Bugtracker