View Issue Details

IDProjectCategoryView StatusLast Update
0006823mantisbtfilterspublic2017-04-16 14:49
ReporterMFWSchmidtAssigned Tocommunity 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.0.0 
Target Version2.1.0Fixed in Version2.1.0 
Summary0006823: Date filter should work with "last update", too
Description

We are missing a filter which shows all issues updated within a specified time frame.
It would be very helpful if the filter "Use Date Filters" could be applied either to "Date Submitted" or "LastUpdate" by selecting a radio button.

TagsNo tags attached.

Relationships

has duplicate 0017129 closedatrol How "use date filters" but on the last modification date 
has duplicate 0017629 closedatrol comment faire le même filtre sur la date de mise à jour? 
related to 0020548 closedatrol Filter : Does the "Changed(hrs)" field works ? 
related to 0021688 closedatrol View All Bugs - Use "Highlight changed" in filter table to filter bugs 
related to 0021044 closedcproensa my view page, $t_hide_status_default consitency 
related to 0022021 new Support relative date filtering 
related to 0011756 closedcproensa On filter method it doesn't show the filter by ? 
child of 0021935 closedcproensa Filter api refactoring, manage stored filters 

Activities

mluker

mluker

2007-12-19 05:10

reporter   ~0016466

As the only date in the View Issues page is the "last updated" date, I had assumed the filter applied to "last updated" and I was getting very frustrated!

garethrandall

garethrandall

2007-12-20 09:50

reporter   ~0016476

Rather than a radio button, why not allow both "Date Submitted" and "Last Update" to be filtered independently? I.e. create filters for both.

vboctor

vboctor

2007-12-20 12:18

manager   ~0016484

I acknowledged this issue. Let me know if anyone wants to contribute an implementation for this one.

eunice

eunice

2009-03-12 08:18

reporter   ~0021035

We need to filter report issue date and resolved date, because we need to know every day : how much report issues and resolved defect were...I just use version v1.1.6, I found this problem....I just create custom field: date, then set : ceatedate, but I dont know how to set : date can get current date??

Could you help Me...Thank you very much

Mr.Bricodage

Mr.Bricodage

2016-09-12 12:26

reporter   ~0054004

I'll provide a PR for this ticket. Should 0006823:0021035 be ignored?
Only submitted date (already implemented) and last updated date, or resolution date should be filtered too?

Mr.Bricodage

Mr.Bricodage

2016-09-12 15:51

reporter   ~0054011

Could you please confirm that I well understood acknowledged solution?
Several attachments to illustrate my comprehension (one checkbox for date submitted, one checkbox for last update date, can be both checked).

I ignored 0006823:0021035 because I'm pretty sure that note content is no about current issue.

Mr.Bricodage

Mr.Bricodage

2016-09-12 15:52

reporter  

CurrentBehavour.PNG (3,889 bytes)
CurrentBehavour.PNG (3,889 bytes)
Mr.Bricodage

Mr.Bricodage

2016-09-12 15:53

reporter  

Proposal.PNG (6,811 bytes)
Proposal.PNG (6,811 bytes)
Mr.Bricodage

Mr.Bricodage

2016-09-12 15:53

reporter  

DateSubmittedChecked.PNG (7,063 bytes)
DateSubmittedChecked.PNG (7,063 bytes)
Mr.Bricodage

Mr.Bricodage

2016-09-12 15:53

reporter  

LastUpdateChecked.PNG (7,102 bytes)
LastUpdateChecked.PNG (7,102 bytes)
Mr.Bricodage

Mr.Bricodage

2016-09-12 15:53

reporter  

BothChecked.PNG (6,815 bytes)
BothChecked.PNG (6,815 bytes)
atrol

atrol

2016-09-12 16:55

developer   ~0054013

Could you please confirm that I well understood acknowledged solution?
I think you did.

Mr.Bricodage

Mr.Bricodage

2016-09-21 17:57

reporter   ~0054055

PR : https://github.com/mantisbt/mantisbt/pull/897

cproensa

cproensa

2016-10-28 07:04

developer   ~0054351

included in PR 862

Issue History

Date Modified Username Field Change
2006-03-09 07:53 MFWSchmidt New Issue
2007-12-19 05:10 mluker Note Added: 0016466
2007-12-20 09:50 garethrandall Note Added: 0016476
2007-12-20 12:18 vboctor Note Added: 0016484
2007-12-20 12:18 vboctor Status new => acknowledged
2009-03-12 08:18 eunice Note Added: 0021035
2014-03-25 12:37 atrol Relationship added has duplicate 0017129
2014-09-02 13:49 atrol Relationship added has duplicate 0017629
2016-01-28 11:50 atrol Relationship added has duplicate 0020548
2016-09-12 12:26 Mr.Bricodage Note Added: 0054004
2016-09-12 12:56 atrol Relationship added related to 0021688
2016-09-12 15:51 Mr.Bricodage Note Added: 0054011
2016-09-12 15:52 Mr.Bricodage File Added: CurrentBehavour.PNG
2016-09-12 15:53 Mr.Bricodage File Added: Proposal.PNG
2016-09-12 15:53 Mr.Bricodage File Added: DateSubmittedChecked.PNG
2016-09-12 15:53 Mr.Bricodage File Added: LastUpdateChecked.PNG
2016-09-12 15:53 Mr.Bricodage File Added: BothChecked.PNG
2016-09-12 16:55 atrol Note Added: 0054013
2016-09-21 17:57 Mr.Bricodage Note Added: 0054055
2016-10-19 12:16 cproensa Relationship added related to 0021044
2016-10-19 12:34 cproensa Relationship replaced related to 0020548
2016-10-28 07:04 cproensa Assigned To => community
2016-10-28 07:04 cproensa Status acknowledged => assigned
2016-10-28 07:04 cproensa Note Added: 0054351
2016-11-20 15:29 cproensa Relationship added child of 0021827
2016-12-07 02:25 vboctor Relationship added related to 0022021
2017-01-14 17:19 cproensa Status assigned => resolved
2017-01-14 17:19 cproensa Resolution open => fixed
2017-01-14 17:19 cproensa Fixed in Version => 2.1.0
2017-01-14 17:19 cproensa Target Version => 2.1.0
2017-01-14 18:02 cproensa Relationship added child of 0021935
2017-01-14 18:03 cproensa Relationship deleted child of 0021827
2017-01-31 04:02 vboctor Status resolved => closed
2017-04-16 14:49 cproensa Relationship added related to 0011756