View Issue Details

IDProjectCategoryView StatusLast Update
0006178mantisbtreportspublic2014-12-08 00:34
ReporterjgueunieAssigned Tograngeway 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSwindows 2000OS Versionsp4
Product Version1.0.0rc1 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0006178: relationship graph is empty
Description

Mantis display an empty relation graph :
There is no image generated by wingraphiz.
There is no error message

It works on a nt4 server with easyphp 1.7 and the same version of wingraphviz

On the new server with win2K and easyphp 1.8 it doesn't work (I made the test on 3 pcs.)

Steps To Reproduce

Mantis setup
easyphp1.8
windows2000
wingraphviz 1.0.24
create bugs with relations ( child...)
display relation grpah

TagsNo tags attached.

Relationships

related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 

Activities

jgueunie

jgueunie

2005-08-24 05:31

reporter   ~0011277

The wingraphviz COM object refuse to load with php 4.3.10.

the sript exit because the $t_graphviz is null after loading wingraphviz

graphviz_api.php line 292 :
$t_graphviz = new COM( $this->graphviz_com_module );

Check if we managed to instantiate the COM object.

if ( is_null( $t_graphviz ) ) {

We can't display any message or trigger an error on

failure, since we may have already sent a Content-type

header potentially incompatible with the any html output.

return;
}

There is no more after updating to php 4.4.0

mkornatzki

mkornatzki

2007-08-05 13:33

reporter   ~0015353

the problem with an empty (none image) still exist in version 1.1.0a4 if there is no relation between issues.

the following changes correct this behaviour:
edit core/graphviz_api.php

before:
if ( count( $this->nodes ) <= 1 )
return;

after:
#even if no relationship exists the graphic is now not corrupt and will show the issue itself
#if ( count( $this->nodes ) <= 1 )

return;

grangeway

grangeway

2010-08-14 14:38

reporter   ~0026316

Fixed by removing support for wingraphviz - just use the dot/neato exe's - see snapshot/commit @ http://git.mantisforge.org/w/mantisbt.git?a=commit;h=629a6760104e5f742ad54b5a765be78d4c42eef3

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036497

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Issue History

Date Modified Username Field Change
2005-08-24 03:11 jgueunie New Issue
2005-08-24 05:31 jgueunie Note Added: 0011277
2007-08-05 13:33 mkornatzki Note Added: 0015353
2010-08-14 14:38 grangeway Note Added: 0026316
2010-08-14 14:38 grangeway Status new => resolved
2010-08-14 14:38 grangeway Fixed in Version => 1.3.0-beta.1
2010-08-14 14:38 grangeway Resolution open => fixed
2010-08-14 14:38 grangeway Assigned To => grangeway
2013-04-05 17:57 grangeway Status resolved => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036497
2013-04-05 18:05 grangeway Relationship added related to 0015721
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2013-04-27 17:04 atrol Assigned To grangeway =>
2013-04-27 17:04 atrol Status resolved => new
2013-04-27 17:04 atrol Resolution fixed => open
2013-04-27 17:04 atrol Fixed in Version 1.3.0-beta.1 =>
2013-04-27 17:18 atrol Status new => resolved
2013-04-27 17:18 atrol Fixed in Version => 1.3.0-beta.1
2013-04-27 17:18 atrol Resolution open => fixed
2013-04-27 17:18 atrol Assigned To => grangeway
2013-04-27 17:39 atrol Target Version => 1.3.0-beta.1
2014-09-23 18:04 grangeway Tag Detached: 2.0.x check
2014-11-25 11:04 vboctor Category graphs => reports
2014-12-08 00:34 vboctor Status resolved => closed