MantisBT

View Issue Details Jump to Notes ] Wiki ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005571mantisbtadministrationpublic2005-05-05 17:292007-05-08 03:43
Reporterjjtest 
Assigned Tovboctor 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005571: Please clarify the difference between $g_project_view_state_enum_string and $g_view_state_enum_string
DescriptionWe use private projects by default, so I went into config_inc.php and found:

    $g_project_view_state_enum_string = '10:public,50:private';
    $g_view_state_enum_string = '10:public,50:private';

I expected that when I reversed the value of $g_project_view_state_enum_string to be '50:private,10:public' I would get the desired result, but I did not. So I changed $g_view_state_enum_string

and it worked the way I wanted it to...reversing the values in the View Status drop down on the Create Project page...

My question is, what are each of these supposed to do? What does $g_project_view_state_enum_string do?
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0006919new Mixed up in code between project_view_status and view_status 

-  Notes
User avatar (0012472)
lifo2 (reporter)
2006-04-06 08:00

Oups I posted something very close : bug 0006919
In fact, this is certainly a mistake, as the g_project_view_state_enum_string var is not used at all.

- Issue History
Date Modified Username Field Change
2005-05-05 17:29 jjtest New Issue
2006-04-06 08:00 lifo2 Note Added: 0012472
2006-04-10 08:13 vboctor Relationship added related to 0006919
2007-02-20 09:20 vboctor Relationship replaced duplicate of 0006919
2007-02-20 09:21 vboctor Duplicate ID 0 => 6919
2007-02-20 09:21 vboctor Status new => resolved
2007-02-20 09:21 vboctor Resolution open => duplicate
2007-02-20 09:21 vboctor Assigned To => vboctor
2007-05-08 03:43 vboctor Status resolved => closed


MantisBT 1.2.17 [^]
Copyright © 2000 - 2014 MantisBT Team
Time: 0.1088 seconds.
memory usage: 3,026 KB
Powered by Mantis Bugtracker