View Issue Details

IDProjectCategoryView StatusLast Update
0003320mantisbtfeaturepublic2008-07-24 16:50
ReporterlherreraAssigned Tograngeway 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0003320: Email ability
Description

A (IMHO) very useful feature is the ability to receive bugs using email, and reply from the Mantis interface.

Additional Information

Hi, my name is Leonardo Herrera. I've been toying around with Mantis the last few days, and now I have a Perl script that checks a POP3 email account and enter bugs to Mantis. I'm using a series of hacks to accomplish this (including custom fields,) but I prefer to know if someone volunteers to add this to Mantis main distribution (that could be me :-).

TagsNo tags attached.

Relationships

duplicate of 0004286 closedSL-Gundam Plugin - EmailReporting Solution for reporting via E-Mail 
related to 0006658 closedryandesign mantisbt Replying to a mantis ticket should add it as a note to that issue 
related to 0001568 closedgrangeway mantisbt Abillity to send mail to mantis adding bugs and bugnotes 
related to 0006619 closedgrangeway mantisbt Report by email concept 
related to 0007086 closedSL-Gundam Plugin - EmailReporting Mantis email via IMAP + folders 

Activities

2003-08-27 19:44

 

mantis_pop.pl (6,384 bytes)
Wanderer

Wanderer

2003-08-29 21:33

developer   ~0004586

I could't recobsruct bug-message structure, can you post exmple here?

lherrera

lherrera

2003-08-29 23:16

reporter   ~0004587

Sorry, don't understand what you mean. Can you be a little more specific?

Wanderer

Wanderer

2003-08-30 00:23

developer   ~0004588

How I must format message for appending into Manis with your script
I saw notes about subject, but how I must write body?
And my apologies for stupid misprints in first note - I must read, what I wrote

lherrera

lherrera

2003-08-30 02:37

reporter   ~0004591

Oh! it's not necessary. As I said before, this is just a quick hack that gets some things done. It uses the body of the message as "Description." I guess you can just add some extra parsing to the message body... in my setup I have lots of wacky and neat stuff (for example, I can answer emails within Mantis, and receive replies) but I'm afraid that it's all in "ugly hacky" state

See a screenshot I'm specially proud of :-). Note that I merged "bugnotes" and bug history in a more tale-writing oriented interface.

2003-08-30 02:37

 

bragging.png (78,983 bytes)
bragging.png (78,983 bytes)
lherrera

lherrera

2003-08-30 02:38

reporter   ~0004592

Last edited: 2003-08-30 02:40

Oops, sorry for the long image.. didn't know it was going to display inline :O

(Maybe some admin can delete this image... mental note, upload big embarrasing stuff compressed)

edited on: 08-30-03 02:40

vboctor

vboctor

2004-03-14 17:02

manager   ~0005205

lherrera, don't worry about the image. This installation is setup so that it displays pictures inline if they are smaller than 100K.

It would be nice if we can get this patch in PHP? This will also make it simpler, since it re-use the APIs of Mantis. We can also support a free text format which copies everything as text, or a structured format (eg: XML) which is parsed and used to fill the different fields of the bug.

leus

leus

2004-03-15 07:23

reporter   ~0005209

(Hey, I just realized that I have two users, lherrera and leus)

I don't think porting this feature to PHP should be too easy. Dealing with encoding, MIME types and the like was a pain in the neck, even using everything available at CPAN. Alas, I'm not too familiar with PHP.

2004-03-17 04:53

 

mantis_pop.php.tar (22,016 bytes)
leeguy

leeguy

2004-03-17 04:59

reporter   ~0005221

I've kludged together a version of the script in PHP. It's pretty ugly, but it's a start.
One difference in my implementation is that instead of using one generic "email" reporter, the reporter is discovered via the senders email address.
Also, there is much room for improvement. Right now, it only does one project, fails to check for custom fields and doesn't check for access rights... like I said, it's a start.

vboctor

vboctor

2004-03-17 05:26

manager   ~0005222

That's really good leeguy, thanks a lot for the port. I will have a look at it and respond to this bug. As you said, it doesn't have to be perfect, but it is a start on a demanded feature.

leus

leus

2004-03-17 07:07

reporter   ~0005223

Hey, that's good, leeguy. Seems okay, I'll test it today.

Matt_wc

Matt_wc

2004-09-15 11:28

reporter   ~0007602

This issue seems to be related to 4286 (Solution for reporting via E-Mail)

http://bugs.mantisbt.org/view.php?id=4286

indy

indy

2004-09-18 03:37

reporter   ~0007640

This solution does not provide an interface for mail account configuration, I think. Also, it is only possible to receive mails from registered users.

But the idea to decode MIME message is good.
If it's ok for you, I will integrate it into my patch.
(Link posted by Matt_wc)

Issue History

Date Modified Username Field Change
2003-08-27 19:44 lherrera New Issue
2003-08-27 19:44 lherrera File Added: mantis_pop.pl
2003-08-29 21:33 Wanderer Note Added: 0004586
2003-08-29 23:16 lherrera Note Added: 0004587
2003-08-30 00:23 Wanderer Note Added: 0004588
2003-08-30 02:37 lherrera Note Added: 0004591
2003-08-30 02:37 lherrera File Added: bragging.png
2003-08-30 02:38 lherrera Note Added: 0004592
2003-08-30 02:40 lherrera Note Edited: 0004592
2004-03-14 17:02 vboctor Note Added: 0005205
2004-03-15 07:23 leus Note Added: 0005209
2004-03-17 04:53 leeguy File Added: mantis_pop.php.tar
2004-03-17 04:59 leeguy Note Added: 0005221
2004-03-17 05:26 vboctor Note Added: 0005222
2004-03-17 07:07 leus Note Added: 0005223
2004-09-15 11:28 Matt_wc Note Added: 0007602
2004-09-18 03:37 indy Note Added: 0007640
2004-11-22 06:50 vboctor Relationship added related to 0004286
2006-03-24 06:11 ryandesign Relationship added related to 0006658
2006-03-24 06:15 ryandesign Relationship added related to 0001568
2006-03-24 06:18 ryandesign Relationship added related to 0006619
2008-07-13 11:00 grangeway Relationship replaced duplicate of 0004286
2008-07-13 11:00 grangeway Status @0@ => resolved
2008-07-13 11:00 grangeway Resolution @0@ => duplicate
2008-07-13 11:00 grangeway Assigned To => grangeway
2008-07-24 16:50 vboctor Status @0@ => closed
2009-11-04 03:17 vboctor Relationship added related to 0007086