View Issue Details

IDProjectCategoryView StatusLast Update
0002814mantisbtfeaturepublic2014-12-08 00:34
ReporterreporterAssigned Todaryn 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Versiongit trunk 
Target Version1.3.0-beta.1Fixed in Version1.3.0-beta.1 
Summary0002814: Prefix CSS class names
Description

It would be nice, if CSS class names will be prefixed via definedable string. It could improve Mantis ingrattion ability into larger projects.

Nepto, http://nepto.sk/

TagsNo tags attached.

Relationships

related to 0004227 acknowledged Roadmap 1.0 - Templates 
related to 0015721 closedgrangeway Functionality to consider porting to master-2.0.x 

Activities

vboctor

vboctor

2003-02-27 00:56

manager   ~0003853

The other option is to have all Mantis forms/ui inside a div with class "mantis". This way our styles will look as follows:

div.mantis tr { blah blah }
div.mantis tr.category { blah blah }

... and so on.

I would prefer this option over using a prefix.

giallu

giallu

2007-07-24 04:00

reporter   ~0015203

I checked bugzilla and it adds a "bugzilla" class to the <body> tag, essentially achieving the same purpose.

This is probably the least intrusive modification we could do; Victor, if you agree I will take care of this.

vboctor

vboctor

2007-07-24 11:05

manager   ~0015208

The thing that we have to keep in mind is integrations with CMS systems, for example, PostNuke, etc. In that case the div option would be better than the body option. Although I would have to agree that the body option is better than what we are doing now.

Would it be possible to have the code that generate <body>, generate <body><div class="mantis"> and </body> becomes </div></body>?

giallu

giallu

2007-07-26 03:23

reporter   ~0015223

sure, though I think the former is better because (IIRC) style defined for <body> are inherited by childs while this does not happens with <div>s

I think we will need more input from guys trying such integrations, otherwise we just waste time.

daryn

daryn

2010-09-28 20:37

reporter   ~0026897

This feature has been added in the master branch.

grangeway

grangeway

2013-04-05 17:57

reporter   ~0036478

Marking as 'acknowledged' not resolved/closed to track that change gets ported to master-2.0.x branch

Issue History

Date Modified Username Field Change
2003-02-27 00:56 vboctor Note Added: 0003853
2006-04-17 12:19 grangeway Relationship added related to 0004227
2006-04-18 10:19 vboctor Status new => acknowledged
2007-07-24 04:00 giallu Note Added: 0015203
2007-07-24 11:05 vboctor Note Added: 0015208
2007-07-26 03:23 giallu Note Added: 0015223
2010-09-28 20:37 daryn Note Added: 0026897
2010-09-28 20:37 daryn Status acknowledged => resolved
2010-09-28 20:37 daryn Fixed in Version => 1.3.0-beta.1
2010-09-28 20:37 daryn Resolution open => fixed
2010-09-28 20:37 daryn Assigned To => daryn
2013-04-05 17:57 grangeway Status resolved => acknowledged
2013-04-05 17:57 grangeway Note Added: 0036478
2013-04-05 18:07 grangeway Relationship added related to 0015721
2013-04-06 09:26 dregad Tag Attached: 2.0.x check
2013-04-06 09:26 dregad Status acknowledged => resolved
2013-04-27 17:43 atrol Target Version => 1.3.0-beta.1
2014-09-23 18:04 grangeway Tag Detached: 2.0.x check
2014-12-08 00:34 vboctor Status resolved => closed